summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJurek Bartuszek <jurek@gentoo.org>2007-05-31 19:29:27 +0000
committerJurek Bartuszek <jurek@gentoo.org>2007-05-31 19:29:27 +0000
commitb865765618f1864248745ed45db418f6f962675a (patch)
tree794daa6d4ed7117282a49829b9a0e8cc29d0f57e /dev-lang
parentstable on ppc64 (diff)
downloadgentoo-2-b865765618f1864248745ed45db418f6f962675a.tar.gz
gentoo-2-b865765618f1864248745ed45db418f6f962675a.tar.bz2
gentoo-2-b865765618f1864248745ed45db418f6f962675a.zip
dev-lang/mono: Fixed mono re-emerging bug (#146424)
(Portage version: 2.1.2.7)
Diffstat (limited to 'dev-lang')
-rw-r--r--dev-lang/mono/ChangeLog9
-rw-r--r--dev-lang/mono/mono-1.1.16.1.ebuild9
-rw-r--r--dev-lang/mono/mono-1.2.3.1.ebuild7
-rw-r--r--dev-lang/mono/mono-1.2.4.ebuild7
4 files changed, 23 insertions, 9 deletions
diff --git a/dev-lang/mono/ChangeLog b/dev-lang/mono/ChangeLog
index 917ae17c845f..2bdca58bb093 100644
--- a/dev-lang/mono/ChangeLog
+++ b/dev-lang/mono/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-lang/mono
# Copyright 2002-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/mono/ChangeLog,v 1.113 2007/05/29 19:36:04 jurek Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/mono/ChangeLog,v 1.114 2007/05/31 19:29:27 jurek Exp $
+
+ 31 May 2007; Jurek Bartuszek <jurek@gentoo.org> mono-1.1.16.1.ebuild,
+ mono-1.2.3.1.ebuild, mono-1.2.4.ebuild:
+ Fixed mono re-emerging bug (#146424). Credit goes to Raja R Harinath
+ <rharinath@novell.com> for proposing the solution.
29 May 2007; Jurek Bartuszek <jurek@gentoo.org> mono-1.2.4.ebuild:
Fixed typo (bug #180192)
@@ -45,7 +50,7 @@
-mono-1.1.18-r1.ebuild, -mono-1.2.ebuild, -mono-1.2.1.ebuild:
Long overdue cleaning of mono ebuilds. 1.1.16.1 left for visual basic
- 14 Jan 2007; Olivier Crête <tester@gentoo.org> mono-1.2.2.1.ebuild:
+ 14 Jan 2007; Olivier CrĂŞte <tester@gentoo.org> mono-1.2.2.1.ebuild:
Stable on amd64 per bug #159886
08 Jan 2007; Tobias Scherbaum <dertobi123@gentoo.org> mono-1.2.2.1.ebuild:
diff --git a/dev-lang/mono/mono-1.1.16.1.ebuild b/dev-lang/mono/mono-1.1.16.1.ebuild
index 7f9c9b9f32a5..d38fb8038804 100644
--- a/dev-lang/mono/mono-1.1.16.1.ebuild
+++ b/dev-lang/mono/mono-1.1.16.1.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2006 Gentoo Foundation
+# Copyright 1999-2007 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/mono/mono-1.1.16.1.ebuild,v 1.2 2006/07/12 21:04:30 latexer Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/mono/mono-1.1.16.1.ebuild,v 1.3 2007/05/31 19:29:27 jurek Exp $
inherit eutils mono flag-o-matic multilib autotools
@@ -76,7 +76,10 @@ src_compile() {
# with old buggy classlibs/mcs versions. See bug #118062
touch ${S}/mcs/build/deps/use-monolite
econf ${myconf} || die
- emake -j1 || die "MONO compilation failure"
+
+ # Force LC_ALL=C and the use of internal mcs/mono to prevent issues with
+ # I18N.dll (bug #146424)
+ LC_ALL=C emake -j1 EXTERNAL_MCS=false EXTERNAL_MONO=false || die "compile failed"
}
src_install() {
diff --git a/dev-lang/mono/mono-1.2.3.1.ebuild b/dev-lang/mono/mono-1.2.3.1.ebuild
index 00fceccffc71..2bc2ba48c6ef 100644
--- a/dev-lang/mono/mono-1.2.3.1.ebuild
+++ b/dev-lang/mono/mono-1.2.3.1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2007 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/mono/mono-1.2.3.1.ebuild,v 1.2 2007/04/30 17:23:11 uberlord Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/mono/mono-1.2.3.1.ebuild,v 1.3 2007/05/31 19:29:27 jurek Exp $
inherit eutils flag-o-matic multilib autotools
@@ -87,7 +87,10 @@ src_compile() {
touch ${S}/mcs/build/deps/use-monolite
econf ${myconf} || die "configure failed"
- emake || die "compile failed"
+
+ # Force LC_ALL=C and the use of internal mcs/mono to prevent issues with
+ # I18N.dll (bug #146424)
+ LC_ALL=C emake EXTERNAL_MCS=false EXTERNAL_MONO=false || die "compile failed"
}
src_install() {
diff --git a/dev-lang/mono/mono-1.2.4.ebuild b/dev-lang/mono/mono-1.2.4.ebuild
index 8a98140bf5be..17815c682773 100644
--- a/dev-lang/mono/mono-1.2.4.ebuild
+++ b/dev-lang/mono/mono-1.2.4.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2007 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/mono/mono-1.2.4.ebuild,v 1.3 2007/05/29 19:36:04 jurek Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/mono/mono-1.2.4.ebuild,v 1.4 2007/05/31 19:29:27 jurek Exp $
inherit eutils flag-o-matic multilib autotools
@@ -83,7 +83,10 @@ src_compile() {
touch ${S}/mcs/build/deps/use-monolite
econf ${myconf} || die "configure failed"
- emake -j1 || die "compile failed"
+
+ # Force LC_ALL=C and the use of internal mcs/mono to prevent issues with
+ # I18N.dll (bug #146424)
+ LC_ALL=C emake EXTERNAL_MCS=false EXTERNAL_MONO=false || die "compile failed"
}
src_install() {