summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMikle Kolyada <zlogene@gentoo.org>2015-01-31 15:52:27 +0000
committerMikle Kolyada <zlogene@gentoo.org>2015-01-31 15:52:27 +0000
commita90b34305729fd5eb3e40ecfdfb9c6ff120f9497 (patch)
tree70a10c7ae5b418fe39fb00951740a88c4af7a963 /dev-lang
parentPoint directly to lrelease of used Qt version (bug #532962) (diff)
downloadgentoo-2-a90b34305729fd5eb3e40ecfdfb9c6ff120f9497.tar.gz
gentoo-2-a90b34305729fd5eb3e40ecfdfb9c6ff120f9497.tar.bz2
gentoo-2-a90b34305729fd5eb3e40ecfdfb9c6ff120f9497.zip
Drop old
(Portage version: 2.2.14/cvs/Linux x86_64, signed Manifest commit with key 0xC42EB5D6)
Diffstat (limited to 'dev-lang')
-rw-r--r--dev-lang/rakudo/ChangeLog7
-rw-r--r--dev-lang/rakudo/rakudo-2014.07.ebuild53
-rw-r--r--dev-lang/rakudo/rakudo-2014.08.ebuild51
-rw-r--r--dev-lang/rakudo/rakudo-2014.09-r1.ebuild51
-rw-r--r--dev-lang/rakudo/rakudo-2014.09.ebuild51
-rw-r--r--dev-lang/rakudo/rakudo-2014.10.ebuild51
-rw-r--r--dev-lang/rakudo/rakudo-2014.11-r1.ebuild56
7 files changed, 6 insertions, 314 deletions
diff --git a/dev-lang/rakudo/ChangeLog b/dev-lang/rakudo/ChangeLog
index 522254452f6e..376baec17e72 100644
--- a/dev-lang/rakudo/ChangeLog
+++ b/dev-lang/rakudo/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-lang/rakudo
# Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/rakudo/ChangeLog,v 1.68 2015/01/26 04:13:44 patrick Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/rakudo/ChangeLog,v 1.69 2015/01/31 15:52:27 zlogene Exp $
+
+ 31 Jan 2015; Mikle Kolyada <zlogene@gentoo.org> -rakudo-2014.07.ebuild,
+ -rakudo-2014.08.ebuild, -rakudo-2014.09-r1.ebuild, -rakudo-2014.09.ebuild,
+ -rakudo-2014.10.ebuild, -rakudo-2014.11-r1.ebuild:
+ Drop old
*rakudo-2015.01.1 (26 Jan 2015)
diff --git a/dev-lang/rakudo/rakudo-2014.07.ebuild b/dev-lang/rakudo/rakudo-2014.07.ebuild
deleted file mode 100644
index bcb05e1ff161..000000000000
--- a/dev-lang/rakudo/rakudo-2014.07.ebuild
+++ /dev/null
@@ -1,53 +0,0 @@
-# Copyright 1999-2014 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/rakudo/rakudo-2014.07.ebuild,v 1.1 2014/07/21 06:35:47 patrick Exp $
-
-EAPI=5
-
-PARROT_VERSION="5.9.0"
-# hack for this specific version, don't copy to future releases
-NQP_VERSION="${PV/01/}"
-
-inherit eutils multilib
-
-DESCRIPTION="A Perl 6 implementation built on the Parrot virtual machine"
-HOMEPAGE="http://rakudo.org/"
-SRC_URI="http://rakudo.org/downloads/${PN}/${P}.tar.gz"
-
-LICENSE="Artistic-2"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-IUSE="doc +parrot java moar"
-
-RDEPEND=">=dev-lang/parrot-${PARROT_VERSION}:=[unicode]
- >=dev-lang/nqp-${NQP_VERSION}[parrot?,java?,moar?]"
-DEPEND="${RDEPEND}
- dev-lang/perl"
-
-src_prepare() {
- sed -i "s,\$(DOCDIR)/rakudo$,&-${PVR}," tools/build/Makefile-Parrot.in || die
-}
-
-src_configure() {
- use parrot && myconf+="parrot,"
- use java && myconf+="jvm,"
- use moar && myconf+="moar,"
- perl Configure.pl --backends=${myconf} --prefix=/usr || die
-}
-
-src_test() {
- emake -j1 test || die
-}
-
-src_install() {
- emake -j1 DESTDIR="${ED}" install || die
-
- dodoc CREDITS README.md docs/ChangeLog docs/ROADMAP || die
-
- if use doc; then
- dohtml -A svg docs/architecture.html docs/architecture.svg || die
- dodoc docs/*.pod || die
- docinto announce
- dodoc docs/announce/* || die
- fi
-}
diff --git a/dev-lang/rakudo/rakudo-2014.08.ebuild b/dev-lang/rakudo/rakudo-2014.08.ebuild
deleted file mode 100644
index e25337e4be57..000000000000
--- a/dev-lang/rakudo/rakudo-2014.08.ebuild
+++ /dev/null
@@ -1,51 +0,0 @@
-# Copyright 1999-2014 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/rakudo/rakudo-2014.08.ebuild,v 1.1 2014/08/25 05:52:53 patrick Exp $
-
-EAPI=5
-
-PARROT_VERSION="6.7.0"
-
-inherit eutils multilib
-
-DESCRIPTION="A Perl 6 implementation built on the Parrot virtual machine"
-HOMEPAGE="http://rakudo.org/"
-SRC_URI="http://rakudo.org/downloads/${PN}/${P}.tar.gz"
-
-LICENSE="Artistic-2"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-IUSE="doc +parrot java moar"
-
-RDEPEND=">=dev-lang/parrot-${PARROT_VERSION}:=[unicode]
- >=dev-lang/nqp-${PV}[parrot?,java?,moar?]"
-DEPEND="${RDEPEND}
- dev-lang/perl"
-
-src_prepare() {
- sed -i "s,\$(DOCDIR)/rakudo$,&-${PVR}," tools/build/Makefile-Parrot.in || die
-}
-
-src_configure() {
- use parrot && myconf+="parrot,"
- use java && myconf+="jvm,"
- use moar && myconf+="moar,"
- perl Configure.pl --backends=${myconf} --prefix=/usr || die
-}
-
-src_test() {
- emake -j1 test || die
-}
-
-src_install() {
- emake -j1 DESTDIR="${ED}" install || die
-
- dodoc CREDITS README.md docs/ChangeLog docs/ROADMAP || die
-
- if use doc; then
- dohtml -A svg docs/architecture.html docs/architecture.svg || die
- dodoc docs/*.pod || die
- docinto announce
- dodoc docs/announce/* || die
- fi
-}
diff --git a/dev-lang/rakudo/rakudo-2014.09-r1.ebuild b/dev-lang/rakudo/rakudo-2014.09-r1.ebuild
deleted file mode 100644
index 828c9d14f7f1..000000000000
--- a/dev-lang/rakudo/rakudo-2014.09-r1.ebuild
+++ /dev/null
@@ -1,51 +0,0 @@
-# Copyright 1999-2014 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/rakudo/rakudo-2014.09-r1.ebuild,v 1.1 2014/10/06 01:09:57 patrick Exp $
-
-EAPI=5
-
-PARROT_VERSION="6.7.0"
-
-inherit eutils multilib
-
-DESCRIPTION="A Perl 6 implementation built on the Parrot virtual machine"
-HOMEPAGE="http://rakudo.org/"
-SRC_URI="http://rakudo.org/downloads/${PN}/${P}.tar.gz"
-
-LICENSE="Artistic-2"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-IUSE="doc +parrot java moar"
-
-RDEPEND="parrot? ( >=dev-lang/parrot-${PARROT_VERSION}:=[unicode] )
- >=dev-lang/nqp-${PV}[parrot?,java?,moar?]"
-DEPEND="${RDEPEND}
- dev-lang/perl"
-
-src_prepare() {
- sed -i "s,\$(DOCDIR)/rakudo$,&-${PVR}," tools/build/Makefile-Parrot.in || die
-}
-
-src_configure() {
- use parrot && myconf+="parrot,"
- use java && myconf+="jvm,"
- use moar && myconf+="moar,"
- perl Configure.pl --backends=${myconf} --prefix=/usr || die
-}
-
-src_test() {
- emake -j1 test || die
-}
-
-src_install() {
- emake -j1 DESTDIR="${ED}" install || die
-
- dodoc CREDITS README.md docs/ChangeLog docs/ROADMAP || die
-
- if use doc; then
- dohtml -A svg docs/architecture.html docs/architecture.svg || die
- dodoc docs/*.pod || die
- docinto announce
- dodoc docs/announce/* || die
- fi
-}
diff --git a/dev-lang/rakudo/rakudo-2014.09.ebuild b/dev-lang/rakudo/rakudo-2014.09.ebuild
deleted file mode 100644
index 3eeac71d2bd7..000000000000
--- a/dev-lang/rakudo/rakudo-2014.09.ebuild
+++ /dev/null
@@ -1,51 +0,0 @@
-# Copyright 1999-2014 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/rakudo/rakudo-2014.09.ebuild,v 1.1 2014/09/19 06:41:36 patrick Exp $
-
-EAPI=5
-
-PARROT_VERSION="6.7.0"
-
-inherit eutils multilib
-
-DESCRIPTION="A Perl 6 implementation built on the Parrot virtual machine"
-HOMEPAGE="http://rakudo.org/"
-SRC_URI="http://rakudo.org/downloads/${PN}/${P}.tar.gz"
-
-LICENSE="Artistic-2"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-IUSE="doc +parrot java moar"
-
-RDEPEND=">=dev-lang/parrot-${PARROT_VERSION}:=[unicode]
- >=dev-lang/nqp-${PV}[parrot?,java?,moar?]"
-DEPEND="${RDEPEND}
- dev-lang/perl"
-
-src_prepare() {
- sed -i "s,\$(DOCDIR)/rakudo$,&-${PVR}," tools/build/Makefile-Parrot.in || die
-}
-
-src_configure() {
- use parrot && myconf+="parrot,"
- use java && myconf+="jvm,"
- use moar && myconf+="moar,"
- perl Configure.pl --backends=${myconf} --prefix=/usr || die
-}
-
-src_test() {
- emake -j1 test || die
-}
-
-src_install() {
- emake -j1 DESTDIR="${ED}" install || die
-
- dodoc CREDITS README.md docs/ChangeLog docs/ROADMAP || die
-
- if use doc; then
- dohtml -A svg docs/architecture.html docs/architecture.svg || die
- dodoc docs/*.pod || die
- docinto announce
- dodoc docs/announce/* || die
- fi
-}
diff --git a/dev-lang/rakudo/rakudo-2014.10.ebuild b/dev-lang/rakudo/rakudo-2014.10.ebuild
deleted file mode 100644
index 36ae3187861e..000000000000
--- a/dev-lang/rakudo/rakudo-2014.10.ebuild
+++ /dev/null
@@ -1,51 +0,0 @@
-# Copyright 1999-2014 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/rakudo/rakudo-2014.10.ebuild,v 1.1 2014/10/25 03:16:57 patrick Exp $
-
-EAPI=5
-
-PARROT_VERSION="6.7.0"
-
-inherit eutils multilib
-
-DESCRIPTION="A Perl 6 implementation built on the Parrot virtual machine"
-HOMEPAGE="http://rakudo.org/"
-SRC_URI="http://rakudo.org/downloads/${PN}/${P}.tar.gz"
-
-LICENSE="Artistic-2"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-IUSE="doc +parrot java moar"
-
-RDEPEND="parrot? ( >=dev-lang/parrot-${PARROT_VERSION}:=[unicode] )
- >=dev-lang/nqp-${PV}[parrot?,java?,moar?]"
-DEPEND="${RDEPEND}
- dev-lang/perl"
-
-src_prepare() {
- sed -i "s,\$(DOCDIR)/rakudo$,&-${PVR}," tools/build/Makefile-Parrot.in || die
-}
-
-src_configure() {
- use parrot && myconf+="parrot,"
- use java && myconf+="jvm,"
- use moar && myconf+="moar,"
- perl Configure.pl --backends=${myconf} --prefix=/usr || die
-}
-
-src_test() {
- emake -j1 test || die
-}
-
-src_install() {
- emake -j1 DESTDIR="${ED}" install || die
-
- dodoc CREDITS README.md docs/ChangeLog docs/ROADMAP || die
-
- if use doc; then
- dohtml -A svg docs/architecture.html docs/architecture.svg || die
- dodoc docs/*.pod || die
- docinto announce
- dodoc docs/announce/* || die
- fi
-}
diff --git a/dev-lang/rakudo/rakudo-2014.11-r1.ebuild b/dev-lang/rakudo/rakudo-2014.11-r1.ebuild
deleted file mode 100644
index 1649478d32a4..000000000000
--- a/dev-lang/rakudo/rakudo-2014.11-r1.ebuild
+++ /dev/null
@@ -1,56 +0,0 @@
-# Copyright 1999-2014 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/rakudo/rakudo-2014.11-r1.ebuild,v 1.2 2014/11/26 10:10:45 patrick Exp $
-
-EAPI=5
-
-PARROT_VERSION="6.7.0"
-
-inherit eutils multilib
-
-DESCRIPTION="A Perl 6 implementation built on the Parrot virtual machine"
-HOMEPAGE="http://rakudo.org/"
-SRC_URI="http://rakudo.org/downloads/${PN}/${P}.tar.gz"
-
-LICENSE="Artistic-2"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-IUSE="doc +parrot java moar"
-
-RDEPEND="parrot? ( >=dev-lang/parrot-${PARROT_VERSION}:=[unicode] )
- >=dev-lang/nqp-${PV}[parrot?,java?,moar?]"
-DEPEND="${RDEPEND}
- dev-lang/perl"
-
-src_prepare() {
- sed -i "s,\$(DOCDIR)/rakudo$,&-${PVR}," tools/build/Makefile-Parrot.in || die
-}
-
-src_configure() {
- use parrot && myconf+="parrot,"
- use java && myconf+="jvm,"
- use moar && myconf+="moar,"
- perl Configure.pl --backends=${myconf} --prefix=/usr || die
-
- # why doesn't ops2c get detected?! :(
- if use parrot; then
- sed -i -e 's~OPS2C = $(PARROT_BIN_DIR)/$(EXE)~OPS2C = $(PARROT_BIN_DIR)/ops2c~' Makefile || die
- fi
-}
-
-src_test() {
- emake -j1 test || die
-}
-
-src_install() {
- emake -j1 DESTDIR="${ED}" install || die
-
- dodoc CREDITS README.md docs/ChangeLog docs/ROADMAP || die
-
- if use doc; then
- dohtml -A svg docs/architecture.html docs/architecture.svg || die
- dodoc docs/*.pod || die
- docinto announce
- dodoc docs/announce/* || die
- fi
-}