summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGeorge Shapovalov <george@gentoo.org>2004-10-07 22:01:31 +0000
committerGeorge Shapovalov <george@gentoo.org>2004-10-07 22:01:31 +0000
commita2a08fdc48b83bac7118be1fecc2a97ad922e6f1 (patch)
treeaab0f90b332b5b7ae725ab1311720cda097b7b02 /dev-lang
parentAdded ~amd64 to KEYWORDS. (Manifest recommit) (diff)
downloadgentoo-2-a2a08fdc48b83bac7118be1fecc2a97ad922e6f1.tar.gz
gentoo-2-a2a08fdc48b83bac7118be1fecc2a97ad922e6f1.tar.bz2
gentoo-2-a2a08fdc48b83bac7118be1fecc2a97ad922e6f1.zip
added new version (2.0_rc2), marked ~amd64
Diffstat (limited to 'dev-lang')
-rw-r--r--dev-lang/smarteiffel/ChangeLog6
-rw-r--r--dev-lang/smarteiffel/files/digest-smarteiffel-2.0_rc21
-rw-r--r--dev-lang/smarteiffel/metadata.xml5
-rw-r--r--dev-lang/smarteiffel/smarteiffel-2.0_rc2.ebuild99
4 files changed, 110 insertions, 1 deletions
diff --git a/dev-lang/smarteiffel/ChangeLog b/dev-lang/smarteiffel/ChangeLog
index c353636932d8..3e97460e5ca1 100644
--- a/dev-lang/smarteiffel/ChangeLog
+++ b/dev-lang/smarteiffel/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for dev-lang/smarteiffel
# Copyright 2002-2004 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/smarteiffel/ChangeLog,v 1.11 2004/07/02 04:31:03 eradicator Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/smarteiffel/ChangeLog,v 1.12 2004/10/07 22:01:31 george Exp $
+
+ 07 Oct 2004; George Shapovalov <george@gentoo.org> smarteiffel-2.0_rc2.ebuild, files/digest-smarteiffel-2.0_rc2, metadata.xml :
+ new version (#64545)
+ added ~amd64 to KEYWORDS
01 Jul 2004; Jeremy Huddleston <eradicator@gentoo.org>
smarteiffel-1.0.ebuild, smarteiffel-1.1.ebuild:
diff --git a/dev-lang/smarteiffel/files/digest-smarteiffel-2.0_rc2 b/dev-lang/smarteiffel/files/digest-smarteiffel-2.0_rc2
new file mode 100644
index 000000000000..1bc0f7e99dd9
--- /dev/null
+++ b/dev-lang/smarteiffel/files/digest-smarteiffel-2.0_rc2
@@ -0,0 +1 @@
+MD5 4a396f616f53f70c4a00768c948e99bb se-2-0-rc2.tar.bz2 4097126
diff --git a/dev-lang/smarteiffel/metadata.xml b/dev-lang/smarteiffel/metadata.xml
new file mode 100644
index 000000000000..f376edc581d2
--- /dev/null
+++ b/dev-lang/smarteiffel/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>lang-misc</herd>
+</pkgmetadata>
diff --git a/dev-lang/smarteiffel/smarteiffel-2.0_rc2.ebuild b/dev-lang/smarteiffel/smarteiffel-2.0_rc2.ebuild
new file mode 100644
index 000000000000..4c116db17ebf
--- /dev/null
+++ b/dev-lang/smarteiffel/smarteiffel-2.0_rc2.ebuild
@@ -0,0 +1,99 @@
+# Copyright 1999-2004 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/smarteiffel/smarteiffel-2.0_rc2.ebuild,v 1.1 2004/10/07 22:01:31 george Exp $
+
+IUSE="doc tcc"
+
+MY_PV=${PV//./-}
+
+DESCRIPTION="GNU Eiffel compiler"
+HOMEPAGE="http://smarteiffel.loria.fr/"
+
+SRC_URI="ftp://ftp.loria.fr/pub/loria/SmartEiffel/se.latest/se-${MY_PV//_/-}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86 ~amd64"
+
+DEPEND="tcc? ( >=dev-lang/tcc-0.9.14 )"
+
+S="${WORKDIR}/SmartEiffel"
+# Destination directory to hold most of the SmartEiffel distribution.
+SE_DIR="/usr/lib/SmartEiffel"
+
+src_compile() {
+ use tcc && CFLAGS=""
+ use tcc && COMPILER=tcc || COMPILER=gcc
+ einfo "Using ${COMPILER} as default C-compiler for SmartEiffel!"
+
+ export SmartEiffel="${S}/sys/system.se"
+ export PATH="${S}/bin:${PATH}"
+ cd ${S}
+ ebegin "Compiling install-program"
+ ${COMPILER} ${CFLAGS} -o install.bin install.c || die
+ #package authors created install directory right next to install.c
+ #how nice of them!
+ eend $?
+
+ einfo "Running install-program"
+ ( echo #skipping stupid prompt
+ echo 2 #compiler setup
+ use tcc && (
+ echo 11; echo tcc; echo g++
+ )
+ echo 12 #CFLAGS setup
+ echo "${CFLAGS}"
+ echo "${CXXFLAGS}"
+ echo 13 #main menu
+ echo 1; # configure
+ echo 1; echo "${S}/sys/system.se"; #set configuration file
+ echo 3; echo "${S}/bin/"; # set bin dir
+ echo 4; echo "${S}/sys/"; # set Sys dir
+ echo 5; echo "${S}/sys/"; # set Short dir
+ echo 6; # configure environment variables
+ echo 1;
+ echo "path_tutorial";
+ echo "${S}/tutorial/"
+ echo 1;
+ echo "path_tools";
+ echo "${S}/tools/";
+ echo 1;
+ echo "path_lib";
+ echo "${S}/lib/";
+ echo 3;
+ echo 8 #exit menu
+ echo 4 #save conf file
+ echo 5; echo
+ echo 6; echo #leave the menu
+ ) | ./install.bin || die
+ einfo "finished running install"
+
+ #looks like only one file with path definitions, good
+ sed -i -e "s:${S}:${SE_DIR}:" ${S}/sys/system.se || die
+}
+
+src_install () {
+ dodir ${SE_DIR}
+ cp -a ${S}/{lib,tools,sys,bin} ${D}/${SE_DIR} || die
+
+ # Create symlinks to the appropriate executable binaries.
+ dodir /usr/bin
+ rm ${S}/bin/README.txt
+ #since then this became a bin file?
+ for NAME in ${S}/bin/*; do
+ NAME=`basename ${NAME}`
+ dosym ${SE_DIR}/bin/${NAME} /usr/bin/${NAME}
+ done
+
+ # Install documentation.
+ if use doc; then
+ einfo "Installing documentation"
+ dodir /usr/share/doc/${PF}
+ cp -a ${S}/{man,misc,tutorial,READ_ME} ${D}/usr/share/doc/${PF} || die
+ fi
+
+ # Setup 'SmartEiffel' environment variable.
+ dodir /etc/env.d
+ echo "SmartEiffel=${SE_DIR}/sys/system.se" > ${D}/etc/env.d/20smarteiffel
+ echo "SmartEiffelDirectory=${SE_DIR}" >> ${D}/etc/env.d/20smarteiffel
+}