summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorStanislav Brabec <utx@gentoo.org>2003-05-19 08:38:37 +0000
committerStanislav Brabec <utx@gentoo.org>2003-05-19 08:38:37 +0000
commit9ab905db8c713e7a50f2d18635091d85f0479e7f (patch)
tree27a441e476c1703a523030cf3dbcffd0d8c48355 /dev-lang
parentunset variable S for installation (diff)
downloadgentoo-2-9ab905db8c713e7a50f2d18635091d85f0479e7f.tar.gz
gentoo-2-9ab905db8c713e7a50f2d18635091d85f0479e7f.tar.bz2
gentoo-2-9ab905db8c713e7a50f2d18635091d85f0479e7f.zip
unset variable S for installation
Diffstat (limited to 'dev-lang')
-rw-r--r--dev-lang/tcl/ChangeLog8
-rw-r--r--dev-lang/tcl/Manifest4
-rw-r--r--dev-lang/tcl/files/digest-tcl-8.4.2-r11
-rw-r--r--dev-lang/tcl/tcl-8.4.2-r1.ebuild88
-rw-r--r--dev-lang/tk/ChangeLog8
-rw-r--r--dev-lang/tk/Manifest4
-rw-r--r--dev-lang/tk/files/digest-tk-8.4.2-r11
-rw-r--r--dev-lang/tk/tk-8.4.2-r1.ebuild71
8 files changed, 179 insertions, 6 deletions
diff --git a/dev-lang/tcl/ChangeLog b/dev-lang/tcl/ChangeLog
index faf195180000..1a84887201a9 100644
--- a/dev-lang/tcl/ChangeLog
+++ b/dev-lang/tcl/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-lang/tcl
# Copyright 2002-2003 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/tcl/ChangeLog,v 1.14 2003/05/09 14:38:20 utx Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/tcl/ChangeLog,v 1.15 2003/05/19 08:37:02 utx Exp $
+
+*tcl-8.4.2-r1 (19 May 2003)
+
+ 19 May 2003; Stanislav Brabec <utx@gentoo.org> tcl-8.4.2-r1.ebuild:
+ Fixed man-pages installation (worked around bug in mkLinks script - unset
+ variable S for installation).
*tcl-8.4.2 (17 Apr 2003)
diff --git a/dev-lang/tcl/Manifest b/dev-lang/tcl/Manifest
index ebaa05b51664..e19ca4716245 100644
--- a/dev-lang/tcl/Manifest
+++ b/dev-lang/tcl/Manifest
@@ -1,9 +1,9 @@
MD5 1c8dfb613b8b84814275d10f7f09ec00 tcl-8.3.3-r1.ebuild 2075
MD5 59930a521e899c966c8c75ca739dd370 tcl-8.3.3-r3.ebuild 2178
MD5 eff073a2329a82ec0ce900c647dd0591 tcl-8.3.4.ebuild 2183
-MD5 f8b69c088a2ee413ff1b7e22e9865256 ChangeLog 2242
+MD5 ba2ae9f81d1ed1dd7d0ede04bbeadd19 ChangeLog 2450
MD5 0d146e25616ec18d4bd1326042c8a1dd tcl-8.4.2.ebuild 2653
-MD5 a6a97594f46090cf812ea7bfcac2a258 tcl-8.4.2-r1.ebuild 2656
+MD5 695c67fe9bbe6be1797fd16f450a9f0d tcl-8.4.2-r1.ebuild 2659
MD5 ee8221e881e685cb7836325e4021881e files/digest-tcl-8.3.3-r1 61
MD5 ee8221e881e685cb7836325e4021881e files/digest-tcl-8.3.3-r3 61
MD5 d7d05b473cf799a637baaa9f321b070f files/digest-tcl-8.3.4 121
diff --git a/dev-lang/tcl/files/digest-tcl-8.4.2-r1 b/dev-lang/tcl/files/digest-tcl-8.4.2-r1
new file mode 100644
index 000000000000..4cc729cd7d81
--- /dev/null
+++ b/dev-lang/tcl/files/digest-tcl-8.4.2-r1
@@ -0,0 +1 @@
+MD5 4be55d8ebfcc9773407537445edd2ae1 tcl8.4.2-src.tar.gz 3330617
diff --git a/dev-lang/tcl/tcl-8.4.2-r1.ebuild b/dev-lang/tcl/tcl-8.4.2-r1.ebuild
new file mode 100644
index 000000000000..580a1c79c2ec
--- /dev/null
+++ b/dev-lang/tcl/tcl-8.4.2-r1.ebuild
@@ -0,0 +1,88 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/tcl/tcl-8.4.2-r1.ebuild,v 1.1 2003/05/19 08:37:02 utx Exp $
+
+
+S=${WORKDIR}/${PN}${PV}
+SRC_URI="ftp://ftp.scriptics.com/pub/tcl/tcl8_4/${PN}${PV}-src.tar.gz"
+
+
+HOMEPAGE="http://dev.scriptics.com/software/tcltk/"
+
+DESCRIPTION="Tool Command Language"
+
+# gentoolkit is needed only for revdep-rebuild
+DEPEND="virtual/glibc
+ >=app-admin/gentoolkit-0.1.22"
+RDEPEND="virtual/glibc"
+
+SLOT="0"
+LICENSE="BSD"
+KEYWORDS="~x86"
+IUSE=""
+
+# hyper-optimizations untested...
+#
+
+src_compile() {
+
+ cd ${S}/unix
+ ./configure --host=${CHOST} \
+ --prefix=/usr \
+ --mandir=/usr/share/man \
+ || die
+ # threading is not recommended as it breaks some packages
+ # --enable-threads \
+
+ emake CFLAGS="${CFLAGS}" || die
+
+}
+
+src_install() {
+
+ #short version number
+ local v1
+ v1=${PV%.*}
+
+ cd ${S}/unix
+ S= make INSTALL_ROOT=${D} MAN_INSTALL_DIR=${D}/usr/share/man install || die
+
+ # fix the tclConfig.sh to eliminate refs to the build directory
+ sed -e "s,^TCL_BUILD_LIB_SPEC='-L${S}/unix,TCL_BUILD_LIB_SPEC='-L/usr/lib," \
+ -e "s,^TCL_SRC_DIR='${S}',TCL_SRC_DIR='/usr/lib/tcl${v1}/include'," \
+ -e "s,^TCL_BUILD_STUB_LIB_SPEC='-L${S}/unix,TCL_BUILD_STUB_LIB_SPEC='-L/usr/lib," \
+ -e "s,^TCL_BUILD_STUB_LIB_PATH='${S}/unix,TCL_BUILD_STUB_LIB_PATH='/usr/lib," \
+ -e "s,^TCL_LIB_FILE='libtcl8.4..TCL_DBGX..so',TCL_LIB_FILE=\"libtcl8.4\$\{TCL_DBGX\}.so\"," \
+ ${D}/usr/lib/tclConfig.sh > ${D}/usr/lib/tclConfig.sh.new
+ mv ${D}/usr/lib/tclConfig.sh.new ${D}/usr/lib/tclConfig.sh
+
+ # install private headers
+ dodir /usr/lib/tcl${v1}/include/unix
+ install -c -m0644 ${S}/unix/*.h ${D}/usr/lib/tcl${v1}/include/unix
+ dodir /usr/lib/tcl${v1}/include/generic
+ install -c -m0644 ${S}/generic/*.h ${D}/usr/lib/tcl${v1}/include/generic
+ rm -f ${D}/usr/lib/tcl${v1}/include/generic/tcl.h
+ rm -f ${D}/usr/lib/tcl${v1}/include/generic/tclDecls.h
+ rm -f ${D}/usr/lib/tcl${v1}/include/generic/tclPlatDecls.h
+
+ # install symlink for libraries
+ dosym /usr/lib/libtcl${v1}.so /usr/lib/libtcl.so
+ dosym /usr/lib/libtclstub${v1}.a /usr/lib/libtclstub.a
+
+ ln -sf tclsh${v1} ${D}/usr/bin/tclsh
+
+ cd ${S}
+ dodoc README changes license.terms
+
+}
+
+pkg_postinst() {
+ ewarn
+ ewarn "If you're upgrading from tcl-8.3, you must recompile the other"
+ ewarn "packages on your system that link with tcl after the upgrade"
+ ewarn "completes. To perform this action, please run revdep-rebuild."
+ ewarn "If you have dev-lang/tk and dev-tcltk/tclx installed you should"
+ ewarn "upgrade them before this recompilation, too,"
+ ewarn
+ sleep 5
+}
diff --git a/dev-lang/tk/ChangeLog b/dev-lang/tk/ChangeLog
index c054d8cc153f..c6f0138aa41f 100644
--- a/dev-lang/tk/ChangeLog
+++ b/dev-lang/tk/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-lang/tk
# Copyright 2002-2003 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/tk/ChangeLog,v 1.15 2003/04/17 17:26:26 utx Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/tk/ChangeLog,v 1.16 2003/05/19 08:38:20 utx Exp $
+
+*tk-8.4.2-r1 (19 May 2003)
+
+ 19 May 2003; Stanislav Brabec <utx@gentoo.org> tk-8.4.2-r1.ebuild:
+ Fixed man-pages installation (worked around bug in mkLinks script - unset
+ variable S for installation).
*tk-8.4.2 (17 Apr 2003)
diff --git a/dev-lang/tk/Manifest b/dev-lang/tk/Manifest
index c925a1884da6..eb40006c85d9 100644
--- a/dev-lang/tk/Manifest
+++ b/dev-lang/tk/Manifest
@@ -3,9 +3,9 @@ MD5 a30e2af10f9e38546f1bb0f134817084 tk-8.3.3-r2.ebuild 2081
MD5 809325e2d5003b4960d4b83493673737 tk-8.3.4-r1.ebuild 1991
MD5 dd76111b932c04955d0487c07b2f8220 tk-8.3.3.ebuild 2026
MD5 411419fc4d00094f72d9eb8a08b31d6a tk-8.3.3-r3.ebuild 2180
-MD5 301d6518e19a7d6014412505edfb4889 ChangeLog 2626
+MD5 1b6ce4d77db2f4414972791dade10abd ChangeLog 2831
MD5 6bad624304d942ece054c88ad9ba5a62 tk-8.4.2.ebuild 1980
-MD5 2f04d70a41eae346aab53a3408c8f7b0 tk-8.4.2-r1.ebuild 1983
+MD5 ffa0a2b1e7a4e947b5e672ff2a748109 tk-8.4.2-r1.ebuild 1985
MD5 2ba3335fd9167fef8f3f99be70675257 files/digest-tk-8.3.3-r2 60
MD5 2ba3335fd9167fef8f3f99be70675257 files/digest-tk-8.3.3-r3 60
MD5 0321d3bb5b70142a415de40ae2d5e3d4 files/digest-tk-8.3.4-r1 192
diff --git a/dev-lang/tk/files/digest-tk-8.4.2-r1 b/dev-lang/tk/files/digest-tk-8.4.2-r1
new file mode 100644
index 000000000000..5d625fd27335
--- /dev/null
+++ b/dev-lang/tk/files/digest-tk-8.4.2-r1
@@ -0,0 +1 @@
+MD5 04812fcdf6b50bfe89b7d44db3f33f19 tk8.4.2-src.tar.gz 3155987
diff --git a/dev-lang/tk/tk-8.4.2-r1.ebuild b/dev-lang/tk/tk-8.4.2-r1.ebuild
new file mode 100644
index 000000000000..0030265eaea4
--- /dev/null
+++ b/dev-lang/tk/tk-8.4.2-r1.ebuild
@@ -0,0 +1,71 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/tk/tk-8.4.2-r1.ebuild,v 1.1 2003/05/19 08:38:20 utx Exp $
+
+S=${WORKDIR}/${PN}${PV}
+SRC_URI="ftp://ftp.scriptics.com/pub/tcl/tcl8_4/${PN}${PV}-src.tar.gz"
+HOMEPAGE="http://dev.scriptics.com/software/tcltk/"
+DESCRIPTION="Tk Widget Set"
+IUSE=""
+
+SLOT="0"
+LICENSE="BSD"
+KEYWORDS="~x86"
+
+DEPEND=">=sys-apps/sed-4.0.5
+ >=sys-apps/portage-2.0.47-r10
+ virtual/x11
+ =dev-lang/tcl-${PV}*"
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}/library
+ epatch ${FILESDIR}/remove-control-v-8.4.diff
+}
+
+# hyper-optimizations untested...
+#
+src_compile() {
+ cd ${S}/unix
+ econf \
+ --with-tcl=/usr/lib \
+ --enable-threads || die
+
+ emake CFLAGS="${CFLAGS}" || die
+}
+
+src_install() {
+ #short version number
+ local v1
+ v1=${PV%.*}
+
+ cd ${S}/unix
+ S= make INSTALL_ROOT=${D} MAN_INSTALL_DIR=${D}/usr/share/man install || die
+
+ # fix the tkConfig.sh to eliminate refs to the build directory
+ sed -i \
+ -e "s,^\(TK_BUILD_LIB_SPEC='-L\)${S}/unix,\1/usr/lib," \
+ -e "s,^\(TK_SRC_DIR='\)${S}',\1/usr/lib/tk${v1}/include'," \
+ -e "s,^\(TK_BUILD_STUB_LIB_SPEC='-L\)${S}/unix,\1/usr/lib," \
+ -e "s,^\(TK_BUILD_STUB_LIB_PATH='\)${S}/unix,\1/usr/lib," \
+ ${D}/usr/lib/tkConfig.sh
+
+ # install private headers
+ dodir /usr/lib/tk${v1}/include/unix
+ install -c -m0644 ${S}/unix/*.h ${D}/usr/lib/tk${v1}/include/unix
+ dodir /usr/lib/tk${v1}/include/generic
+ install -c -m0644 ${S}/generic/*.h ${D}/usr/lib/tk${v1}/include/generic
+ rm -f ${D}/usr/lib/tk${v1}/include/generic/tk.h
+ rm -f ${D}/usr/lib/tk${v1}/include/generic/tkDecls.h
+ rm -f ${D}/usr/lib/tk${v1}/include/generic/tkPlatDecls.h
+
+ # install symlink for libraries
+ #dosym /usr/lib/libtk${v1}.a /usr/lib/libtk.a
+ dosym /usr/lib/libtk${v1}.so /usr/lib/libtk.so
+ dosym /usr/lib/libtkstub${v1}.a /usr/lib/libtkstub.a
+
+ ln -sf wish${v1} ${D}/usr/bin/wish
+
+ cd ${S}
+ dodoc README changes license.terms
+}