summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSeemant Kulleen <seemant@gentoo.org>2002-08-02 04:47:33 +0000
committerSeemant Kulleen <seemant@gentoo.org>2002-08-02 04:47:33 +0000
commit9535281410496de748accf309a866e24da4445ea (patch)
treeb8817877cf539715d902a1c0c3b490ff47330477 /dev-lang
parentbeautified (diff)
downloadgentoo-2-9535281410496de748accf309a866e24da4445ea.tar.gz
gentoo-2-9535281410496de748accf309a866e24da4445ea.tar.bz2
gentoo-2-9535281410496de748accf309a866e24da4445ea.zip
modernised
Diffstat (limited to 'dev-lang')
-rw-r--r--dev-lang/ferite/ferite-0.99.4.ebuild16
-rw-r--r--dev-lang/ghc/ghc-5.02.3.ebuild22
-rw-r--r--dev-lang/gpc/gpc-2.1.ebuild10
-rw-r--r--dev-lang/icon/icon-9.40.ebuild82
-rw-r--r--dev-lang/mono/mono-0.12.ebuild4
-rw-r--r--dev-lang/mono/mono-0.13.ebuild4
-rw-r--r--dev-lang/nasm/nasm-0.98-r3.ebuild6
-rw-r--r--dev-lang/nasm/nasm-0.98-r4.ebuild4
-rw-r--r--dev-lang/nasm/nasm-0.98.30.ebuild4
-rw-r--r--dev-lang/nasm/nasm-0.98.31-r1.ebuild6
-rw-r--r--dev-lang/nasm/nasm-0.98.31.ebuild4
-rw-r--r--dev-lang/python/python-2.1.3-r1.ebuild4
-rw-r--r--dev-lang/python/python-2.1.3.ebuild4
-rw-r--r--dev-lang/python/python-2.2-r7.ebuild10
-rw-r--r--dev-lang/python/python-2.2.1-r1.ebuild4
-rw-r--r--dev-lang/python/python-2.2.1-r2.ebuild4
-rw-r--r--dev-lang/python/python-2.2.1.ebuild14
-rw-r--r--dev-lang/swig/swig-1.3.10-r2.ebuild14
-rw-r--r--dev-lang/tcl/tcl-8.3.3-r1.ebuild10
-rw-r--r--dev-lang/tcl/tcl-8.3.3-r3.ebuild12
-rw-r--r--dev-lang/tk/tk-8.3.3-r1.ebuild10
-rw-r--r--dev-lang/tk/tk-8.3.3.ebuild10
22 files changed, 129 insertions, 129 deletions
diff --git a/dev-lang/ferite/ferite-0.99.4.ebuild b/dev-lang/ferite/ferite-0.99.4.ebuild
index 4dbe1deb4704..3d7ab5665a2c 100644
--- a/dev-lang/ferite/ferite-0.99.4.ebuild
+++ b/dev-lang/ferite/ferite-0.99.4.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2002 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License, v2 or later
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/ferite/ferite-0.99.4.ebuild,v 1.3 2002/07/22 07:24:29 george Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/ferite/ferite-0.99.4.ebuild,v 1.4 2002/08/02 04:44:53 seemant Exp $
S=${WORKDIR}/${P}
@@ -20,19 +20,19 @@ KEYWORDS="x86"
src_compile() {
./configure --host=${CHOST} \
- --prefix=/usr \
- --infodir=/usr/share/info \
- --mandir=/usr/share/man || die
+ --prefix=/usr \
+ --infodir=/usr/share/info \
+ --mandir=/usr/share/man || die
emake || die
}
src_install() {
make prefix=${D}/usr \
- infodir=${D}/usr/share/info \
- mandir=${D}/usr/share/man \
- install || die
-
+ infodir=${D}/usr/share/info \
+ mandir=${D}/usr/share/man \
+ install || die
+
dodoc AUTHORS ChangeLog COPYING README* INSTALL NEWS
dohtml -r docs
diff --git a/dev-lang/ghc/ghc-5.02.3.ebuild b/dev-lang/ghc/ghc-5.02.3.ebuild
index 9b906ec09615..2bbf19ccdcf5 100644
--- a/dev-lang/ghc/ghc-5.02.3.ebuild
+++ b/dev-lang/ghc/ghc-5.02.3.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2002 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/ghc/ghc-5.02.3.ebuild,v 1.4 2002/07/29 16:13:02 seemant Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/ghc/ghc-5.02.3.ebuild,v 1.5 2002/08/02 04:44:53 seemant Exp $
# ebuild for Glorious Glasgow Haskell
@@ -23,8 +23,8 @@
#
# USE variable summary:
# opengl - Build HOpenGL (OpenGL binding for Haskell).
-# doc - Build extra documenation from DocBook sources, namely
-# the GHC User's Guide and the hslibs docs. In HTML format.
+# doc - Build extra documenation from DocBook sources, namely
+# the GHC User's Guide and the hslibs docs. In HTML format.
# tetex - Build the above docs as PostScript as well.
#
# 2002-05-22 Sven Moritz Hallberg <pesco@gmx.de>
@@ -40,7 +40,7 @@ SLOT="0"
KEYWORDS="x86"
# FIXME: Add USE support for parallel haskell (requires PVM)
-# Get PVM from ftp://ftp.netlib.org/pvm3/
+# Get PVM from ftp://ftp.netlib.org/pvm3/
DEPEND=">=sys-devel/perl-5.6.1
>=sys-devel/gcc-2.95.3
>=sys-devel/make-3.79.1
@@ -93,8 +93,8 @@ if test -z "${GHC}"; then
echo I will bootstrap from HC files.
boot_from_hc=yes
- # This is the version of our "base GHC", that is, the one we will use
- # for the first build from Haskell source. It's the stage 1's
+ # This is the version of our "base GHC", that is, the one we will use
+ # for the first build from Haskell source. It's the stage 1's
# version if there is no outside GHC, or that one's version
# otherwise (see else clause below).
BASE_GHC_VERSION=${STAGE1_PV}
@@ -116,8 +116,8 @@ fi
# Determine which source files to download:
# - We always need the source distribution for the final version.
# - If bootstrap from HC files is required:
-# - We need the corresponding source distribution.
-# - We need a set of HC files suitable for our architecture.
+# - We need the corresponding source distribution.
+# - We need a set of HC files suitable for our architecture.
# List of platforms for which registerised HC files are available.
HC_PLATS="x86 sparc"
@@ -193,14 +193,14 @@ src_unpack() {
src_compile() {
if test x$boot_from_hc = xyes; then
echo ">>> Bootstrapping GHC ${STAGE1_PV} from HC files"
- build_stage1 # bootstrap from HC files
+ build_stage1 # bootstrap from HC files
fi
if test x$need_stage2 = xyes; then
echo ">>> Bootstrapping intermediate GHC ${PV} using GHC ${BASE_GHC_VERSION}"
- build_stage2 # bootstrap intermediate GHC
+ build_stage2 # bootstrap intermediate GHC
fi
echo ">>> Building complete GHC ${PV} using GHC ${PV} itself"
- build_stage3 # final build
+ build_stage3 # final build
}
src_install() {
diff --git a/dev-lang/gpc/gpc-2.1.ebuild b/dev-lang/gpc/gpc-2.1.ebuild
index 578dbb73ebc5..25016336d464 100644
--- a/dev-lang/gpc/gpc-2.1.ebuild
+++ b/dev-lang/gpc/gpc-2.1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2002 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License, v2 or later
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/gpc/gpc-2.1.ebuild,v 1.4 2002/07/22 08:02:59 george Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/gpc/gpc-2.1.ebuild,v 1.5 2002/08/02 04:44:53 seemant Exp $
S="${WORKDIR}/gcc-2.95.3"
@@ -33,7 +33,7 @@ src_unpack() {
#comment out read to let ebuild continue
cp config-lang.in config-lang.in.orig
- sed -e "s:read:#read:" config-lang.in.orig > config-lang.in
+ sed -e "s:read:#read:" config-lang.in.orig > config-lang.in
#this fix seems to be specific to gentoo glibc
#one of the patches to glibc-2.2.5-r4 was causing problems
@@ -52,12 +52,12 @@ src_compile() {
#lets reduce optimisation somewhat
export CFLAGS="${CFLAGS/-O?/-O2}"
- export CXXFLAGS="${CXXFLAGS/-O?/-O2}"
+ export CXXFLAGS="${CXXFLAGS/-O?/-O2}"
#it also looks like gpc does not like -pipe
#resolved!
- #export CFLAGS="${CFLAGS/-pipe/}"
- #export CXXFLAGS="${CXXFLAGS/-pipe/}"
+ #export CFLAGS="${CFLAGS/-pipe/}"
+ #export CXXFLAGS="${CXXFLAGS/-pipe/}"
./configure --enable-languages=pascal\
--host=${CHOST} --build=${CHOST} --target=${CHOST} \
diff --git a/dev-lang/icon/icon-9.40.ebuild b/dev-lang/icon/icon-9.40.ebuild
index c415024b55cb..91dcc20b33cb 100644
--- a/dev-lang/icon/icon-9.40.ebuild
+++ b/dev-lang/icon/icon-9.40.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2002 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License, v2 or later
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/icon/icon-9.40.ebuild,v 1.5 2002/08/01 11:40:14 seemant Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/icon/icon-9.40.ebuild,v 1.6 2002/08/02 04:44:53 seemant Exp $
S=${WORKDIR}/icon.v940src
SRC_URI="http://www.cs.arizona.edu/icon/ftp/packages/unix/icon.v940src.tgz"
@@ -16,52 +16,52 @@ SLOT="0"
KEYWORDS="x86"
src_unpack() {
-
- cd ${WORKDIR}
- unpack ${A}
- cd ${S}/config/unix/intel_linux
- patch -p0 <${FILESDIR}/${P}-gentoo.diff
-
+
+ cd ${WORKDIR}
+ unpack ${A}
+ cd ${S}/config/unix/intel_linux
+ patch -p0 <${FILESDIR}/${P}-gentoo.diff
+
}
src_compile() {
-
- cd ${S}
+
+ cd ${S}
- if [ "`use X`" ]; then
- try make X-Configure name=intel_linux
- else
- try make Configure name=intel_linux
- fi
-
- try make
-
- # small builtin test
- try make Samples
- # large builtin test
- try make Test
+ if [ "`use X`" ]; then
+ make X-Configure name=intel_linux || die
+ else
+ make Configure name=intel_linux || die
+ fi
+
+ make || die
+
+ # small builtin test
+ make Samples || die
+ # large builtin test
+ make Test || die
}
src_install () {
-
- #try make Install dest=${D}/opt/icon
- # fhs-problems, manual rectify
-
- into /usr
-
- cd ${S}/bin
- rm .placeholder libXpm.a rt.h
- dobin *
-
- cd ${S}/lib
- rm .placeholder
- dolib *
-
- cd ${S}/man/man1
- doman icont.1
-
- cd ${S}/doc
- dodoc * ../README
-
+
+ #make Install dest=${D}/opt/icon || die
+ # fhs-problems, manual rectify
+
+ into /usr
+
+ cd ${S}/bin
+ rm .placeholder libXpm.a rt.h
+ dobin *
+
+ cd ${S}/lib
+ rm .placeholder
+ dolib *
+
+ cd ${S}/man/man1
+ doman icont.1
+
+ cd ${S}/doc
+ dodoc * ../README
+
}
diff --git a/dev-lang/mono/mono-0.12.ebuild b/dev-lang/mono/mono-0.12.ebuild
index 4b4d599d9f1c..04d032f4ccb0 100644
--- a/dev-lang/mono/mono-0.12.ebuild
+++ b/dev-lang/mono/mono-0.12.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2002 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License, v2 or later
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/mono/mono-0.12.ebuild,v 1.4 2002/07/28 17:48:40 sunflare Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/mono/mono-0.12.ebuild,v 1.5 2002/08/02 04:44:53 seemant Exp $
S=${WORKDIR}/${P}
DESCRIPTION="Mono runtime"
@@ -11,7 +11,7 @@ LICENSE="GPL-2"
SLOT="0"
DEPEND="virtual/glibc
- dev-util/pkgconfig"
+ dev-util/pkgconfig"
RDEPEND="${DEPEND}"
KEYWORDS="x86"
diff --git a/dev-lang/mono/mono-0.13.ebuild b/dev-lang/mono/mono-0.13.ebuild
index 98a85542981d..ec3411cf5c9a 100644
--- a/dev-lang/mono/mono-0.13.ebuild
+++ b/dev-lang/mono/mono-0.13.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2002 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License, v2 or later
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/mono/mono-0.13.ebuild,v 1.3 2002/07/29 10:09:23 trance Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/mono/mono-0.13.ebuild,v 1.4 2002/08/02 04:44:53 seemant Exp $
S=${WORKDIR}/${P}
DESCRIPTION="Mono runtime"
@@ -11,7 +11,7 @@ LICENSE="GPL-2"
SLOT="0"
DEPEND="virtual/glibc
- dev-util/pkgconfig
+ dev-util/pkgconfig
>=dev-libs/glib-2.0"
RDEPEND="${DEPEND}"
KEYWORDS="x86 -ppc"
diff --git a/dev-lang/nasm/nasm-0.98-r3.ebuild b/dev-lang/nasm/nasm-0.98-r3.ebuild
index 56f79af2c286..6164817fe399 100644
--- a/dev-lang/nasm/nasm-0.98-r3.ebuild
+++ b/dev-lang/nasm/nasm-0.98-r3.ebuild
@@ -1,6 +1,6 @@
# Copyright 2002 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License, v2 or later
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/nasm/nasm-0.98-r3.ebuild,v 1.5 2002/07/23 04:11:56 george Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/nasm/nasm-0.98-r3.ebuild,v 1.6 2002/08/02 04:44:54 seemant Exp $
S=${WORKDIR}/${P}
DESCRIPTION="groovy little assembler"
@@ -20,7 +20,7 @@ SLOT="0"
LICENSE="LGPL-2.1"
KEYWORDS="x86"
-src_compile() {
+src_compile() {
./configure --prefix=/usr || die
if [ "`use build`" ]; then
@@ -42,7 +42,7 @@ src_install() {
dodoc COPYING Changes Licence MODIFIED Readme Wishlist
docinto txt
cd doc
- dodoc nasmdoc.txt
+ dodoc nasmdoc.txt
docinto html
dodoc html/*.html
docinto ps
diff --git a/dev-lang/nasm/nasm-0.98-r4.ebuild b/dev-lang/nasm/nasm-0.98-r4.ebuild
index 1b74db6b094e..f8e799412c0f 100644
--- a/dev-lang/nasm/nasm-0.98-r4.ebuild
+++ b/dev-lang/nasm/nasm-0.98-r4.ebuild
@@ -1,6 +1,6 @@
# Copyright 2002 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License, v2 or later
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/nasm/nasm-0.98-r4.ebuild,v 1.3 2002/07/23 04:11:56 george Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/nasm/nasm-0.98-r4.ebuild,v 1.4 2002/08/02 04:44:54 seemant Exp $
S=${WORKDIR}/${P}
DESCRIPTION="groovy little assembler"
@@ -20,7 +20,7 @@ SLOT="0"
LICENSE="LGPL-2.1"
KEYWORDS="x86"
-src_compile() {
+src_compile() {
./configure --prefix=/usr || die
if [ "`use build`" ]; then
diff --git a/dev-lang/nasm/nasm-0.98.30.ebuild b/dev-lang/nasm/nasm-0.98.30.ebuild
index 9b6084bcdd77..bfd4b98bf0dd 100644
--- a/dev-lang/nasm/nasm-0.98.30.ebuild
+++ b/dev-lang/nasm/nasm-0.98.30.ebuild
@@ -1,6 +1,6 @@
# Copyright 2002 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License, v2 or later
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/nasm/nasm-0.98.30.ebuild,v 1.3 2002/07/23 04:11:56 george Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/nasm/nasm-0.98.30.ebuild,v 1.4 2002/08/02 04:44:54 seemant Exp $
S=${WORKDIR}/${P}
DESCRIPTION="groovy little assembler"
@@ -20,7 +20,7 @@ SLOT="0"
LICENSE="LGPL-2.1"
KEYWORDS="x86"
-src_compile() {
+src_compile() {
./configure --prefix=/usr || die
if [ "`use build`" ]; then
diff --git a/dev-lang/nasm/nasm-0.98.31-r1.ebuild b/dev-lang/nasm/nasm-0.98.31-r1.ebuild
index 224af473aac2..3275d45ae1bf 100644
--- a/dev-lang/nasm/nasm-0.98.31-r1.ebuild
+++ b/dev-lang/nasm/nasm-0.98.31-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 2002 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License, v2 or later
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/nasm/nasm-0.98.31-r1.ebuild,v 1.3 2002/07/23 04:11:56 george Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/nasm/nasm-0.98.31-r1.ebuild,v 1.4 2002/08/02 04:44:54 seemant Exp $
S=${WORKDIR}/${P}
DESCRIPTION="groovy little assembler"
@@ -30,7 +30,7 @@ src_unpack() {
}
-src_compile() {
+src_compile() {
./configure --prefix=/usr || die
@@ -39,7 +39,7 @@ src_compile() {
else
make everything || die
fi
-
+
}
src_install() {
diff --git a/dev-lang/nasm/nasm-0.98.31.ebuild b/dev-lang/nasm/nasm-0.98.31.ebuild
index 0521a91a2a25..8a5dec47120c 100644
--- a/dev-lang/nasm/nasm-0.98.31.ebuild
+++ b/dev-lang/nasm/nasm-0.98.31.ebuild
@@ -1,6 +1,6 @@
# Copyright 2002 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License, v2 or later
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/nasm/nasm-0.98.31.ebuild,v 1.3 2002/07/23 04:11:56 george Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/nasm/nasm-0.98.31.ebuild,v 1.4 2002/08/02 04:44:54 seemant Exp $
S=${WORKDIR}/${P}
DESCRIPTION="groovy little assembler"
@@ -20,7 +20,7 @@ SLOT="0"
LICENSE="LGPL-2.1"
KEYWORDS="x86"
-src_compile() {
+src_compile() {
./configure --prefix=/usr || die
if [ "`use build`" ]; then
diff --git a/dev-lang/python/python-2.1.3-r1.ebuild b/dev-lang/python/python-2.1.3-r1.ebuild
index 98faa86cf862..23e1ad6a0374 100644
--- a/dev-lang/python/python-2.1.3-r1.ebuild
+++ b/dev-lang/python/python-2.1.3-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2002 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License, v2 or later
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/python/python-2.1.3-r1.ebuild,v 1.3 2002/07/23 04:40:42 george Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/python/python-2.1.3-r1.ebuild,v 1.4 2002/08/02 04:44:54 seemant Exp $
PYVER_MAJOR="`echo ${PV} | cut -d '.' -f 1`"
PYVER_MINOR="`echo ${PV} | cut -d '.' -f 2`"
@@ -33,7 +33,7 @@ src_compile() {
t=${S}/Makefile.pre.in
cp $t $t.orig || die
sed 's:install-platlib.*:& --install-scripts=$(BINDIR):' $t.orig > $t
-
+
local myopts
#if we are creating a new build image, we remove the dependency on g++
diff --git a/dev-lang/python/python-2.1.3.ebuild b/dev-lang/python/python-2.1.3.ebuild
index da974960b000..3efad9e893c1 100644
--- a/dev-lang/python/python-2.1.3.ebuild
+++ b/dev-lang/python/python-2.1.3.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2002 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License, v2 or later
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/python/python-2.1.3.ebuild,v 1.3 2002/07/23 04:40:42 george Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/python/python-2.1.3.ebuild,v 1.4 2002/08/02 04:44:54 seemant Exp $
PYVER_MAJOR="`echo ${PV} | cut -d '.' -f 1`"
PYVER_MINOR="`echo ${PV} | cut -d '.' -f 2`"
@@ -33,7 +33,7 @@ src_compile() {
t=${S}/Makefile.pre.in
cp $t $t.orig || die
sed 's:install-platlib.*:& --install-scripts=$(BINDIR):' $t.orig > $t
-
+
local myopts
#if we are creating a new build image, we remove the dependency on g++
diff --git a/dev-lang/python/python-2.2-r7.ebuild b/dev-lang/python/python-2.2-r7.ebuild
index e4cbba0c10a5..de0f8e36a1e8 100644
--- a/dev-lang/python/python-2.2-r7.ebuild
+++ b/dev-lang/python/python-2.2-r7.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2002 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License, v2 or later
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/python/python-2.2-r7.ebuild,v 1.4 2002/07/23 04:40:42 george Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/python/python-2.2-r7.ebuild,v 1.5 2002/08/02 04:44:54 seemant Exp $
PYVER_MAJOR="`echo ${PV} | cut -d '.' -f 1`"
PYVER_MINOR="`echo ${PV} | cut -d '.' -f 2`"
@@ -36,10 +36,10 @@ src_compile() {
t=${S}/Makefile.pre.in
cp $t $t.orig || die
sed 's:install-platlib.*:& --install-scripts=$(BINDIR):' $t.orig > $t
-
+
# adjust Setup to include the various modules we need
cd ${S}
- # turn **on** shared
+ # turn **on** shared
scmd="s:#\(\*shared\*\):\1:;"
# adjust for USE readline
if use readline; then
@@ -79,11 +79,11 @@ src_compile() {
# no USE vars to switch off these adjustments:
scmd="$scmd s:#\(_locale .*\):\1:;" # access to ISO C locale support
scmd="$scmd s:#\(syslog .*\):\1:;" # syslog daemon interface
- scmd="$scmd s:#\(zlib .*\):\1:;" # This require zlib 1.1.3 (or later).
+ scmd="$scmd s:#\(zlib .*\):\1:;" # This require zlib 1.1.3 (or later).
scmd="$scmd s:#\(termios .*\):\1:;" # Steen Lumholt's termios module
scmd="$scmd s:#\(resource .*\):\1:;" # Jeremy Hylton's rlimit interface
sed "$scmd" Modules/Setup.dist > Modules/Setup
-
+
local myopts
#if we are creating a new build image, we remove the dependency on g++
if [ "`use build`" -a ! "`use bootstrap`" ]
diff --git a/dev-lang/python/python-2.2.1-r1.ebuild b/dev-lang/python/python-2.2.1-r1.ebuild
index e38d947e66e8..d4be93ba8289 100644
--- a/dev-lang/python/python-2.2.1-r1.ebuild
+++ b/dev-lang/python/python-2.2.1-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2002 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License, v2 or later
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/python/python-2.2.1-r1.ebuild,v 1.3 2002/07/21 00:59:19 cardoe Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/python/python-2.2.1-r1.ebuild,v 1.4 2002/08/02 04:44:54 seemant Exp $
PYVER_MAJOR="`echo ${PV} | cut -d '.' -f 1`"
PYVER_MINOR="`echo ${PV} | cut -d '.' -f 2`"
@@ -36,7 +36,7 @@ src_compile() {
t=${S}/Makefile.pre.in
cp $t $t.orig || die
sed 's:install-platlib.*:& --install-scripts=$(BINDIR):' $t.orig > $t
-
+
local myopts
#if we are creating a new build image, we remove the dependency on g++
if [ "`use build`" -a ! "`use bootstrap`" ]
diff --git a/dev-lang/python/python-2.2.1-r2.ebuild b/dev-lang/python/python-2.2.1-r2.ebuild
index be85f30bf70c..1e026315490c 100644
--- a/dev-lang/python/python-2.2.1-r2.ebuild
+++ b/dev-lang/python/python-2.2.1-r2.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2002 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License, v2 or later
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/python/python-2.2.1-r2.ebuild,v 1.3 2002/07/21 00:54:59 cardoe Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/python/python-2.2.1-r2.ebuild,v 1.4 2002/08/02 04:44:54 seemant Exp $
PYVER_MAJOR="`echo ${PV} | cut -d '.' -f 1`"
PYVER_MINOR="`echo ${PV} | cut -d '.' -f 2`"
@@ -36,7 +36,7 @@ src_compile() {
t=${S}/Makefile.pre.in
cp $t $t.orig || die
sed 's:install-platlib.*:& --install-scripts=$(BINDIR):' $t.orig > $t
-
+
local myopts
#if we are creating a new build image, we remove the dependency on g++
if [ "`use build`" -a ! "`use bootstrap`" ]
diff --git a/dev-lang/python/python-2.2.1.ebuild b/dev-lang/python/python-2.2.1.ebuild
index d76d4bbf3fe3..395976365320 100644
--- a/dev-lang/python/python-2.2.1.ebuild
+++ b/dev-lang/python/python-2.2.1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2002 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License, v2 or later
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/python/python-2.2.1.ebuild,v 1.4 2002/07/23 04:40:42 george Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/python/python-2.2.1.ebuild,v 1.5 2002/08/02 04:44:54 seemant Exp $
PYVER_MAJOR="`echo ${PV} | cut -d '.' -f 1`"
PYVER_MINOR="`echo ${PV} | cut -d '.' -f 2`"
@@ -35,21 +35,21 @@ src_compile() {
t=${S}/Makefile.pre.in
cp $t $t.orig || die
sed 's:install-platlib.*:& --install-scripts=$(BINDIR):' $t.orig > $t
-
- # turn **on** shared
+
+ # turn **on** shared
echo '*shared*' >> Modules/Setup.local
-
+
local myopts
#if we are creating a new build image, we remove the dependency on g++
if [ "`use build`" -a ! "`use bootstrap`" ]
then
myopts="--with-cxx=no"
fi
-
+
./configure \
--prefix=/usr \
--without-libdb \
- --with-fpectl \
+ --with-fpectl \
--infodir='${prefix}'/share/info \
--mandir='${prefix}'/share/man $myopts || die
emake || die "Parallel make failed"
@@ -69,7 +69,7 @@ src_install() {
newexe ${FILESDIR}/python-config-${PYVER} python-config
# seems like the build do not install Makefile.pre.in anymore
- # it probably shouldn't - use DistUtils, people!
+ # it probably shouldn't - use DistUtils, people!
insinto /usr/lib/python${PYVER}/config
doins ${S}/Makefile.pre.in
diff --git a/dev-lang/swig/swig-1.3.10-r2.ebuild b/dev-lang/swig/swig-1.3.10-r2.ebuild
index 55a8467bbe6a..01c9612ec6b5 100644
--- a/dev-lang/swig/swig-1.3.10-r2.ebuild
+++ b/dev-lang/swig/swig-1.3.10-r2.ebuild
@@ -1,6 +1,6 @@
# Copyright 2002 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License, v2 or later
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/swig/swig-1.3.10-r2.ebuild,v 1.3 2002/07/23 05:02:15 george Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/swig/swig-1.3.10-r2.ebuild,v 1.4 2002/08/02 04:44:54 seemant Exp $
S=${WORKDIR}/SWIG-${PV}
DESCRIPTION="Simplied Wrapper and Interface Generator"
@@ -26,17 +26,17 @@ src_compile() {
local myc
use python && myc="$myc --with-py" \
- || myc="$myc --without-py"
+ || myc="$myc --without-py"
use java && myc="$myc --with-java=$JAVA_HOME --with-javaincl=${JAVA_HOME}/include" \
- || myc="$myc --without-java"
+ || myc="$myc --without-java"
use ruby && myc="$myc --with-ruby=/usr/bin/ruby" \
- || myc="$myc --without-ruby"
+ || myc="$myc --without-ruby"
use guile && myc="$myc --with-guile" \
- || myc="$myc --without-guile"
+ || myc="$myc --without-guile"
use tcltk && myc="$myc --with-tcl" \
- || myc="$myc --without-tcl"
+ || myc="$myc --without-tcl"
use perl && myc="$myc --with-perl" \
- || myc="$myc --without-perl"
+ || myc="$myc --without-perl"
unset CXXFLAGS
unset CFLAGS
diff --git a/dev-lang/tcl/tcl-8.3.3-r1.ebuild b/dev-lang/tcl/tcl-8.3.3-r1.ebuild
index 7b3973b590f5..fb13b38872b2 100644
--- a/dev-lang/tcl/tcl-8.3.3-r1.ebuild
+++ b/dev-lang/tcl/tcl-8.3.3-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 2002 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License, v2 or later
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/tcl/tcl-8.3.3-r1.ebuild,v 1.6 2002/07/23 05:08:47 george Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/tcl/tcl-8.3.3-r1.ebuild,v 1.7 2002/08/02 04:44:54 seemant Exp $
S=${WORKDIR}/${PN}${PV}
@@ -46,10 +46,10 @@ src_install() {
# fix the tclConfig.sh to eliminate refs to the build directory
sed -e "s,^TCL_BUILD_LIB_SPEC='-L${S}/unix,TCL_BUILD_LIB_SPEC='-L/usr/lib," \
- -e "s,^TCL_SRC_DIR='${S}',TCL_SRC_DIR='/usr/lib/tcl${v1}/include'," \
- -e "s,^TCL_BUILD_STUB_LIB_SPEC='-L${S}/unix,TCL_BUILD_STUB_LIB_SPEC='-L/usr/lib," \
- -e "s,^TCL_BUILD_STUB_LIB_PATH='${S}/unix,TCL_BUILD_STUB_LIB_PATH='/usr/lib," \
- ${D}/usr/lib/tclConfig.sh > ${D}/usr/lib/tclConfig.sh.new
+ -e "s,^TCL_SRC_DIR='${S}',TCL_SRC_DIR='/usr/lib/tcl${v1}/include'," \
+ -e "s,^TCL_BUILD_STUB_LIB_SPEC='-L${S}/unix,TCL_BUILD_STUB_LIB_SPEC='-L/usr/lib," \
+ -e "s,^TCL_BUILD_STUB_LIB_PATH='${S}/unix,TCL_BUILD_STUB_LIB_PATH='/usr/lib," \
+ ${D}/usr/lib/tclConfig.sh > ${D}/usr/lib/tclConfig.sh.new
mv ${D}/usr/lib/tclConfig.sh.new ${D}/usr/lib/tclConfig.sh
# install private headers
diff --git a/dev-lang/tcl/tcl-8.3.3-r3.ebuild b/dev-lang/tcl/tcl-8.3.3-r3.ebuild
index e8b34a530d65..84fc6e681e0b 100644
--- a/dev-lang/tcl/tcl-8.3.3-r3.ebuild
+++ b/dev-lang/tcl/tcl-8.3.3-r3.ebuild
@@ -1,6 +1,6 @@
# Copyright 2002 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License, v2 or later
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/tcl/tcl-8.3.3-r3.ebuild,v 1.3 2002/07/23 05:08:47 george Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/tcl/tcl-8.3.3-r3.ebuild,v 1.4 2002/08/02 04:44:54 seemant Exp $
S=${WORKDIR}/${PN}${PV}
@@ -46,11 +46,11 @@ src_install() {
# fix the tclConfig.sh to eliminate refs to the build directory
sed -e "s,^TCL_BUILD_LIB_SPEC='-L${S}/unix,TCL_BUILD_LIB_SPEC='-L/usr/lib," \
- -e "s,^TCL_SRC_DIR='${S}',TCL_SRC_DIR='/usr/lib/tcl${v1}/include'," \
- -e "s,^TCL_BUILD_STUB_LIB_SPEC='-L${S}/unix,TCL_BUILD_STUB_LIB_SPEC='-L/usr/lib," \
- -e "s,^TCL_BUILD_STUB_LIB_PATH='${S}/unix,TCL_BUILD_STUB_LIB_PATH='/usr/lib," \
- -e "s,^TCL_LIB_FILE='libtcl8.3..TCL_DBGX..so',TCL_LIB_FILE=\"libtcl8.3\$\{TCL_DBGX\}.so\"," \
- ${D}/usr/lib/tclConfig.sh > ${D}/usr/lib/tclConfig.sh.new
+ -e "s,^TCL_SRC_DIR='${S}',TCL_SRC_DIR='/usr/lib/tcl${v1}/include'," \
+ -e "s,^TCL_BUILD_STUB_LIB_SPEC='-L${S}/unix,TCL_BUILD_STUB_LIB_SPEC='-L/usr/lib," \
+ -e "s,^TCL_BUILD_STUB_LIB_PATH='${S}/unix,TCL_BUILD_STUB_LIB_PATH='/usr/lib," \
+ -e "s,^TCL_LIB_FILE='libtcl8.3..TCL_DBGX..so',TCL_LIB_FILE=\"libtcl8.3\$\{TCL_DBGX\}.so\"," \
+ ${D}/usr/lib/tclConfig.sh > ${D}/usr/lib/tclConfig.sh.new
mv ${D}/usr/lib/tclConfig.sh.new ${D}/usr/lib/tclConfig.sh
# install private headers
diff --git a/dev-lang/tk/tk-8.3.3-r1.ebuild b/dev-lang/tk/tk-8.3.3-r1.ebuild
index eb8c0fe4692a..8ba816dd834e 100644
--- a/dev-lang/tk/tk-8.3.3-r1.ebuild
+++ b/dev-lang/tk/tk-8.3.3-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2002 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License, v2 or later
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/tk/tk-8.3.3-r1.ebuild,v 1.2 2002/08/01 11:59:01 seemant Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/tk/tk-8.3.3-r1.ebuild,v 1.3 2002/08/02 04:44:55 seemant Exp $
S=${WORKDIR}/${PN}${PV}
@@ -44,10 +44,10 @@ src_install() {
# fix the tkConfig.sh to eliminate refs to the build directory
sed -e "s,^TK_BUILD_LIB_SPEC='-L${S2}/unix,TCL_BUILD_LIB_SPEC='-L/usr/lib," \
- -e "s,^TK_SRC_DIR='${S2}',TCL_SRC_DIR='/usr/lib/tk${V2}/include'," \
- -e "s,^TK_BUILD_STUB_LIB_SPEC='-L${S2}/unix,TCL_BUILD_STUB_LIB_SPEC='-L/usr/lib," \
- -e "s,^TK_BUILD_STUB_LIB_PATH='${S2}/unix,TCL_BUILD_STUB_LIB_PATH='/usr/lib," \
- ${D}/usr/lib/tkConfig.sh > ${D}/usr/lib/tkConfig.sh.new
+ -e "s,^TK_SRC_DIR='${S2}',TCL_SRC_DIR='/usr/lib/tk${V2}/include'," \
+ -e "s,^TK_BUILD_STUB_LIB_SPEC='-L${S2}/unix,TCL_BUILD_STUB_LIB_SPEC='-L/usr/lib," \
+ -e "s,^TK_BUILD_STUB_LIB_PATH='${S2}/unix,TCL_BUILD_STUB_LIB_PATH='/usr/lib," \
+ ${D}/usr/lib/tkConfig.sh > ${D}/usr/lib/tkConfig.sh.new
mv ${D}/usr/lib/tkConfig.sh.new ${D}/usr/lib/tkConfig.sh
# install private headers
diff --git a/dev-lang/tk/tk-8.3.3.ebuild b/dev-lang/tk/tk-8.3.3.ebuild
index 063e6b5ec031..6e1b15e8f128 100644
--- a/dev-lang/tk/tk-8.3.3.ebuild
+++ b/dev-lang/tk/tk-8.3.3.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2002 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License, v2 or later
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/tk/tk-8.3.3.ebuild,v 1.6 2002/08/01 11:59:01 seemant Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/tk/tk-8.3.3.ebuild,v 1.7 2002/08/02 04:44:55 seemant Exp $
S=${WORKDIR}/${PN}${PV}
@@ -44,10 +44,10 @@ src_install() {
# fix the tkConfig.sh to eliminate refs to the build directory
sed -e "s,^TK_BUILD_LIB_SPEC='-L${S2}/unix,TCL_BUILD_LIB_SPEC='-L/usr/lib," \
- -e "s,^TK_SRC_DIR='${S2}',TCL_SRC_DIR='/usr/lib/tk${V2}/include'," \
- -e "s,^TK_BUILD_STUB_LIB_SPEC='-L${S2}/unix,TCL_BUILD_STUB_LIB_SPEC='-L/usr/lib," \
- -e "s,^TK_BUILD_STUB_LIB_PATH='${S2}/unix,TCL_BUILD_STUB_LIB_PATH='/usr/lib," \
- ${D}/usr/lib/tkConfig.sh > ${D}/usr/lib/tkConfig.sh.new
+ -e "s,^TK_SRC_DIR='${S2}',TCL_SRC_DIR='/usr/lib/tk${V2}/include'," \
+ -e "s,^TK_BUILD_STUB_LIB_SPEC='-L${S2}/unix,TCL_BUILD_STUB_LIB_SPEC='-L/usr/lib," \
+ -e "s,^TK_BUILD_STUB_LIB_PATH='${S2}/unix,TCL_BUILD_STUB_LIB_PATH='/usr/lib," \
+ ${D}/usr/lib/tkConfig.sh > ${D}/usr/lib/tkConfig.sh.new
mv ${D}/usr/lib/tkConfig.sh.new ${D}/usr/lib/tkConfig.sh
# install private headers