summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2014-08-14 01:45:51 +0000
committerMike Frysinger <vapier@gentoo.org>2014-08-14 01:45:51 +0000
commit79b8ef61a14a63e5fbbaef95d71bedc39c52fc89 (patch)
treeb60fc5ec01ae6c3eb271217ad87fe5eedd54b1e9 /dev-lang
parentBetter atom handling for package.use (diff)
downloadgentoo-2-79b8ef61a14a63e5fbbaef95d71bedc39c52fc89.tar.gz
gentoo-2-79b8ef61a14a63e5fbbaef95d71bedc39c52fc89.tar.bz2
gentoo-2-79b8ef61a14a63e5fbbaef95d71bedc39c52fc89.zip
Rewrite ebuild to fix many errors & merge the live/release versions.
(Portage version: 2.2.10/cvs/Linux x86_64, signed Manifest commit with key D2E96200)
Diffstat (limited to 'dev-lang')
-rw-r--r--dev-lang/jimtcl/ChangeLog9
-rw-r--r--dev-lang/jimtcl/files/jimtcl-0.75-bootstrap.patch15
-rw-r--r--dev-lang/jimtcl/jimtcl-0.75-r1.ebuild72
-rw-r--r--dev-lang/jimtcl/jimtcl-9999.ebuild64
4 files changed, 141 insertions, 19 deletions
diff --git a/dev-lang/jimtcl/ChangeLog b/dev-lang/jimtcl/ChangeLog
index b66fca5b3880..304d686aa57c 100644
--- a/dev-lang/jimtcl/ChangeLog
+++ b/dev-lang/jimtcl/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for dev-lang/jimtcl
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/jimtcl/ChangeLog,v 1.14 2014/06/10 00:21:53 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/jimtcl/ChangeLog,v 1.15 2014/08/14 01:45:51 vapier Exp $
+
+*jimtcl-0.75-r1 (14 Aug 2014)
+
+ 14 Aug 2014; Mike Frysinger <vapier@gentoo.org>
+ +files/jimtcl-0.75-bootstrap.patch, +jimtcl-0.75-r1.ebuild,
+ jimtcl-9999.ebuild:
+ Rewrite ebuild to fix many errors & merge the live/release versions.
10 Jun 2014; Mike Frysinger <vapier@gentoo.org> jimtcl-0.73.ebuild,
jimtcl-0.74-r1.ebuild, jimtcl-0.75.ebuild:
diff --git a/dev-lang/jimtcl/files/jimtcl-0.75-bootstrap.patch b/dev-lang/jimtcl/files/jimtcl-0.75-bootstrap.patch
new file mode 100644
index 000000000000..60850e0b6d0b
--- /dev/null
+++ b/dev-lang/jimtcl/files/jimtcl-0.75-bootstrap.patch
@@ -0,0 +1,15 @@
+always do a bootstrap w/local jimsh0 to avoid requiring tcl or jimtcl
+to be installed first. the bootstrap prog is small too.
+
+--- a/autosetup/find-tclsh
++++ b/autosetup/find-tclsh
+@@ -4,9 +4,6 @@
+ d=`dirname "$0"`
+ { "$d/jimsh0" "$d/test-tclsh"; } 2>/dev/null && exit 0
+ PATH="$PATH:$d"; export PATH
+-for tclsh in jimsh tclsh tclsh8.5 tclsh8.6; do
+- { $tclsh "$d/test-tclsh"; } 2>/dev/null && exit 0
+-done
+ echo 1>&2 "No installed jimsh or tclsh, building local bootstrap jimsh0"
+ for cc in ${CC_FOR_BUILD:-cc} gcc; do
+ { $cc -o "$d/jimsh0" "$d/jimsh0.c"; } 2>/dev/null || continue
diff --git a/dev-lang/jimtcl/jimtcl-0.75-r1.ebuild b/dev-lang/jimtcl/jimtcl-0.75-r1.ebuild
new file mode 100644
index 000000000000..42a1209affd9
--- /dev/null
+++ b/dev-lang/jimtcl/jimtcl-0.75-r1.ebuild
@@ -0,0 +1,72 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/jimtcl/jimtcl-0.75-r1.ebuild,v 1.1 2014/08/14 01:45:51 vapier Exp $
+
+EAPI="5"
+
+inherit multiprocessing eutils
+
+if [[ ${PV} == "9999" ]] ; then
+ EGIT_REPO_URI="http://repo.or.cz/r/jimtcl.git"
+ inherit git-2
+else
+ inherit vcs-snapshot
+ SRC_URI="https://github.com/msteveb/jimtcl/zipball/${PV} -> ${P}.zip"
+ KEYWORDS="~amd64 ~arm ~arm64 ~m68k ~mips ~s390 ~sh ~x86"
+fi
+
+DESCRIPTION="Small footprint implementation of Tcl programming language"
+HOMEPAGE="http://jim.tcl.tk/"
+
+LICENSE="LGPL-2"
+SLOT="0"
+IUSE="doc static-libs"
+
+RDEPEND=""
+DEPEND="doc? ( app-text/asciidoc )
+ app-arch/unzip"
+
+src_unpack() {
+ if [[ ${PV} == "9999" ]] ; then
+ git-2_src_unpack
+ else
+ default
+ cd "${WORKDIR}"/msteveb-jimtcl-*
+ S=${PWD}
+ fi
+}
+
+src_prepare() {
+ epatch "${FILESDIR}"/${PN}-0.75-bootstrap.patch
+}
+
+src_configure() {
+ multijob_init
+ CCACHE=None multijob_child_init econf --with-jim-shared
+ if use static-libs ; then
+ # The build does not support doing both simultaneously.
+ mkdir static-libs
+ cd static-libs
+ CCACHE=None ECONF_SOURCE=${S} multijob_child_init econf
+ fi
+ multijob_finish
+}
+
+src_compile() {
+ # Must build static-libs first.
+ use static-libs && emake -C static-libs libjim.a
+ emake all
+ use doc && emake docs
+}
+
+src_install() {
+ dobin jimsh
+ use static-libs && dolib.a static-libs/libjim.a
+ ln -sf libjim.so.* libjim.so
+ dolib.so libjim.so*
+ insinto /usr/include
+ doins jim.h jimautoconf.h jim-subcmd.h jim-signal.h \
+ jim-win32compat.h jim-eventloop.h jim-config.h
+ dodoc AUTHORS README TODO
+ use doc && dohtml Tcl.html
+}
diff --git a/dev-lang/jimtcl/jimtcl-9999.ebuild b/dev-lang/jimtcl/jimtcl-9999.ebuild
index f73fa4ac23f1..fe7855a8cba1 100644
--- a/dev-lang/jimtcl/jimtcl-9999.ebuild
+++ b/dev-lang/jimtcl/jimtcl-9999.ebuild
@@ -1,44 +1,72 @@
-# Copyright 1999-2013 Gentoo Foundation
+# Copyright 1999-2014 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/jimtcl/jimtcl-9999.ebuild,v 1.8 2013/09/17 19:16:49 hwoarang Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/jimtcl/jimtcl-9999.ebuild,v 1.9 2014/08/14 01:45:51 vapier Exp $
-EAPI="4"
+EAPI="5"
-inherit multilib git-2
+inherit multiprocessing eutils
+
+if [[ ${PV} == "9999" ]] ; then
+ EGIT_REPO_URI="http://repo.or.cz/r/jimtcl.git"
+ inherit git-2
+else
+ inherit vcs-snapshot
+ SRC_URI="https://github.com/msteveb/jimtcl/zipball/${PV} -> ${P}.zip"
+ KEYWORDS="~amd64 ~arm ~arm64 ~m68k ~mips ~s390 ~sh ~x86"
+fi
DESCRIPTION="Small footprint implementation of Tcl programming language"
-HOMEPAGE="http://jim.tcl.tk"
-EGIT_REPO_URI="http://repo.or.cz/r/jimtcl.git"
+HOMEPAGE="http://jim.tcl.tk/"
LICENSE="LGPL-2"
SLOT="0"
-KEYWORDS=""
IUSE="doc static-libs"
+
+RDEPEND=""
DEPEND="doc? ( app-text/asciidoc )
app-arch/unzip"
+src_unpack() {
+ if [[ ${PV} == "9999" ]] ; then
+ git-2_src_unpack
+ else
+ default
+ cd "${WORKDIR}"/msteveb-jimtcl-*
+ S=${PWD}
+ fi
+}
+
+src_prepare() {
+ epatch "${FILESDIR}"/${PN}-0.75-bootstrap.patch
+}
+
src_configure() {
- ! use static-libs && myconf=--with-jim-shared
- econf ${myconf}
+ multijob_init
+ CCACHE=None multijob_child_init econf --with-jim-shared
+ if use static-libs ; then
+ # The build does not support doing both simultaneously.
+ mkdir static-libs
+ cd static-libs
+ CCACHE=None ECONF_SOURCE=${S} multijob_child_init econf
+ fi
+ multijob_finish
}
src_compile() {
+ # Must build static-libs first.
+ use static-libs && emake -C static-libs libjim.a
emake all
use doc && emake docs
}
src_install() {
dobin jimsh
- use static-libs && {
- dolib.a libjim.a
- } || {
- dolib.so libjim.so*
- dosym /usr/$(get_libdir)/libjim.so* \
- /usr/$(get_libdir)/libjim.so
- }
+ use static-libs && dolib.a static-libs/libjim.a
+ ln -sf libjim.so.* libjim.so
+ dolib.so libjim.so*
insinto /usr/include
- doins jim.h jimautoconf.h jim-subcmd.h jim-signal.h
- doins jim-win32compat.h jim-eventloop.h jim-config.h
+ doins jim.h jimautoconf.h jim-subcmd.h jim-signal.h \
+ jim-win32compat.h jim-eventloop.h jim-config.h
dodoc AUTHORS README TODO
use doc && dohtml Tcl.html
}