summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDavid Holm <dholm@gentoo.org>2004-02-28 16:03:42 +0000
committerDavid Holm <dholm@gentoo.org>2004-02-28 16:03:42 +0000
commit67a56bd29e27d951cab2a1f1a2895a7d399c203a (patch)
treed6cc6c497a1c16ad58f6c8ed72a01724097ef076 /dev-lang
parentversion bump (Manifest recommit) (diff)
downloadgentoo-2-67a56bd29e27d951cab2a1f1a2895a7d399c203a.tar.gz
gentoo-2-67a56bd29e27d951cab2a1f1a2895a7d399c203a.tar.bz2
gentoo-2-67a56bd29e27d951cab2a1f1a2895a7d399c203a.zip
Fixed some ebuild issues thanks to Mr Bones
Diffstat (limited to 'dev-lang')
-rw-r--r--dev-lang/pasm/pasm-1.6c.ebuild13
1 files changed, 6 insertions, 7 deletions
diff --git a/dev-lang/pasm/pasm-1.6c.ebuild b/dev-lang/pasm/pasm-1.6c.ebuild
index 55e4609ed1a6..47d70182d8bc 100644
--- a/dev-lang/pasm/pasm-1.6c.ebuild
+++ b/dev-lang/pasm/pasm-1.6c.ebuild
@@ -1,10 +1,10 @@
# Copyright 1999-2004 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/pasm/pasm-1.6c.ebuild,v 1.1 2004/02/28 15:37:38 dholm Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/pasm/pasm-1.6c.ebuild,v 1.2 2004/02/28 16:03:42 dholm Exp $
+inherit eutils
-S="${WORKDIR}/${P}"
-DESCRIPTION="pasm is a portable assembler for processors of the PowerPC family."
+DESCRIPTION="A portable assembler for processors of the PowerPC family"
SRC_URI="http://devnull.owl.de/~frank/${PN}.tar.gz"
HOMEPAGE="http://devnull.owl.de/~frank/pasm_e.html"
LICENSE="GPL-2"
@@ -13,7 +13,6 @@ IUSE=""
KEYWORDS="~ppc"
src_unpack() {
- mkdir -p ${S}
mkdir -p ${S}/LinuxPPC
cd ${S}
unpack ${A}
@@ -21,10 +20,10 @@ src_unpack() {
}
src_compile() {
- emake || die
+ emake || die "Compilation failed"
}
src_install () {
- dobin pasm
- dodoc pasm.doc
+ dobin pasm || die "Failed to install pasm binary"
+ dodoc pasm.doc || die "Failed to install pasm documentation"
}