summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGeorge Shapovalov <george@gentoo.org>2008-06-10 07:29:10 +0000
committerGeorge Shapovalov <george@gentoo.org>2008-06-10 07:29:10 +0000
commit5ad3ab11975ab5a35b17e27af4ae5a75a54c0f19 (patch)
tree21219e1d875b8a74d9c4874d4bc08576739ccd9a /dev-lang
parentAdd radeonhd. (diff)
downloadgentoo-2-5ad3ab11975ab5a35b17e27af4ae5a75a54c0f19.tar.gz
gentoo-2-5ad3ab11975ab5a35b17e27af4ae5a75a54c0f19.tar.bz2
gentoo-2-5ad3ab11975ab5a35b17e27af4ae5a75a54c0f19.zip
new version out
(Portage version: 2.1.5.3)
Diffstat (limited to 'dev-lang')
-rw-r--r--dev-lang/gnat-gcc/ChangeLog7
-rw-r--r--dev-lang/gnat-gcc/gnat-gcc-4.3.1.ebuild54
2 files changed, 60 insertions, 1 deletions
diff --git a/dev-lang/gnat-gcc/ChangeLog b/dev-lang/gnat-gcc/ChangeLog
index 287e2065a8f8..00ab713cb74c 100644
--- a/dev-lang/gnat-gcc/ChangeLog
+++ b/dev-lang/gnat-gcc/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-lang/gnat-gcc
# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/gnat-gcc/ChangeLog,v 1.24 2008/03/17 12:37:50 coldwind Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/gnat-gcc/ChangeLog,v 1.25 2008/06/10 07:29:10 george Exp $
+
+*gnat-gcc-4.3.1 (10 Jun 2008)
+
+ 10 Jun 2008; George Shapovalov <george@gentoo.org> +gnat-gcc-4.3.1.ebuild:
+ new version out
17 Mar 2008; Santiago M. Mola <coldwind@gentoo.org> gnat-gcc-3.4.6.ebuild,
gnat-gcc-4.2.2.ebuild:
diff --git a/dev-lang/gnat-gcc/gnat-gcc-4.3.1.ebuild b/dev-lang/gnat-gcc/gnat-gcc-4.3.1.ebuild
new file mode 100644
index 000000000000..ed601defd816
--- /dev/null
+++ b/dev-lang/gnat-gcc/gnat-gcc-4.3.1.ebuild
@@ -0,0 +1,54 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/gnat-gcc/gnat-gcc-4.3.1.ebuild,v 1.1 2008/06/10 07:29:10 george Exp $
+
+inherit gnatbuild
+
+DESCRIPTION="GNAT Ada Compiler - gcc version"
+HOMEPAGE="http://gcc.gnu.org/"
+LICENSE="GMGPL"
+
+# overriding the BOOT_SLOT, as 4.1 should do fine, no need for bootstrap duplication
+BOOT_SLOT="4.1"
+
+# SLOT is set in gnatbuild.eclass, depends only on PV (basically SLOT=GCCBRANCH)
+# so the URI's are static.
+SRC_URI="ftp://gcc.gnu.org/pub/gcc/releases/gcc-${PV}/gcc-core-${PV}.tar.bz2
+ ftp://gcc.gnu.org/pub/gcc/releases/gcc-${PV}/gcc-ada-${PV}.tar.bz2
+ ppc? ( mirror://gentoo/gnatboot-${BOOT_SLOT}-ppc.tar.bz2 )
+ x86? ( mirror://gentoo/gnatboot-${BOOT_SLOT}-i386.tar.bz2 )
+ amd64? ( mirror://gentoo/gnatboot-${BOOT_SLOT}-amd64.tar.bz2 )"
+
+KEYWORDS="~amd64 ~ppc ~x86"
+
+QA_EXECSTACK="${BINPATH:1}/gnatls ${BINPATH:1}/gnatbind ${BINPATH:1}/gnatmake
+ ${LIBEXECPATH:1}/gnat1 ${LIBPATH:1}/adalib/libgnat-${SLOT}.so"
+
+src_unpack() {
+ gnatbuild_src_unpack
+
+ #fixup some hardwired flags
+ cd "${S}"/gcc/ada
+
+ # universal gcc -> gnatgcc substitution occasionally produces lines too long
+ # and then build halts on the style check.
+ #
+ # The sed in makegpr.adb is actually not for the line length but rather to
+ # "undo" the fixing, Last3 is matching just that - the last three characters
+ # of the compiler name.
+ sed -i -e 's:(Last3 = "gnatgcc"):(Last3 = "gcc"):' makegpr.adb &&
+ sed -i -e 's:and Nam is "gnatgcc":and Nam is "gcc":' osint.ads ||
+ die "reversing [gnat]gcc substitution in comments failed"
+
+ # Looks like old bootstrap cannot process new C syntax..
+ sed -i -e "/-DREVISION/d" -e "/-DDEVPHASE/d" \
+ -e "s: -DDATESTAMP=\$(DATESTAMP_s)::" "${S}"/gcc/Makefile.in
+ sed -i -e "s: DATESTAMP DEVPHASE REVISION::" \
+ -e "s:PKGVERSION:\"\":" "${S}"/gcc/version.c
+}
+
+src_compile() {
+ # looks like gnatlib_and_tools and gnatlib_shared have become part of
+ # bootstrap
+ gnatbuild_src_compile configure make-tools bootstrap
+}