summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrick Kursawe <phosphan@gentoo.org>2004-04-01 09:43:28 +0000
committerPatrick Kursawe <phosphan@gentoo.org>2004-04-01 09:43:28 +0000
commit57df5c2c8f2e94fb6a7e30e5ebb0edfac138b783 (patch)
tree57d29c487c630c72c26b06c7323ac7bc49f942c1 /dev-lang
parentmore descriptive DESCRIPTION (Manifest recommit) (diff)
downloadgentoo-2-57df5c2c8f2e94fb6a7e30e5ebb0edfac138b783.tar.gz
gentoo-2-57df5c2c8f2e94fb6a7e30e5ebb0edfac138b783.tar.bz2
gentoo-2-57df5c2c8f2e94fb6a7e30e5ebb0edfac138b783.zip
1.8.1 is stable
Diffstat (limited to 'dev-lang')
-rw-r--r--dev-lang/R/ChangeLog6
-rw-r--r--dev-lang/R/R-1.8.0.ebuild105
-rw-r--r--dev-lang/R/R-1.8.1.ebuild8
-rw-r--r--dev-lang/R/files/digest-R-1.8.01
4 files changed, 10 insertions, 110 deletions
diff --git a/dev-lang/R/ChangeLog b/dev-lang/R/ChangeLog
index bf4d561c0b61..4647b77853c7 100644
--- a/dev-lang/R/ChangeLog
+++ b/dev-lang/R/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for dev-lang/R
# Copyright 2002-2004 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/R/ChangeLog,v 1.16 2004/03/22 11:23:17 phosphan Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/R/ChangeLog,v 1.17 2004/04/01 09:43:28 phosphan Exp $
+
+ 01 Apr 2004; Patrick Kursawe <phosphan@gentoo.org> R-1.8.0.ebuild,
+ R-1.8.1.ebuild:
+ 1.8.1 is stable
22 Mar 2004; Patrick Kursawe <phosphan@gentoo.org> R-1.8.1.ebuild:
Fixing bug #40100 (problems with newer Xfree)
diff --git a/dev-lang/R/R-1.8.0.ebuild b/dev-lang/R/R-1.8.0.ebuild
deleted file mode 100644
index c31818971db7..000000000000
--- a/dev-lang/R/R-1.8.0.ebuild
+++ /dev/null
@@ -1,105 +0,0 @@
-# Copyright 1999-2004 Gentoo Technologies, Inc.
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/R/R-1.8.0.ebuild,v 1.3 2004/02/25 07:25:48 phosphan Exp $
-
-IUSE="atlas X tcltk gnome"
-
-S=${WORKDIR}/${P}
-
-DESCRIPTION="R is GNU S - A language and environment for statistical computing and graphics."
-
-SRC_URI="http://cran.r-project.org/src/base/${P}.tgz"
-
- #There are daily release patches, don't know how to utilize these
- #"ftp://ftp.stat.math.ethz.ch/Software/${PN}/${PN}-release.diff.gz"
-
-HOMEPAGE="http://www.r-project.org/"
-
-DEPEND="virtual/glibc
- >=dev-lang/perl-5.6.1-r3
- >=sys-libs/readline-4.1-r3
- >=sys-libs/zlib-1.1.3-r2
- >=media-libs/jpeg-6b-r2
- >=media-libs/libpng-1.2.1
- atlas? ( dev-libs/atlas )
- X? ( virtual/x11 )
- tcltk? ( dev-lang/tk )
- gnome? ( >=gnome-base/gnome-libs-1.4.1.4
- =gnome-base/libglade-0.17*
- >=dev-libs/libxml-1.8.16
- >=gnome-base/ORBit-0.5.12
- >=media-libs/imlib-1.9.10
- >=x11-libs/gtk+-1.2.10
- >=dev-libs/glib-1.2.10
- >=media-sound/esound-0.2.23
- >=media-libs/audiofile-0.2.1 )"
-
-SLOT="0"
-LICENSE="GPL-2 LGPL-2.1"
-KEYWORDS="x86 sparc ppc"
-
-src_compile() {
-
- local myconf="--enable-R-profiling --enable-R-shlib --with-readline"
-
- #Eventually, we will want to take into account that a user may have
- #an alternate or additional blas libraries,
- #i.e. USE variable blas and and virtual/blas
- use atlas || myconf="${myconf} --without-blas" #default enabled
-
- use X || myconf="${myconf} --without-x" #default enabled
-
- if use tcltk; then
- #configure needs to find the files tclConfig.sh and tkConfig.sh
- myconf="${myconf} --with-tcltk --with-tcl-config=/usr/lib/tclConfig.sh --with-tk-config=/usr/lib/tkConfig.sh"
- else
- myconf="${myconf} --without-tcltk"
- fi
-
- use gnome && myconf="${myconf} --with-gnome" #default disabled
-
- ./configure \
- --host=${CHOST} \
- --prefix=/usr \
- --infodir=/usr/share/info \
- --mandir=/usr/share/man \
- ${myconf} || die "./configure failed"
-
- make || die
-
-}
-
-src_install () {
-
- make \
- prefix=${D}/usr \
- mandir=${D}/usr/share/man \
- infodir=${D}/usr/share/info \
- install || die "Installation Failed"
-
- #fix the R wrapper script to have the correct R_HOME_DIR
- #sed regexp borrowed from included debian rules
- cp ${D}/usr/lib/R/bin/R ${S}/bin/R.orig
- sed -e '/^R_HOME_DIR=.*/s::R_HOME_DIR=/usr/lib/R:' \
- ${S}/bin/R.orig > ${D}/usr/lib/R/bin/R
-
- #R installs two identical wrappers under /usr/bin and /usr/lib/R/bin/
- #the 2nd one is corrected by above sed, for the 1st
- #I'll just symlink it into /usr/bin
- cd ${D}/usr/bin/
- rm R
- dosym ../lib/R/bin/R /usr/bin/R
- cd ${S}
-
- dodoc AUTHORS BUGS COPYING* ChangeLog FAQ INSTALL *NEWS README \
- RESOURCES THANKS VERSION Y2K
-
- #Add rudimentary menu entry if gnome
- if use gnome; then
- insinto /usr/share/gnome/apps/Applications
- doins ${FILESDIR}/R.desktop
- insinto /usr/share/pixmaps
- doins ${FILESDIR}/R-logo.png
- fi
-
-}
diff --git a/dev-lang/R/R-1.8.1.ebuild b/dev-lang/R/R-1.8.1.ebuild
index bbed92a564dc..16e039cde181 100644
--- a/dev-lang/R/R-1.8.1.ebuild
+++ b/dev-lang/R/R-1.8.1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/R/R-1.8.1.ebuild,v 1.3 2004/03/22 11:23:17 phosphan Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/R/R-1.8.1.ebuild,v 1.4 2004/04/01 09:43:28 phosphan Exp $
IUSE="atlas X tcltk gnome"
@@ -19,7 +19,9 @@ DEPEND="virtual/glibc
>=sys-libs/zlib-1.1.3-r2
>=media-libs/jpeg-6b-r2
>=media-libs/libpng-1.2.1
- atlas? ( dev-libs/atlas )
+ x86? ( atlas? ( dev-libs/atlas ) )
+ sparc? ( atlas? ( dev-libs/atlas ) )
+ ~amd64? ( atlas? ( dev-libs/atlas ) )
X? ( virtual/x11 )
tcltk? ( dev-lang/tk )
gnome? ( >=gnome-base/gnome-libs-1.4.1.4
@@ -34,7 +36,7 @@ DEPEND="virtual/glibc
SLOT="0"
LICENSE="GPL-2 LGPL-2.1"
-KEYWORDS="~x86 ~sparc ~ppc ~amd64"
+KEYWORDS="x86 sparc ppc amd64"
src_unpack() {
unpack ${A}
diff --git a/dev-lang/R/files/digest-R-1.8.0 b/dev-lang/R/files/digest-R-1.8.0
deleted file mode 100644
index bf99be3f3c5a..000000000000
--- a/dev-lang/R/files/digest-R-1.8.0
+++ /dev/null
@@ -1 +0,0 @@
-MD5 bb019d7e12e38ac8a8bc247f06cc6b42 R-1.8.0.tgz 9379849