summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGeert Bevin <gbevin@gentoo.org>2002-04-07 13:36:44 +0000
committerGeert Bevin <gbevin@gentoo.org>2002-04-07 13:36:44 +0000
commit3ad7e56693810f0e8a77096cb8a20ae67a63d810 (patch)
tree96c8f54953e29b4bb372080d1998f80c635e9f2e /dev-lang
parentsmall fix (diff)
downloadgentoo-2-3ad7e56693810f0e8a77096cb8a20ae67a63d810.tar.gz
gentoo-2-3ad7e56693810f0e8a77096cb8a20ae67a63d810.tar.bz2
gentoo-2-3ad7e56693810f0e8a77096cb8a20ae67a63d810.zip
added slots
Diffstat (limited to 'dev-lang')
-rw-r--r--dev-lang/python/python-2.0-r5.ebuild4
-rw-r--r--dev-lang/python/python-2.0-r6.ebuild4
-rw-r--r--dev-lang/python/python-2.0-r7.ebuild4
-rw-r--r--dev-lang/python/python-2.1.1-r3.ebuild4
-rw-r--r--dev-lang/python/python-2.1.1-r4.ebuild4
-rw-r--r--dev-lang/python/python-2.2-r4.ebuild4
6 files changed, 18 insertions, 6 deletions
diff --git a/dev-lang/python/python-2.0-r5.ebuild b/dev-lang/python/python-2.0-r5.ebuild
index 55a7ba61e944..c9d303c9b855 100644
--- a/dev-lang/python/python-2.0-r5.ebuild
+++ b/dev-lang/python/python-2.0-r5.ebuild
@@ -3,7 +3,7 @@
# Author Daniel Robbins <drobbins@gentoo.org>
# Modified Tod M. Neidt <tneidt@fidnet.com>
# /home/cvsroot/gentoo-x86/dev-lang/python/python-2.0-r4.ebuild,v 1.1 2001/06/04 19:49:02 drobbins Exp
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/python/python-2.0-r5.ebuild,v 1.1 2001/10/20 16:08:33 danarmak Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/python/python-2.0-r5.ebuild,v 1.2 2002/04/07 13:32:59 gbevin Exp $
S=${WORKDIR}/Python-2.0
@@ -23,6 +23,8 @@ DEPEND="virtual/glibc >=sys-libs/zlib-1.1.3
RDEPEND="$DEPEND"
PROVIDE="virtual/python-2.0"
+SLOT="2"
+
src_unpack() {
local mylibs
unpack BeOpen-Python-2.0.tar.bz2
diff --git a/dev-lang/python/python-2.0-r6.ebuild b/dev-lang/python/python-2.0-r6.ebuild
index 1e4f65f3c36a..c687fba8e2ab 100644
--- a/dev-lang/python/python-2.0-r6.ebuild
+++ b/dev-lang/python/python-2.0-r6.ebuild
@@ -3,7 +3,7 @@
# Author Daniel Robbins <drobbins@gentoo.org>
# Modified Tod M. Neidt <tneidt@fidnet.com>
# /home/cvsroot/gentoo-x86/dev-lang/python/python-2.0-r4.ebuild,v 1.1 2001/06/04 19:49:02 drobbins Exp
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/python/python-2.0-r6.ebuild,v 1.3 2001/11/08 18:04:51 achim Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/python/python-2.0-r6.ebuild,v 1.4 2002/04/07 13:32:59 gbevin Exp $
S=${WORKDIR}/Python-2.0
@@ -23,6 +23,8 @@ DEPEND="virtual/glibc >=sys-libs/zlib-1.1.3
RDEPEND="$DEPEND"
PROVIDE="virtual/python-2.0"
+SLOT="2"
+
src_unpack() {
local mylibs
unpack BeOpen-Python-2.0.tar.bz2
diff --git a/dev-lang/python/python-2.0-r7.ebuild b/dev-lang/python/python-2.0-r7.ebuild
index a0f827c52819..4332fb4bac5e 100644
--- a/dev-lang/python/python-2.0-r7.ebuild
+++ b/dev-lang/python/python-2.0-r7.ebuild
@@ -3,7 +3,7 @@
# Author Daniel Robbins <drobbins@gentoo.org>
# Modified Tod M. Neidt <tneidt@fidnet.com>
# /home/cvsroot/gentoo-x86/dev-lang/python/python-2.0-r4.ebuild,v 1.1 2001/06/04 19:49:02 drobbins Exp
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/python/python-2.0-r7.ebuild,v 1.1 2002/01/15 01:27:50 gbevin Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/python/python-2.0-r7.ebuild,v 1.2 2002/04/07 13:32:59 gbevin Exp $
S=${WORKDIR}/Python-2.0
@@ -23,6 +23,8 @@ DEPEND="virtual/glibc >=sys-libs/zlib-1.1.3
RDEPEND="$DEPEND"
PROVIDE="virtual/python-2.0"
+SLOT="2"
+
src_unpack() {
local mylibs
unpack BeOpen-Python-2.0.tar.bz2
diff --git a/dev-lang/python/python-2.1.1-r3.ebuild b/dev-lang/python/python-2.1.1-r3.ebuild
index fd5d5cf91283..f53c464f573d 100644
--- a/dev-lang/python/python-2.1.1-r3.ebuild
+++ b/dev-lang/python/python-2.1.1-r3.ebuild
@@ -1,7 +1,7 @@
# Copyright 1999-2002 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License, v2 or later
# Maintainer: Daniel Robbins <drobbins@gentoo.org>
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/python/python-2.1.1-r3.ebuild,v 1.1 2001/12/06 22:12:34 drobbins Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/python/python-2.1.1-r3.ebuild,v 1.2 2002/04/07 13:32:59 gbevin Exp $
S=${WORKDIR}/Python-${PV}
FCHKSUM="python-fchksum-1.6"
@@ -19,6 +19,8 @@ DEPEND="virtual/glibc >=sys-libs/zlib-1.1.3
RDEPEND="$DEPEND"
PROVIDE="virtual/python-2.1"
+SLOT="2.1"
+
src_unpack() {
# unpack python
unpack Python-${PV}.tgz
diff --git a/dev-lang/python/python-2.1.1-r4.ebuild b/dev-lang/python/python-2.1.1-r4.ebuild
index ccdf39ee3cdd..7f7005ae0b4c 100644
--- a/dev-lang/python/python-2.1.1-r4.ebuild
+++ b/dev-lang/python/python-2.1.1-r4.ebuild
@@ -1,7 +1,7 @@
# Copyright 1999-2002 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License, v2 or later
# Maintainer: Daniel Robbins <drobbins@gentoo.org>
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/python/python-2.1.1-r4.ebuild,v 1.1 2002/01/15 01:27:50 gbevin Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/python/python-2.1.1-r4.ebuild,v 1.2 2002/04/07 13:33:00 gbevin Exp $
S=${WORKDIR}/Python-${PV}
FCHKSUM="python-fchksum-1.6"
@@ -19,6 +19,8 @@ DEPEND="virtual/glibc >=sys-libs/zlib-1.1.3
RDEPEND="$DEPEND"
PROVIDE="virtual/python-2.1"
+SLOT="2.1"
+
src_unpack() {
# unpack python
unpack Python-${PV}.tgz
diff --git a/dev-lang/python/python-2.2-r4.ebuild b/dev-lang/python/python-2.2-r4.ebuild
index 8c55847f00a1..afd9a2261a5c 100644
--- a/dev-lang/python/python-2.2-r4.ebuild
+++ b/dev-lang/python/python-2.2-r4.ebuild
@@ -1,7 +1,7 @@
# Copyright 1999-2002 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License, v2 or later
# Maintainer: Daniel Robbins <drobbins@gentoo.org>
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/python/python-2.2-r4.ebuild,v 1.3 2002/04/07 05:52:01 drobbins Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/python/python-2.2-r4.ebuild,v 1.4 2002/04/07 13:33:00 gbevin Exp $
PYVER="`echo ${PV} | cut -d '.' -f 1,2`"
S=${WORKDIR}/Python-${PV}
@@ -22,6 +22,8 @@ DEPEND="virtual/glibc >=sys-libs/zlib-1.1.3
RDEPEND="$DEPEND"
PROVIDE="virtual/python"
+SLOT="2.2"
+
src_unpack() {
# unpack python
unpack Python-${PV}.tgz