summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndres Loeh <kosmikus@gentoo.org>2003-07-31 10:49:41 +0000
committerAndres Loeh <kosmikus@gentoo.org>2003-07-31 10:49:41 +0000
commit350901742842fbf4ca8cba9188d219807655bba3 (patch)
treee1bac2270deb6062ca12612bc9e8f195559970c2 /dev-lang
parentghc 6.0.1 is out (diff)
downloadgentoo-2-350901742842fbf4ca8cba9188d219807655bba3.tar.gz
gentoo-2-350901742842fbf4ca8cba9188d219807655bba3.tar.bz2
gentoo-2-350901742842fbf4ca8cba9188d219807655bba3.zip
ghc 6.0.1 is out
Diffstat (limited to 'dev-lang')
-rw-r--r--dev-lang/ghc/ChangeLog7
-rw-r--r--dev-lang/ghc/Manifest4
-rw-r--r--dev-lang/ghc/files/digest-ghc-6.0.11
-rw-r--r--dev-lang/ghc/ghc-6.0.1.ebuild142
4 files changed, 151 insertions, 3 deletions
diff --git a/dev-lang/ghc/ChangeLog b/dev-lang/ghc/ChangeLog
index d8f3114d4c3a..a9f60b90f695 100644
--- a/dev-lang/ghc/ChangeLog
+++ b/dev-lang/ghc/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-lang/ghc
# Copyright 2002-2003 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/ghc/ChangeLog,v 1.18 2003/07/29 23:21:27 kosmikus Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/ghc/ChangeLog,v 1.19 2003/07/31 10:49:24 kosmikus Exp $
+
+*ghc-6.0.1 (31 Jul 2003)
+
+ 31 Jul 2003; Andres Loeh <kosmikus@gentoo.org> ghc-6.0.1.ebuild:
+ Version bump.
30 Jul 2003; Andres Loeh <kosmikus@gentoo.org> ghc-6.0.ebuild:
Fixed bug that caused ghc to be built with HOpenGL despite -opengl being set.
diff --git a/dev-lang/ghc/Manifest b/dev-lang/ghc/Manifest
index c17e86b75ebf..d325d2b7841a 100644
--- a/dev-lang/ghc/Manifest
+++ b/dev-lang/ghc/Manifest
@@ -4,8 +4,8 @@ MD5 d1ee334700eb465393538865978531b5 ghc-5.04.ebuild 6950
MD5 b6e8ef3b1bab47650ac6a3134e931375 ghc-6.0.ebuild 4262
MD5 4e310a2cb7f0093cd85d9a366f2337cc ghc-5.04.2.ebuild 4536
MD5 42b857369c2e24507f00520e99fdaf5a ghc-5.02.3.ebuild 7646
-MD5 b6e8ef3b1bab47650ac6a3134e931375 ghc-6.0.1.ebuild 4262
-MD5 563ac6caa663695b8b28da0328016cc2 ChangeLog 4870
+MD5 fa326cb3c1499ef73016242e06a243e9 ghc-6.0.1.ebuild 4264
+MD5 31e212a04c2d364e65c4835ef257365d ChangeLog 4980
MD5 9da9270be8ac4d92d6a5c23fd519cc3c files/lndir.c 8050
MD5 cc8947705ec2b2a685edb4eefddeebc2 files/ghc-5.02.3-gentoo.patch.bz2 14489
MD5 1c126024044290a2f7e501c0f4415169 files/ghc-5.04-gentoo.patch.bz2 68891
diff --git a/dev-lang/ghc/files/digest-ghc-6.0.1 b/dev-lang/ghc/files/digest-ghc-6.0.1
new file mode 100644
index 000000000000..3ab666612440
--- /dev/null
+++ b/dev-lang/ghc/files/digest-ghc-6.0.1
@@ -0,0 +1 @@
+MD5 6e258de758b34905ecfc636a38fa9e23 ghc-6.0.1-src.tar.bz2 5265055
diff --git a/dev-lang/ghc/ghc-6.0.1.ebuild b/dev-lang/ghc/ghc-6.0.1.ebuild
new file mode 100644
index 000000000000..0bccf18b884a
--- /dev/null
+++ b/dev-lang/ghc/ghc-6.0.1.ebuild
@@ -0,0 +1,142 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/ghc/ghc-6.0.1.ebuild,v 1.1 2003/07/31 10:49:24 kosmikus Exp $
+
+#Some explanation of bootstrap logic:
+#
+#After thinking through the best way to bootstrap ghc I decided to split it into
+#ghc and ghc-bin and make ghc depend on ghc-bin.
+# The ebuild has been revamped and greatly simplified. Bootstrap off old 4x hc files no longer works on x86.
+#Not sure what happens with old scheme on sparc, as I did not see any test reports.
+#
+#The considerations:
+#Making ghc unpack binary build first (under ${WORKDIR}) and bootstrapping from that will effectively force
+#ghc-bin reinstall every time ghc is rebuilt or upgraded. What is worse it will likely force download of binary image
+#at upgrade, which is not nice (in fact quite bad for modem users - 16+ MB).
+#
+#The best results are achieved if ghc-bin is left alone after ghc installation -
+#Both ebuilds install in the same place, thus space penalty is minimal. In fact only the docs exist in double
+#(considering that ghc is not installing much docs at present this looks more like an advantage).
+#When the upgrade time comes, if you still have ghc-bin around, portage will happily bootstrap off
+#your existing ghc (or ghc-bin, whichever was merged last), without attempting to ruin anything...
+#
+#There is only one issue: ghci will be successfully built only if ghc is bootstrapped from the same version.
+#Thus we need to detect presently installed one and bootstrap in one or two stages..
+
+inherit base
+
+IUSE="doc tetex opengl"
+
+DESCRIPTION="The Glasgow Haskell Compiler"
+HOMEPAGE="http://www.haskell.org/ghc/"
+
+SRC_URI="http://www.haskell.org/ghc/dist/${PV}/ghc-${PV}-src.tar.bz2"
+
+LICENSE="as-is"
+SLOT="0"
+KEYWORDS="~x86 ~sparc -ppc -alpha"
+
+
+PROVIDE="virtual/ghc"
+# FIXME: Add USE support for parallel haskell (requires PVM)
+# Get PVM from ftp://ftp.netlib.org/pvm3/
+DEPEND="virtual/ghc
+ >=dev-lang/perl-5.6.1
+ >=sys-devel/gcc-2.95.3
+ >=sys-devel/make-3.79.1
+ >=sys-apps/sed-3.02.80
+ >=sys-devel/flex-2.5.4a
+ >=dev-libs/gmp-4.1
+ doc? ( >=app-text/openjade-1.3.1
+ >=app-text/sgml-common-0.6.3
+ =app-text/docbook-sgml-dtd-3.1-r1
+ >=app-text/docbook-dsssl-stylesheets-1.64
+ >=dev-haskell/haddock-0.4
+ tetex? ( >=app-text/tetex-1.0.7
+ >=app-text/jadetex-3.12 ) )
+ opengl? ( virtual/opengl
+ virtual/glu
+ virtual/glut )"
+
+RDEPEND="virtual/glibc
+ >=sys-devel/gcc-2.95.3
+ >=dev-lang/perl-5.6.1
+ opengl? ( virtual/opengl virtual/glu virtual/glut )"
+
+# extend path to /opt/ghc/bin to guarantee that ghc-bin is found
+GHCPATH="${PATH}:/opt/ghc/bin"
+
+src_unpack() {
+ base_src_unpack
+
+ # fix libraries/OpenGL/Makefile
+ cd ${S}
+ pushd libraries/OpenGL
+ mv Makefile Makefile-orig
+ sed -e 's/\(-D.*=\)"\(.*\)"/\1\\\"\2\\\"/' Makefile-orig > Makefile
+ popd
+}
+
+src_compile() {
+ local myconf
+ if [ `use opengl` ]; then
+ myconf="--enable-hopengl"
+ fi
+
+ # unset SGML_CATALOG_FILES because documentation installation
+ # breaks otherwise ...
+ PATH="${GHCPATH}" SGML_CATALOG_FILES="" econf \
+ --enable-threaded-rts ${myconf} || die "econf failed"
+
+ # the build does not seem to work all that
+ # well with parallel make
+ make || die
+
+ # if documentation has been requested, build documentation ...
+ if use doc; then
+ emake html || die
+ if use tetex; then
+ emake ps || die
+ fi
+ fi
+
+}
+
+src_install () {
+ local mydoc
+
+ # determine what to do with documentation
+ if [ `use doc` ]; then
+ mydoc="html"
+ if [ `use tetex` ]; then
+ mydoc="${mydoc} ps"
+ fi
+ else
+ mydoc=""
+ # needed to prevent haddock from being called
+ echo NO_HADDOCK_DOCS=YES >> mk/build.mk
+ fi
+ echo SGMLDocWays="${mydoc}" >> mk/build.mk
+
+ make install install-docs \
+ prefix="${D}/usr" \
+ datadir="${D}/usr/share/doc/${PF}" \
+ infodir="${D}/usr/share/info" \
+ mandir="${D}/usr/share/man" || die
+
+ #need to remove ${D} from ghcprof script
+ cd ${D}/usr/bin
+ mv ghcprof ghcprof-orig
+ sed -e 's:$FPTOOLS_TOP_ABS:#$FPTOOLS_TOP_ABS:' ghcprof-orig > ghcprof
+ chmod a+x ghcprof
+ rm -f ghcprof-orig
+
+ cd ${S}/ghc
+ dodoc README ANNOUNCE LICENSE VERSION
+}
+
+
+pkg_postinst () {
+ einfo "If you have dev-lang/ghc-bin installed, you might"
+ einfo "want to unmerge it again. It is no longer needed."
+}