summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPeter Alfredsen <loki_val@gentoo.org>2008-11-24 23:56:14 +0000
committerPeter Alfredsen <loki_val@gentoo.org>2008-11-24 23:56:14 +0000
commit1f10ccbf77c213e8cae4afb77177333f8e2bf9f7 (patch)
tree5545e2fadb7ef4cd11b67f782a59e99bebcb07ed /dev-lang
parentBump to 0.6.4. Clean up old revisions. (diff)
downloadgentoo-2-1f10ccbf77c213e8cae4afb77177333f8e2bf9f7.tar.gz
gentoo-2-1f10ccbf77c213e8cae4afb77177333f8e2bf9f7.tar.bz2
gentoo-2-1f10ccbf77c213e8cae4afb77177333f8e2bf9f7.zip
Go eapi-2, libgdiplus needs it anyway. Tweak sigaltstack usage so we don't have to send segfaults to the kernel all the time. Prepare for ia64 and arm by making the options they'll need ready.
(Portage version: 2.2_rc16/cvs/Linux 2.6.28-rc4 x86_64)
Diffstat (limited to 'dev-lang')
-rw-r--r--dev-lang/mono/ChangeLog9
-rw-r--r--dev-lang/mono/files/mono-2.0.1-fix_implicit_pointer_conversions.patch18
-rw-r--r--dev-lang/mono/mono-2.0.1.ebuild41
3 files changed, 46 insertions, 22 deletions
diff --git a/dev-lang/mono/ChangeLog b/dev-lang/mono/ChangeLog
index 890f6de92e24..83a788199fa6 100644
--- a/dev-lang/mono/ChangeLog
+++ b/dev-lang/mono/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for dev-lang/mono
# Copyright 2002-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/mono/ChangeLog,v 1.146 2008/11/23 16:52:37 loki_val Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/mono/ChangeLog,v 1.147 2008/11/24 23:56:14 loki_val Exp $
+
+ 24 Nov 2008; Peter Alfredsen <loki_val@gentoo.org>
+ +files/mono-2.0.1-fix_implicit_pointer_conversions.patch,
+ mono-2.0.1.ebuild:
+ Go eapi-2, libgdiplus needs it anyway. Tweak sigaltstack usage so we don't
+ have to send segfaults to the kernel all the time. Prepare for ia64 and
+ arm by making the options they'll need ready.
23 Nov 2008; Peter Alfredsen <loki_val@gentoo.org> mono-2.0.1.ebuild:
Drop libdir patches, lib64 isn't really needed for platform independent
diff --git a/dev-lang/mono/files/mono-2.0.1-fix_implicit_pointer_conversions.patch b/dev-lang/mono/files/mono-2.0.1-fix_implicit_pointer_conversions.patch
new file mode 100644
index 000000000000..35b99919336f
--- /dev/null
+++ b/dev-lang/mono/files/mono-2.0.1-fix_implicit_pointer_conversions.patch
@@ -0,0 +1,18 @@
+#! /bin/sh /usr/share/dpatch/dpatch-run
+## fix_implicit_pointer_conversions.dpatch by Mirco Bauer <meebey@debian.org>
+##
+## All lines beginning with `## DP:' are a description of the patch.
+## DP: No description.
+
+@DPATCH@
+diff -urNad mono-1.2.6~/mono/metadata/security.c mono-1.2.6/mono/metadata/security.c
+--- mono-1.2.6~/mono/metadata/security.c 2007-11-08 23:07:19.000000000 +0100
++++ mono-1.2.6/mono/metadata/security.c 2007-12-24 15:54:02.000000000 +0100
+@@ -12,6 +12,7 @@
+ #endif
+
+ #include <mono/metadata/appdomain.h>
++#include <mono/metadata/assembly.h>
+ #include <mono/metadata/image.h>
+ #include <mono/metadata/exception.h>
+ #include <mono/metadata/object-internals.h>
diff --git a/dev-lang/mono/mono-2.0.1.ebuild b/dev-lang/mono/mono-2.0.1.ebuild
index f845c1a3ab7b..300d9ac06c89 100644
--- a/dev-lang/mono/mono-2.0.1.ebuild
+++ b/dev-lang/mono/mono-2.0.1.ebuild
@@ -1,6 +1,8 @@
# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/mono/mono-2.0.1.ebuild,v 1.2 2008/11/23 16:52:37 loki_val Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/mono/mono-2.0.1.ebuild,v 1.3 2008/11/24 23:56:14 loki_val Exp $
+
+EAPI=2
inherit base eutils flag-o-matic multilib autotools
@@ -15,7 +17,9 @@ IUSE=""
RDEPEND="!<dev-dotnet/pnet-0.6.12
>=dev-libs/glib-2.6
- =dev-dotnet/libgdiplus-${PV%%.*}*"
+ =dev-dotnet/libgdiplus-${PV%%.*}*
+ ia64? ( sys-libs/libunwind )"
+
DEPEND="${RDEPEND}
sys-devel/bc
>=dev-util/pkgconfig-0.19"
@@ -23,41 +27,36 @@ PDEPEND="dev-dotnet/pe-format"
RESTRICT="test"
-#Threading and mimeicon patches from Fedora CVS. Muine patch from Novell.
+#Threading and mimeicon patches from Fedora CVS. Muine patch from Novell. Pointer conversions patch from Debian.
PATCHES=( "${FILESDIR}/${PN}-biginteger_overflow.diff"
"${FILESDIR}/${PN}-2.0-ppc-threading.patch"
"${FILESDIR}/${PN}-2.0-mimeicon.patch"
- "${FILESDIR}/${P}-fix-wsdl-troubles-with-muine.patch" )
+ "${FILESDIR}/${P}-fix-wsdl-troubles-with-muine.patch"
+ "${FILESDIR}/${P}-fix_implicit_pointer_conversions.patch" )
-
-function get-memory-total() {
- cat /proc/meminfo | grep MemTotal | sed -r "s/[^0-9]*([[0-9]+).*/\1/"
-}
-
-src_compile() {
+src_configure() {
# mono's build system is finiky, strip the flags
strip-flags
#Remove this at your own peril. Mono will barf in unexpected ways.
append-flags -fno-strict-aliasing
- # Enable large heaps if memory is more than >=3GB
- if [[ $(get-memory-total) -ge 3145728 ]] ; then
- myconf="${myconf} --with-large-heap=yes"
- fi
-
- # Force the use of monolite mcs to prevent issues with classlibs (bug #118062)
- touch "${S}"/mcs/build/deps/use-monolite
-
- econf --without-moonlight \
+ econf --disable-dependency-tracking \
+ --without-moonlight \
--with-preview=yes \
--with-glib=system \
--with-gc=included \
--with-libgdiplus=installed \
- --with-tls=__thread \
- --with-ikvm=yes \
+ --with-tls=$(use arm && printf "pthread" || printf "__thread" ) \
+ --with-sigaltstack=$((use x86 || use amd64) && printf "yes" || printf "no" ) \
+ --with-ikvm-native=no \
--with-jit=yes
+
+ # dev-dotnet/ikvm provides ikvm-native
+}
+
+src_compile() {
emake EXTERNAL_MCS=false EXTERNAL_MONO=false
if [[ "$?" -ne "0" ]]; then