summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2012-09-25 04:35:12 +0000
committerMike Frysinger <vapier@gentoo.org>2012-09-25 04:35:12 +0000
commitd947d12cc98bddd28d78bc1c5d2d0fdff1cf1f63 (patch)
tree9dc64b625fc43aa6fc7e301f20d27759a01a5ce1 /dev-lang/yasm
parentFix quoting issues. (diff)
downloadgentoo-2-d947d12cc98bddd28d78bc1c5d2d0fdff1cf1f63.tar.gz
gentoo-2-d947d12cc98bddd28d78bc1c5d2d0fdff1cf1f63.tar.bz2
gentoo-2-d947d12cc98bddd28d78bc1c5d2d0fdff1cf1f63.zip
Add live git ebuild #435838 by Alphat-PC.
(Portage version: 2.2.0_alpha131/cvs/Linux x86_64)
Diffstat (limited to 'dev-lang/yasm')
-rw-r--r--dev-lang/yasm/ChangeLog8
-rw-r--r--dev-lang/yasm/yasm-9999.ebuild54
2 files changed, 60 insertions, 2 deletions
diff --git a/dev-lang/yasm/ChangeLog b/dev-lang/yasm/ChangeLog
index f527290aa9bd..3d938c07526f 100644
--- a/dev-lang/yasm/ChangeLog
+++ b/dev-lang/yasm/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-lang/yasm
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/yasm/ChangeLog,v 1.55 2012/06/16 10:48:02 grobian Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/yasm/ChangeLog,v 1.56 2012/09/25 04:35:12 vapier Exp $
+
+*yasm-9999 (25 Sep 2012)
+
+ 25 Sep 2012; Mike Frysinger <vapier@gentoo.org> +yasm-9999.ebuild:
+ Add live git ebuild #435838 by Alphat-PC.
16 Jun 2012; Fabian Groffen <grobian@gentoo.org> yasm-1.2.0.ebuild:
Fix autoreconf for platforms where /bin/sh doesn't understand $(xxx)
@@ -211,4 +216,3 @@
09 Feb 2004; <augustus@gentoo.org> yasm-0.3.0.ebuild:
New ebuild for yasm. Keyworded ~amd64 and ~x86. Ran tests that came with
package. All seems well. Needs testing with some real code.
-
diff --git a/dev-lang/yasm/yasm-9999.ebuild b/dev-lang/yasm/yasm-9999.ebuild
new file mode 100644
index 000000000000..6500238f52f3
--- /dev/null
+++ b/dev-lang/yasm/yasm-9999.ebuild
@@ -0,0 +1,54 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/yasm/yasm-9999.ebuild,v 1.1 2012/09/25 04:35:12 vapier Exp $
+
+EAPI=4
+PYTHON_DEPEND="python? 2:2.7"
+inherit autotools eutils python
+if [[ ${PV} == "9999"* ]] ; then
+ EGIT_REPO_URI="git://github.com/yasm/yasm.git"
+ inherit git-2
+else
+ SRC_URI="http://www.tortall.net/projects/yasm/releases/${P}.tar.gz"
+ KEYWORDS="-* ~amd64 ~x86 ~amd64-fbsd ~x86-fbsd ~x86-freebsd ~amd64-linux ~x86-linux ~x64-macos ~x86-macos ~x86-solaris"
+fi
+
+DESCRIPTION="An assembler for x86 and x86_64 instruction sets"
+HOMEPAGE="http://www.tortall.net/projects/yasm/"
+
+LICENSE="BSD-2 BSD || ( Artistic GPL-2 LGPL-2 )"
+SLOT="0"
+IUSE="nls python"
+
+RDEPEND="nls? ( virtual/libintl )"
+DEPEND="nls? ( sys-devel/gettext )
+ python? ( >=dev-python/cython-0.14 )"
+
+DOCS=( AUTHORS )
+
+pkg_setup() {
+ # Python is required for generating x86insns.c, see
+ # modules/arch/x86/Makefile.inc for more details.
+ if use python || [[ ${PV} == "9999" ]] ; then
+ python_set_active_version 2
+ python_pkg_setup
+ fi
+}
+
+src_prepare() {
+ # ksh doesn't grok $(xxx), makes aclocal fail
+ sed -i -e '1c\#!/usr/bin/env sh' YASM-VERSION-GEN.sh || die
+ eautoreconf
+
+ if [[ ${PV} == "9999" ]] ; then
+ ./modules/arch/x86/gen_x86_insn.py || die
+ fi
+}
+
+src_configure() {
+ econf \
+ --disable-warnerror \
+ $(use_enable python) \
+ $(use_enable python python-bindings) \
+ $(use_enable nls)
+}