summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Sterrett <msterret@gentoo.org>2003-09-06 22:29:29 +0000
committerMichael Sterrett <msterret@gentoo.org>2003-09-06 22:29:29 +0000
commitdacd3fae1731f833aece4e53f86ca4f50822f66b (patch)
treeb1a2f0f8c339914aa7e313554b90bf5dda770f9a /dev-lang/tcl
parentrepoman: trim trailing whitespace (diff)
downloadgentoo-2-dacd3fae1731f833aece4e53f86ca4f50822f66b.tar.gz
gentoo-2-dacd3fae1731f833aece4e53f86ca4f50822f66b.tar.bz2
gentoo-2-dacd3fae1731f833aece4e53f86ca4f50822f66b.zip
repoman: trim trailing whitespace
Diffstat (limited to 'dev-lang/tcl')
-rw-r--r--dev-lang/tcl/Manifest14
-rw-r--r--dev-lang/tcl/tcl-8.3.3-r1.ebuild18
-rw-r--r--dev-lang/tcl/tcl-8.3.3-r3.ebuild18
-rw-r--r--dev-lang/tcl/tcl-8.3.4.ebuild18
-rw-r--r--dev-lang/tcl/tcl-8.4.2-r1.ebuild18
-rw-r--r--dev-lang/tcl/tcl-8.4.2.ebuild18
-rw-r--r--dev-lang/tcl/tcl-8.4.3.ebuild18
7 files changed, 61 insertions, 61 deletions
diff --git a/dev-lang/tcl/Manifest b/dev-lang/tcl/Manifest
index f06dffebc003..a74748eb847c 100644
--- a/dev-lang/tcl/Manifest
+++ b/dev-lang/tcl/Manifest
@@ -1,13 +1,13 @@
+MD5 3aa2a254c5916ebf1b3c2a806a8b2cb9 ChangeLog 2560
+MD5 efce7f63c18f3658617fda1b3f7d5838 tcl-8.3.3-r1.ebuild 2065
+MD5 08cf84b54506f74693dfb290bcb9ed09 tcl-8.3.3-r3.ebuild 2168
+MD5 e2b68ca009a061f2904e82843493906d tcl-8.3.4.ebuild 2179
+MD5 8c2b1fbfbd6a363e66afa121c021bb0b tcl-8.4.2.ebuild 2649
+MD5 294413bdc33e50063240be6ae9914276 tcl-8.4.2-r1.ebuild 2655
+MD5 e4221a44aa7483a63c711162f334b20e tcl-8.4.3.ebuild 2652
MD5 ee8221e881e685cb7836325e4021881e files/digest-tcl-8.3.3-r1 61
MD5 ee8221e881e685cb7836325e4021881e files/digest-tcl-8.3.3-r3 61
MD5 d7d05b473cf799a637baaa9f321b070f files/digest-tcl-8.3.4 121
MD5 f608ebc717b6f106b101e76b49c89df2 files/digest-tcl-8.4.2 65
MD5 f608ebc717b6f106b101e76b49c89df2 files/digest-tcl-8.4.2-r1 65
MD5 805b9b9face80f817e3a995e109d524d files/digest-tcl-8.4.3 65
-MD5 4d789330b75b3718dbf9176d90ba8d25 tcl-8.3.3-r1.ebuild 2074
-MD5 ef64831bbaf6b767a5529e51493f8bed tcl-8.3.3-r3.ebuild 2177
-MD5 bffe9e3745c5a02b5a5dc2a00d906152 tcl-8.3.4.ebuild 2188
-MD5 3aa2a254c5916ebf1b3c2a806a8b2cb9 ChangeLog 2560
-MD5 283dced8142b077f7703628a4dcb2861 tcl-8.4.2.ebuild 2658
-MD5 1a764eb397808036f1aec8e48e5a2da9 tcl-8.4.2-r1.ebuild 2664
-MD5 b9c0e0b47fd2b4abe52eb0f7630859e9 tcl-8.4.3.ebuild 2661
diff --git a/dev-lang/tcl/tcl-8.3.3-r1.ebuild b/dev-lang/tcl/tcl-8.3.3-r1.ebuild
index d4e4967bd069..45ba338fcd28 100644
--- a/dev-lang/tcl/tcl-8.3.3-r1.ebuild
+++ b/dev-lang/tcl/tcl-8.3.3-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2003 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/tcl/tcl-8.3.3-r1.ebuild,v 1.13 2003/02/13 10:31:19 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/tcl/tcl-8.3.3-r1.ebuild,v 1.14 2003/09/06 22:27:51 msterret Exp $
S=${WORKDIR}/${PN}${PV}
@@ -27,9 +27,9 @@ src_compile() {
--prefix=/usr \
--mandir=/usr/share/man \
|| die
- # threading is not recommended as it breaks some packages
+ # threading is not recommended as it breaks some packages
# --enable-threads \
-
+
emake CFLAGS="${CFLAGS}" || die
}
@@ -39,10 +39,10 @@ src_install() {
#short version number
local v1
v1=${PV%.*}
-
+
cd ${S}/unix
make INSTALL_ROOT=${D} MAN_INSTALL_DIR=${D}/usr/share/man install || die
-
+
# fix the tclConfig.sh to eliminate refs to the build directory
sed -e "s,^TCL_BUILD_LIB_SPEC='-L${S}/unix,TCL_BUILD_LIB_SPEC='-L/usr/lib," \
-e "s,^TCL_SRC_DIR='${S}',TCL_SRC_DIR='/usr/lib/tcl${v1}/include'," \
@@ -50,7 +50,7 @@ src_install() {
-e "s,^TCL_BUILD_STUB_LIB_PATH='${S}/unix,TCL_BUILD_STUB_LIB_PATH='/usr/lib," \
${D}/usr/lib/tclConfig.sh > ${D}/usr/lib/tclConfig.sh.new
mv ${D}/usr/lib/tclConfig.sh.new ${D}/usr/lib/tclConfig.sh
-
+
# install private headers
dodir /usr/lib/tcl${v1}/include/unix
install -c -m0644 ${S}/unix/*.h ${D}/usr/lib/tcl${v1}/include/unix
@@ -58,14 +58,14 @@ src_install() {
install -c -m0644 ${S}/generic/*.h ${D}/usr/lib/tcl${v1}/include/generic
rm -f ${D}/usr/lib/tcl${v1}/include/generic/tcl.h
rm -f ${D}/usr/lib/tcl${v1}/include/generic/tclDecls.h
- rm -f ${D}/usr/lib/tcl${v1}/include/generic/tclPlatDecls.h
+ rm -f ${D}/usr/lib/tcl${v1}/include/generic/tclPlatDecls.h
# install symlink for libraries
dosym /usr/lib/libtcl${v1}.a /usr/lib/libtcl.a
dosym /usr/lib/libtclstub${v1}.a /usr/lib/libtclstub.a
-
+
ln -sf tclsh${v1} ${D}/usr/bin/tclsh
-
+
cd ${S}
dodoc README changes license.terms
diff --git a/dev-lang/tcl/tcl-8.3.3-r3.ebuild b/dev-lang/tcl/tcl-8.3.3-r3.ebuild
index 6fcb2905f814..08791797e95f 100644
--- a/dev-lang/tcl/tcl-8.3.3-r3.ebuild
+++ b/dev-lang/tcl/tcl-8.3.3-r3.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2003 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/tcl/tcl-8.3.3-r3.ebuild,v 1.12 2003/02/13 10:31:24 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/tcl/tcl-8.3.3-r3.ebuild,v 1.13 2003/09/06 22:27:51 msterret Exp $
S=${WORKDIR}/${PN}${PV}
@@ -27,9 +27,9 @@ src_compile() {
--prefix=/usr \
--mandir=/usr/share/man \
|| die
- # threading is not recommended as it breaks some packages
+ # threading is not recommended as it breaks some packages
# --enable-threads \
-
+
emake CFLAGS="${CFLAGS}" || die
}
@@ -39,10 +39,10 @@ src_install() {
#short version number
local v1
v1=${PV%.*}
-
+
cd ${S}/unix
make INSTALL_ROOT=${D} MAN_INSTALL_DIR=${D}/usr/share/man install || die
-
+
# fix the tclConfig.sh to eliminate refs to the build directory
sed -e "s,^TCL_BUILD_LIB_SPEC='-L${S}/unix,TCL_BUILD_LIB_SPEC='-L/usr/lib," \
-e "s,^TCL_SRC_DIR='${S}',TCL_SRC_DIR='/usr/lib/tcl${v1}/include'," \
@@ -51,7 +51,7 @@ src_install() {
-e "s,^TCL_LIB_FILE='libtcl8.3..TCL_DBGX..so',TCL_LIB_FILE=\"libtcl8.3\$\{TCL_DBGX\}.so\"," \
${D}/usr/lib/tclConfig.sh > ${D}/usr/lib/tclConfig.sh.new
mv ${D}/usr/lib/tclConfig.sh.new ${D}/usr/lib/tclConfig.sh
-
+
# install private headers
dodir /usr/lib/tcl${v1}/include/unix
install -c -m0644 ${S}/unix/*.h ${D}/usr/lib/tcl${v1}/include/unix
@@ -59,14 +59,14 @@ src_install() {
install -c -m0644 ${S}/generic/*.h ${D}/usr/lib/tcl${v1}/include/generic
rm -f ${D}/usr/lib/tcl${v1}/include/generic/tcl.h
rm -f ${D}/usr/lib/tcl${v1}/include/generic/tclDecls.h
- rm -f ${D}/usr/lib/tcl${v1}/include/generic/tclPlatDecls.h
+ rm -f ${D}/usr/lib/tcl${v1}/include/generic/tclPlatDecls.h
# install symlink for libraries
dosym /usr/lib/libtcl${v1}.so /usr/lib/libtcl.so
dosym /usr/lib/libtclstub${v1}.a /usr/lib/libtclstub.a
-
+
ln -sf tclsh${v1} ${D}/usr/bin/tclsh
-
+
cd ${S}
dodoc README changes license.terms
diff --git a/dev-lang/tcl/tcl-8.3.4.ebuild b/dev-lang/tcl/tcl-8.3.4.ebuild
index fd421e7abf57..e77019594506 100644
--- a/dev-lang/tcl/tcl-8.3.4.ebuild
+++ b/dev-lang/tcl/tcl-8.3.4.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2003 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/tcl/tcl-8.3.4.ebuild,v 1.5 2003/07/18 20:09:03 tester Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/tcl/tcl-8.3.4.ebuild,v 1.6 2003/09/06 22:27:51 msterret Exp $
S=${WORKDIR}/${PN}${PV}
@@ -27,9 +27,9 @@ src_compile() {
--prefix=/usr \
--mandir=/usr/share/man \
|| die
- # threading is not recommended as it breaks some packages
+ # threading is not recommended as it breaks some packages
# --enable-threads \
-
+
emake CFLAGS="${CFLAGS}" || die
}
@@ -39,10 +39,10 @@ src_install() {
#short version number
local v1
v1=${PV%.*}
-
+
cd ${S}/unix
make INSTALL_ROOT=${D} MAN_INSTALL_DIR=${D}/usr/share/man install || die
-
+
# fix the tclConfig.sh to eliminate refs to the build directory
sed -e "s,^TCL_BUILD_LIB_SPEC='-L${S}/unix,TCL_BUILD_LIB_SPEC='-L/usr/lib," \
-e "s,^TCL_SRC_DIR='${S}',TCL_SRC_DIR='/usr/lib/tcl${v1}/include'," \
@@ -51,7 +51,7 @@ src_install() {
-e "s,^TCL_LIB_FILE='libtcl8.3..TCL_DBGX..so',TCL_LIB_FILE=\"libtcl8.3\$\{TCL_DBGX\}.so\"," \
${D}/usr/lib/tclConfig.sh > ${D}/usr/lib/tclConfig.sh.new
mv ${D}/usr/lib/tclConfig.sh.new ${D}/usr/lib/tclConfig.sh
-
+
# install private headers
dodir /usr/lib/tcl${v1}/include/unix
install -c -m0644 ${S}/unix/*.h ${D}/usr/lib/tcl${v1}/include/unix
@@ -59,14 +59,14 @@ src_install() {
install -c -m0644 ${S}/generic/*.h ${D}/usr/lib/tcl${v1}/include/generic
rm -f ${D}/usr/lib/tcl${v1}/include/generic/tcl.h
rm -f ${D}/usr/lib/tcl${v1}/include/generic/tclDecls.h
- rm -f ${D}/usr/lib/tcl${v1}/include/generic/tclPlatDecls.h
+ rm -f ${D}/usr/lib/tcl${v1}/include/generic/tclPlatDecls.h
# install symlink for libraries
dosym /usr/lib/libtcl${v1}.so /usr/lib/libtcl.so
dosym /usr/lib/libtclstub${v1}.a /usr/lib/libtclstub.a
-
+
ln -sf tclsh${v1} ${D}/usr/bin/tclsh
-
+
cd ${S}
dodoc README changes license.terms
diff --git a/dev-lang/tcl/tcl-8.4.2-r1.ebuild b/dev-lang/tcl/tcl-8.4.2-r1.ebuild
index 7c2ada1a1283..e72d51c36f7f 100644
--- a/dev-lang/tcl/tcl-8.4.2-r1.ebuild
+++ b/dev-lang/tcl/tcl-8.4.2-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2003 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/tcl/tcl-8.4.2-r1.ebuild,v 1.2 2003/08/15 13:03:24 lanius Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/tcl/tcl-8.4.2-r1.ebuild,v 1.3 2003/09/06 22:27:51 msterret Exp $
S=${WORKDIR}/${PN}${PV}
@@ -31,9 +31,9 @@ src_compile() {
--prefix=/usr \
--mandir=/usr/share/man \
|| die
- # threading is not recommended as it breaks some packages
+ # threading is not recommended as it breaks some packages
# --enable-threads \
-
+
emake CFLAGS="${CFLAGS}" || die
}
@@ -43,10 +43,10 @@ src_install() {
#short version number
local v1
v1=${PV%.*}
-
+
cd ${S}/unix
S= make INSTALL_ROOT=${D} MAN_INSTALL_DIR=${D}/usr/share/man install || die
-
+
# fix the tclConfig.sh to eliminate refs to the build directory
sed -e "s,^TCL_BUILD_LIB_SPEC='-L${S}/unix,TCL_BUILD_LIB_SPEC='-L/usr/lib," \
-e "s,^TCL_SRC_DIR='${S}',TCL_SRC_DIR='/usr/lib/tcl${v1}/include'," \
@@ -55,7 +55,7 @@ src_install() {
-e "s,^TCL_LIB_FILE='libtcl8.4..TCL_DBGX..so',TCL_LIB_FILE=\"libtcl8.4\$\{TCL_DBGX\}.so\"," \
${D}/usr/lib/tclConfig.sh > ${D}/usr/lib/tclConfig.sh.new
mv ${D}/usr/lib/tclConfig.sh.new ${D}/usr/lib/tclConfig.sh
-
+
# install private headers
dodir /usr/lib/tcl${v1}/include/unix
install -c -m0644 ${S}/unix/*.h ${D}/usr/lib/tcl${v1}/include/unix
@@ -63,14 +63,14 @@ src_install() {
install -c -m0644 ${S}/generic/*.h ${D}/usr/lib/tcl${v1}/include/generic
rm -f ${D}/usr/lib/tcl${v1}/include/generic/tcl.h
rm -f ${D}/usr/lib/tcl${v1}/include/generic/tclDecls.h
- rm -f ${D}/usr/lib/tcl${v1}/include/generic/tclPlatDecls.h
+ rm -f ${D}/usr/lib/tcl${v1}/include/generic/tclPlatDecls.h
# install symlink for libraries
dosym /usr/lib/libtcl${v1}.so /usr/lib/libtcl.so
dosym /usr/lib/libtclstub${v1}.a /usr/lib/libtclstub.a
-
+
ln -sf tclsh${v1} ${D}/usr/bin/tclsh
-
+
cd ${S}
dodoc README changes license.terms
diff --git a/dev-lang/tcl/tcl-8.4.2.ebuild b/dev-lang/tcl/tcl-8.4.2.ebuild
index 540bb8889db1..ea736c088d02 100644
--- a/dev-lang/tcl/tcl-8.4.2.ebuild
+++ b/dev-lang/tcl/tcl-8.4.2.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2003 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/tcl/tcl-8.4.2.ebuild,v 1.3 2003/08/15 13:03:24 lanius Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/tcl/tcl-8.4.2.ebuild,v 1.4 2003/09/06 22:27:51 msterret Exp $
S=${WORKDIR}/${PN}${PV}
@@ -31,9 +31,9 @@ src_compile() {
--prefix=/usr \
--mandir=/usr/share/man \
|| die
- # threading is not recommended as it breaks some packages
+ # threading is not recommended as it breaks some packages
# --enable-threads \
-
+
emake CFLAGS="${CFLAGS}" || die
}
@@ -43,10 +43,10 @@ src_install() {
#short version number
local v1
v1=${PV%.*}
-
+
cd ${S}/unix
make INSTALL_ROOT=${D} MAN_INSTALL_DIR=${D}/usr/share/man install || die
-
+
# fix the tclConfig.sh to eliminate refs to the build directory
sed -e "s,^TCL_BUILD_LIB_SPEC='-L${S}/unix,TCL_BUILD_LIB_SPEC='-L/usr/lib," \
-e "s,^TCL_SRC_DIR='${S}',TCL_SRC_DIR='/usr/lib/tcl${v1}/include'," \
@@ -55,7 +55,7 @@ src_install() {
-e "s,^TCL_LIB_FILE='libtcl8.4..TCL_DBGX..so',TCL_LIB_FILE=\"libtcl8.4\$\{TCL_DBGX\}.so\"," \
${D}/usr/lib/tclConfig.sh > ${D}/usr/lib/tclConfig.sh.new
mv ${D}/usr/lib/tclConfig.sh.new ${D}/usr/lib/tclConfig.sh
-
+
# install private headers
dodir /usr/lib/tcl${v1}/include/unix
install -c -m0644 ${S}/unix/*.h ${D}/usr/lib/tcl${v1}/include/unix
@@ -63,14 +63,14 @@ src_install() {
install -c -m0644 ${S}/generic/*.h ${D}/usr/lib/tcl${v1}/include/generic
rm -f ${D}/usr/lib/tcl${v1}/include/generic/tcl.h
rm -f ${D}/usr/lib/tcl${v1}/include/generic/tclDecls.h
- rm -f ${D}/usr/lib/tcl${v1}/include/generic/tclPlatDecls.h
+ rm -f ${D}/usr/lib/tcl${v1}/include/generic/tclPlatDecls.h
# install symlink for libraries
dosym /usr/lib/libtcl${v1}.so /usr/lib/libtcl.so
dosym /usr/lib/libtclstub${v1}.a /usr/lib/libtclstub.a
-
+
ln -sf tclsh${v1} ${D}/usr/bin/tclsh
-
+
cd ${S}
dodoc README changes license.terms
diff --git a/dev-lang/tcl/tcl-8.4.3.ebuild b/dev-lang/tcl/tcl-8.4.3.ebuild
index ab3e3856abd3..8368baf074af 100644
--- a/dev-lang/tcl/tcl-8.4.3.ebuild
+++ b/dev-lang/tcl/tcl-8.4.3.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2003 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/tcl/tcl-8.4.3.ebuild,v 1.2 2003/08/15 13:03:24 lanius Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/tcl/tcl-8.4.3.ebuild,v 1.3 2003/09/06 22:27:51 msterret Exp $
S=${WORKDIR}/${PN}${PV}
@@ -31,9 +31,9 @@ src_compile() {
--prefix=/usr \
--mandir=/usr/share/man \
|| die
- # threading is not recommended as it breaks some packages
+ # threading is not recommended as it breaks some packages
# --enable-threads \
-
+
emake CFLAGS="${CFLAGS}" || die
}
@@ -43,10 +43,10 @@ src_install() {
#short version number
local v1
v1=${PV%.*}
-
+
cd ${S}/unix
S= make INSTALL_ROOT=${D} MAN_INSTALL_DIR=${D}/usr/share/man install || die
-
+
# fix the tclConfig.sh to eliminate refs to the build directory
sed -e "s,^TCL_BUILD_LIB_SPEC='-L${S}/unix,TCL_BUILD_LIB_SPEC='-L/usr/lib," \
-e "s,^TCL_SRC_DIR='${S}',TCL_SRC_DIR='/usr/lib/tcl${v1}/include'," \
@@ -55,7 +55,7 @@ src_install() {
-e "s,^TCL_LIB_FILE='libtcl8.4..TCL_DBGX..so',TCL_LIB_FILE=\"libtcl8.4\$\{TCL_DBGX\}.so\"," \
${D}/usr/lib/tclConfig.sh > ${D}/usr/lib/tclConfig.sh.new
mv ${D}/usr/lib/tclConfig.sh.new ${D}/usr/lib/tclConfig.sh
-
+
# install private headers
dodir /usr/lib/tcl${v1}/include/unix
install -c -m0644 ${S}/unix/*.h ${D}/usr/lib/tcl${v1}/include/unix
@@ -63,14 +63,14 @@ src_install() {
install -c -m0644 ${S}/generic/*.h ${D}/usr/lib/tcl${v1}/include/generic
rm -f ${D}/usr/lib/tcl${v1}/include/generic/tcl.h
rm -f ${D}/usr/lib/tcl${v1}/include/generic/tclDecls.h
- rm -f ${D}/usr/lib/tcl${v1}/include/generic/tclPlatDecls.h
+ rm -f ${D}/usr/lib/tcl${v1}/include/generic/tclPlatDecls.h
# install symlink for libraries
dosym /usr/lib/libtcl${v1}.so /usr/lib/libtcl.so
dosym /usr/lib/libtclstub${v1}.a /usr/lib/libtclstub.a
-
+
ln -sf tclsh${v1} ${D}/usr/bin/tclsh
-
+
cd ${S}
dodoc README changes license.terms