summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorStefan Jones <cretin@gentoo.org>2002-12-18 12:19:57 +0000
committerStefan Jones <cretin@gentoo.org>2002-12-18 12:19:57 +0000
commit77d725a5b32705d69b53de1bb63c2b1e2d82973e (patch)
tree214e6174161c9b18eebd2bb9ccdce24a880e029d /dev-lang/tcl/tcl-8.3.4.ebuild
parentfix0rs (diff)
downloadgentoo-2-77d725a5b32705d69b53de1bb63c2b1e2d82973e.tar.gz
gentoo-2-77d725a5b32705d69b53de1bb63c2b1e2d82973e.tar.bz2
gentoo-2-77d725a5b32705d69b53de1bb63c2b1e2d82973e.zip
New version
Diffstat (limited to 'dev-lang/tcl/tcl-8.3.4.ebuild')
-rw-r--r--dev-lang/tcl/tcl-8.3.4.ebuild73
1 files changed, 73 insertions, 0 deletions
diff --git a/dev-lang/tcl/tcl-8.3.4.ebuild b/dev-lang/tcl/tcl-8.3.4.ebuild
new file mode 100644
index 000000000000..b169a45ea626
--- /dev/null
+++ b/dev-lang/tcl/tcl-8.3.4.ebuild
@@ -0,0 +1,73 @@
+# Copyright 2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/tcl/tcl-8.3.4.ebuild,v 1.1 2002/12/18 12:17:44 cretin Exp $
+
+
+S=${WORKDIR}/${PN}${PV}
+SRC_URI="ftp://ftp.scriptics.com/pub/tcl/tcl8_3/${PN}${PV}.tar.gz"
+
+
+HOMEPAGE="http://dev.scriptics.com/software/tcltk/"
+
+DESCRIPTION="Tool Command Language"
+
+DEPEND="virtual/glibc"
+
+SLOT="0"
+LICENSE="BSD"
+KEYWORDS="x86 ppc sparc alpha"
+
+# hyper-optimizations untested...
+#
+
+src_compile() {
+
+ cd ${S}/unix
+ ./configure --host=${CHOST} \
+ --prefix=/usr \
+ --mandir=/usr/share/man \
+ || die
+ # threading is not recommended as it breaks some packages
+ # --enable-threads \
+
+ emake CFLAGS="${CFLAGS}" || die
+
+}
+
+src_install() {
+
+ #short version number
+ local v1
+ v1=${PV%.*}
+
+ cd ${S}/unix
+ make INSTALL_ROOT=${D} MAN_INSTALL_DIR=${D}/usr/share/man install || die
+
+ # fix the tclConfig.sh to eliminate refs to the build directory
+ sed -e "s,^TCL_BUILD_LIB_SPEC='-L${S}/unix,TCL_BUILD_LIB_SPEC='-L/usr/lib," \
+ -e "s,^TCL_SRC_DIR='${S}',TCL_SRC_DIR='/usr/lib/tcl${v1}/include'," \
+ -e "s,^TCL_BUILD_STUB_LIB_SPEC='-L${S}/unix,TCL_BUILD_STUB_LIB_SPEC='-L/usr/lib," \
+ -e "s,^TCL_BUILD_STUB_LIB_PATH='${S}/unix,TCL_BUILD_STUB_LIB_PATH='/usr/lib," \
+ -e "s,^TCL_LIB_FILE='libtcl8.3..TCL_DBGX..so',TCL_LIB_FILE=\"libtcl8.3\$\{TCL_DBGX\}.so\"," \
+ ${D}/usr/lib/tclConfig.sh > ${D}/usr/lib/tclConfig.sh.new
+ mv ${D}/usr/lib/tclConfig.sh.new ${D}/usr/lib/tclConfig.sh
+
+ # install private headers
+ dodir /usr/lib/tcl${v1}/include/unix
+ install -c -m0644 ${S}/unix/*.h ${D}/usr/lib/tcl${v1}/include/unix
+ dodir /usr/lib/tcl${v1}/include/generic
+ install -c -m0644 ${S}/generic/*.h ${D}/usr/lib/tcl${v1}/include/generic
+ rm -f ${D}/usr/lib/tcl${v1}/include/generic/tcl.h
+ rm -f ${D}/usr/lib/tcl${v1}/include/generic/tclDecls.h
+ rm -f ${D}/usr/lib/tcl${v1}/include/generic/tclPlatDecls.h
+
+ # install symlink for libraries
+ dosym /usr/lib/libtcl${v1}.so /usr/lib/libtcl.so
+ dosym /usr/lib/libtclstub${v1}.a /usr/lib/libtclstub.a
+
+ ln -sf tclsh${v1} ${D}/usr/bin/tclsh
+
+ cd ${S}
+ dodoc README changes license.terms
+
+}