summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGeorge Shapovalov <george@gentoo.org>2002-12-10 08:45:57 +0000
committerGeorge Shapovalov <george@gentoo.org>2002-12-10 08:45:57 +0000
commitc5d225527d015f86ee8e2dfc9a7929ef55e15afc (patch)
treebe210144799b45e6824ea4ff56ee38ecbed01a9a /dev-lang/smarteiffel/smarteiffel-1.0.ebuild
parentbump (diff)
downloadgentoo-2-c5d225527d015f86ee8e2dfc9a7929ef55e15afc.tar.gz
gentoo-2-c5d225527d015f86ee8e2dfc9a7929ef55e15afc.tar.bz2
gentoo-2-c5d225527d015f86ee8e2dfc9a7929ef55e15afc.zip
version update, see ChangeLog for the list of changes
Diffstat (limited to 'dev-lang/smarteiffel/smarteiffel-1.0.ebuild')
-rw-r--r--dev-lang/smarteiffel/smarteiffel-1.0.ebuild78
1 files changed, 78 insertions, 0 deletions
diff --git a/dev-lang/smarteiffel/smarteiffel-1.0.ebuild b/dev-lang/smarteiffel/smarteiffel-1.0.ebuild
new file mode 100644
index 000000000000..d9b9dbe3fe35
--- /dev/null
+++ b/dev-lang/smarteiffel/smarteiffel-1.0.ebuild
@@ -0,0 +1,78 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/smarteiffel/smarteiffel-1.0.ebuild,v 1.1 2002/12/10 08:45:55 george Exp $
+
+IUSE="doc tcc"
+
+DESCRIPTION="GNU Eiffel compiler"
+HOMEPAGE="http://smarteiffel.loria.fr/"
+
+SRC_URI="ftp://ftp.loria.fr/pub/loria/SmartEiffel/se-${PV}.tgz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86 ~ppc ~alpha ~sparc ~sparc64"
+
+#DEPEND="tcc? ( >=dev-lang/tcc-0.9.14 )"
+DEPEND="virtual/glibc"
+
+S="${WORKDIR}/SmartEiffel"
+# Destination directory to hold most of the SmartEiffel distribution.
+SE_DIR="/usr/lib/SmartEiffel"
+
+src_compile() {
+ #tcc did not work for me while processing the ebuild
+ #commenting out until resolved
+ #George Shapovalov <george@gentoo.org>, see #8897
+
+# use tcc && COMPILER=tcc
+# use tcc || COMPILER=gcc
+# use tcc && CFLAGS=""
+ COMPILER=gcc
+ einfo "Using ${COMPILER} as default C-compiler for SmartEiffel!"
+
+ export SmartEiffel="${S}/sys/system.se"
+ export PATH="${S}/bin:${PATH}"
+ cd ${S}
+ ebegin "Compiling install-program"
+ ${COMPILER} ${CFLAGS} -o install install.c || die
+ eend $?
+
+ einfo "Running install-program"
+ ( echo yes
+ echo no
+ echo UNIX
+ echo ${COMPILER}
+ echo ${CFLAGS}
+ echo yes
+ ) | ./install -interactive || die
+
+ # Regenerate a proper loadpath.UNIX file.
+ cp sys/loadpath.UNIX sys/loadpath.UNIX.orig
+ sed -e "s:^${S}:${SE_DIR}:" \
+ sys/loadpath.UNIX.orig > sys/loadpath.UNIX || die
+}
+
+src_install () {
+ dodir ${SE_DIR}
+ cp -a ${S}/{lib,tools,sys,bin} ${D}/${SE_DIR} || die
+
+ # Create symlinks to the appropriate executable binaries.
+ dodir /usr/bin
+ for NAME in ${S}/bin/*; do
+ NAME=`basename ${NAME}`
+ dosym ${SE_DIR}/bin/${NAME} /usr/bin/${NAME}
+ done
+
+ # Install documentation.
+ if [ -n `use doc` ]; then
+ einfo "Installing documentation"
+ dodir /usr/share/doc/${PF}
+ cp -a ${S}/{man,misc,tutorial,READ_ME} ${D}/usr/share/doc/${PF} || die
+ fi
+
+ # Setup 'SmartEiffel' environment variable.
+ dodir /etc/env.d
+ echo "SmartEiffel=${SE_DIR}/sys/system.se" > ${D}/etc/env.d/20smarteiffel
+ echo "SmartEiffelDirectory=${SE_DIR}" >> ${D}/etc/env.d/20smarteiffel
+}