summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2007-10-21 13:49:04 +0000
committerHans de Graaff <graaff@gentoo.org>2007-10-21 13:49:04 +0000
commit2222d9f94657c45ff481bc8f9fe6c04350a32174 (patch)
tree71c1f9ab979a86412eafb370c145083bfd36b139 /dev-lang/ruby
parentVersion bump. (diff)
downloadgentoo-2-2222d9f94657c45ff481bc8f9fe6c04350a32174.tar.gz
gentoo-2-2222d9f94657c45ff481bc8f9fe6c04350a32174.tar.bz2
gentoo-2-2222d9f94657c45ff481bc8f9fe6c04350a32174.zip
Add emacs and xemacs USE flag support
(Portage version: 2.1.3.9)
Diffstat (limited to 'dev-lang/ruby')
-rw-r--r--dev-lang/ruby/ChangeLog9
-rw-r--r--dev-lang/ruby/files/digest-ruby-1.8.6_p110-r26
-rw-r--r--dev-lang/ruby/ruby-1.8.6_p110-r2.ebuild170
3 files changed, 184 insertions, 1 deletions
diff --git a/dev-lang/ruby/ChangeLog b/dev-lang/ruby/ChangeLog
index 8060c134d4d4..9ed32a1b7ff0 100644
--- a/dev-lang/ruby/ChangeLog
+++ b/dev-lang/ruby/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for dev-lang/ruby
# Copyright 2002-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/ruby/ChangeLog,v 1.307 2007/10/13 02:47:26 beandog Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/ruby/ChangeLog,v 1.308 2007/10/21 13:49:04 graaff Exp $
+
+*ruby-1.8.6_p110-r2 (21 Oct 2007)
+
+ 21 Oct 2007; Hans de Graaff <graaff@gentoo.org>
+ +ruby-1.8.6_p110-r2.ebuild:
+ Add emacs and xemacs USE flags and use them to pull in the correct editing
+ mode for each. Had to drop several arch keywords as reported on bug 196413.
13 Oct 2007; Steve Dibb <beandog@gentoo.org> ruby-1.8.6_p110-r1.ebuild:
amd64 stable, security bug 194236
diff --git a/dev-lang/ruby/files/digest-ruby-1.8.6_p110-r2 b/dev-lang/ruby/files/digest-ruby-1.8.6_p110-r2
new file mode 100644
index 000000000000..408fe1eb2248
--- /dev/null
+++ b/dev-lang/ruby/files/digest-ruby-1.8.6_p110-r2
@@ -0,0 +1,6 @@
+MD5 7e4c2b197387232afd9a11378feeb246 onigd2_5_9.tar.gz 221355
+RMD160 ceeee9a0221d431d6576a566621ba9badab6423d onigd2_5_9.tar.gz 221355
+SHA256 b24df7c0fa6fc72ce37fd1e203f378359f29f739a3f4c5b6bdd40ca5f7d25db0 onigd2_5_9.tar.gz 221355
+MD5 5d9f903eae163cda2374ef8fdba5c0a5 ruby-1.8.6-p110.tar.gz 4546509
+RMD160 6495c22a94149e4dbc3608f0bf2f0c75683060e0 ruby-1.8.6-p110.tar.gz 4546509
+SHA256 d3f11ecaf2b0bd7bd3f0bc24007b1c7c12640c55cd40e8e4cc396ba835186fbe ruby-1.8.6-p110.tar.gz 4546509
diff --git a/dev-lang/ruby/ruby-1.8.6_p110-r2.ebuild b/dev-lang/ruby/ruby-1.8.6_p110-r2.ebuild
new file mode 100644
index 000000000000..049db5bfa51d
--- /dev/null
+++ b/dev-lang/ruby/ruby-1.8.6_p110-r2.ebuild
@@ -0,0 +1,170 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/ruby/ruby-1.8.6_p110-r2.ebuild,v 1.1 2007/10/21 13:49:04 graaff Exp $
+
+WANT_AUTOCONF="latest"
+WANT_AUTOMAKE="latest"
+
+ONIGURUMA="onigd2_5_9"
+
+inherit autotools eutils flag-o-matic multilib versionator
+
+MY_P="${PN}-$(replace_version_separator 3 '-')"
+S=${WORKDIR}/${MY_P}
+
+SLOT=$(get_version_component_range 1-2)
+MY_SUFFIX=$(delete_version_separator 1 ${SLOT})
+
+DESCRIPTION="An object-oriented scripting language"
+HOMEPAGE="http://www.ruby-lang.org/"
+SRC_URI="ftp://ftp.ruby-lang.org/pub/ruby/${SLOT}/${MY_P}.tar.gz
+ cjk? ( http://www.geocities.jp/kosako3/oniguruma/archive/${ONIGURUMA}.tar.gz )"
+
+LICENSE="Ruby"
+KEYWORDS="~alpha ~amd64 ~ia64 ~ppc ~ppc64 ~s390 ~sparc ~x86"
+IUSE="cjk debug doc emacs examples ipv6 rubytests socks5 threads tk xemacs"
+
+RDEPEND=">=sys-libs/gdbm-1.8.0
+ >=sys-libs/readline-4.1
+ >=sys-libs/ncurses-5.2
+ socks5? ( >=net-proxy/dante-1.1.13 )
+ tk? ( dev-lang/tk )
+ >=dev-ruby/ruby-config-0.3.1
+ !=dev-lang/ruby-cvs-${SLOT}*
+ !dev-ruby/rdoc
+ !dev-ruby/rexml"
+DEPEND="${RDEPEND}
+ emacs? ( app-emacs/ruby-mode )
+ xemacs? ( app-xemacs/ruby-modes )"
+
+PROVIDE="virtual/ruby"
+
+src_unpack() {
+ unpack ${A}
+
+ if use cjk ; then
+ einfo "Applying ${ONIGURUMA}"
+ pushd ${WORKDIR}/oniguruma
+ econf --with-rubydir="${S}" || die "oniguruma econf failed"
+ emake $MY_SUFFIX || die "oniguruma emake failed"
+ popd
+ fi
+
+ cd "${S}/ext/dl"
+ epatch "${FILESDIR}/${PN}-1.8.6-memory-leak.diff"
+ cd "${S}"
+
+ epatch "${FILESDIR}/${P}-net-http-p111.patch"
+
+ # Fix a hardcoded lib path in configure script
+ sed -i -e "s:\(RUBY_LIB_PREFIX=\"\${prefix}/\)lib:\1$(get_libdir):" \
+ configure.in || die "sed failed"
+
+ eautoreconf
+}
+
+src_compile() {
+ # -fomit-frame-pointer makes ruby segfault, see bug #150413.
+ filter-flags -fomit-frame-pointer
+ # In many places aliasing rules are broken; play it safe
+ # as it's risky with newer compilers to leave it as it is.
+ append-flags -fno-strict-aliasing
+
+ # Socks support via dante
+ if use socks5 ; then
+ # Socks support can't be disabled as long as SOCKS_SERVER is
+ # set and socks library is present, so need to unset
+ # SOCKS_SERVER in that case.
+ unset SOCKS_SERVER
+ fi
+
+ # Increase GC_MALLOC_LIMIT if set (default is 8000000)
+ if [ -n "${RUBY_GC_MALLOC_LIMIT}" ] ; then
+ append-flags "-DGC_MALLOC_LIMIT=${RUBY_GC_MALLOC_LIMIT}"
+ fi
+
+ econf --program-suffix=$MY_SUFFIX --enable-shared \
+ $(use_enable socks5 socks) \
+ $(use_enable doc install-doc) \
+ $(use_enable threads pthread) \
+ $(use_enable ipv6) \
+ $(use_enable debug) \
+ $(use_with tk) \
+ ${myconf} \
+ --with-sitedir=/usr/$(get_libdir)/ruby/site_ruby \
+ || die "econf failed"
+
+ emake EXTLDFLAGS="${LDFLAGS}" || die "emake failed"
+}
+
+src_test() {
+ emake -j1 test || die "make test failed"
+
+ elog "Ruby's make test has been run. Ruby also ships with a make check"
+ elog "that cannot be run until after ruby has been installed."
+ elog
+ if use rubytests; then
+ elog "You have enabled rubytests, so they will be installed to"
+ elog "/usr/share/${PN}-${SLOT}/test. To run them you must be a user other"
+ elog "than root, and you must place them into a writeable directory."
+ elog "Then call: "
+ elog
+ elog "ruby -C /location/of/tests runner.rb"
+ else
+ elog "Enable the rubytests USE flag to install the make check tests"
+ fi
+}
+
+src_install() {
+ LD_LIBRARY_PATH="${D}/usr/$(get_libdir)"
+ RUBYLIB="${S}:${D}/usr/$(get_libdir)/ruby/${SLOT}"
+ for d in $(find "${S}/ext" -type d) ; do
+ RUBYLIB="${RUBYLIB}:$d"
+ done
+ export LD_LIBRARY_PATH RUBYLIB
+
+ emake DESTDIR="${D}" install || die "make install failed"
+
+ MINIRUBY=$(echo -e 'include Makefile\ngetminiruby:\n\t@echo $(MINIRUBY)'|make -f - getminiruby)
+ keepdir $(${MINIRUBY} -rrbconfig -e "print Config::CONFIG['sitelibdir']")
+ keepdir $(${MINIRUBY} -rrbconfig -e "print Config::CONFIG['sitearchdir']")
+
+ if use doc; then
+ make DESTDIR="${D}" install-doc || die "make install-doc failed"
+ fi
+
+ if use examples; then
+ dodir /usr/share/doc/${PF}
+ cp -pPR sample "${D}/usr/share/doc/${PF}"
+ fi
+
+ dosym libruby$MY_SUFFIX$(get_libname ${PV%_*}) /usr/$(get_libdir)/libruby$(get_libname ${PV%.*})
+ dosym libruby$MY_SUFFIX$(get_libname ${PV%_*}) /usr/$(get_libdir)/libruby$(get_libname ${PV%_*})
+
+ dodoc ChangeLog NEWS README* ToDo
+
+ if use rubytests; then
+ dodir /usr/share/${PN}-${SLOT}
+ cp -pPR test "${D}/usr/share/${PN}-${SLOT}"
+ fi
+}
+
+pkg_postinst() {
+
+ ewarn "If you upgrade to >=sys-apps/coreutils-6.7-r1,"
+ ewarn "you should re-emerge ruby again."
+ ewarn "See bug #159922 for details"
+ ewarn
+ if [[ ! -n $(readlink "${ROOT}"usr/bin/ruby) ]] ; then
+ "${ROOT}usr/sbin/ruby-config" ruby$MY_SUFFIX
+ fi
+ elog
+ elog "You can change the default ruby interpreter by ${ROOT}usr/sbin/ruby-config"
+ elog
+}
+
+pkg_postrm() {
+ if [[ ! -n $(readlink "${ROOT}"usr/bin/ruby) ]] ; then
+ "${ROOT}usr/sbin/ruby-config" ruby$MY_SUFFIX
+ fi
+}