summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>2009-08-30 21:34:13 +0000
committerArfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>2009-08-30 21:34:13 +0000
commit88fce843b8c2c281e9fd8c879151cfd0890a3227 (patch)
treea21d20d30868ddf79609e983e2e46a5ef6323f65 /dev-lang/python
parentold (diff)
downloadgentoo-2-88fce843b8c2c281e9fd8c879151cfd0890a3227.tar.gz
gentoo-2-88fce843b8c2c281e9fd8c879151cfd0890a3227.tar.bz2
gentoo-2-88fce843b8c2c281e9fd8c879151cfd0890a3227.zip
Reenable test_math.py and test_pow.py on alpha (bug #282786).
(Portage version: 14170-svn/cvs/Linux x86_64)
Diffstat (limited to 'dev-lang/python')
-rw-r--r--dev-lang/python/ChangeLog7
-rw-r--r--dev-lang/python/python-2.4.6.ebuild6
-rw-r--r--dev-lang/python/python-2.5.4-r3.ebuild6
-rw-r--r--dev-lang/python/python-2.6.2-r1.ebuild7
-rw-r--r--dev-lang/python/python-3.1.1.ebuild7
5 files changed, 10 insertions, 23 deletions
diff --git a/dev-lang/python/ChangeLog b/dev-lang/python/ChangeLog
index 3ef16e878b32..d41238d0dbef 100644
--- a/dev-lang/python/ChangeLog
+++ b/dev-lang/python/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-lang/python
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/python/ChangeLog,v 1.408 2009/08/28 19:00:17 armin76 Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/python/ChangeLog,v 1.409 2009/08/30 21:34:13 arfrever Exp $
+
+ 30 Aug 2009; Arfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>
+ python-2.4.6.ebuild, python-2.5.4-r3.ebuild, python-2.6.2-r1.ebuild,
+ python-3.1.1.ebuild:
+ Reenable test_math.py and test_pow.py on alpha (bug #282786).
28 Aug 2009; Raúl Porcel <armin76@gentoo.org> python-2.6.2-r1.ebuild:
arm/m68k stable wrt #277645
diff --git a/dev-lang/python/python-2.4.6.ebuild b/dev-lang/python/python-2.4.6.ebuild
index 6d686acbb60d..6df66b6e8474 100644
--- a/dev-lang/python/python-2.4.6.ebuild
+++ b/dev-lang/python/python-2.4.6.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/python/python-2.4.6.ebuild,v 1.12 2009/08/26 14:45:50 arfrever Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/python/python-2.4.6.ebuild,v 1.13 2009/08/30 21:34:13 arfrever Exp $
# NOTE about python-portage interactions :
# - Do not add a pkg_setup() check for a certain version of portage
@@ -188,10 +188,6 @@ src_test() {
# (See bug #67970)
local skip_tests="cookielib distutils global hotshot mimetools minidom mmap posix sax strptime subprocess syntax tcl time urllib urllib2"
- # test_pow fails on alpha.
- # https://bugs.python.org/issue756093
- [[ ${ARCH} == "alpha" ]] && skip_tests+=" pow"
-
for test in ${skip_tests}; do
mv "${S}"/Lib/test/test_${test}.py "${T}"
done
diff --git a/dev-lang/python/python-2.5.4-r3.ebuild b/dev-lang/python/python-2.5.4-r3.ebuild
index 79fc8a2d18d0..407e8acab929 100644
--- a/dev-lang/python/python-2.5.4-r3.ebuild
+++ b/dev-lang/python/python-2.5.4-r3.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/python/python-2.5.4-r3.ebuild,v 1.14 2009/08/26 14:45:51 arfrever Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/python/python-2.5.4-r3.ebuild,v 1.15 2009/08/30 21:34:13 arfrever Exp $
# NOTE about python-portage interactions :
# - Do not add a pkg_setup() check for a certain version of portage
@@ -191,10 +191,6 @@ src_test() {
# (See bug #67970)
local skip_tests="distutils global mimetools minidom mmap posix pyexpat sax strptime subprocess syntax tcl time urllib urllib2 webbrowser xml_etree"
- # test_pow fails on alpha.
- # https://bugs.python.org/issue756093
- [[ ${ARCH} == "alpha" ]] && skip_tests+=" pow"
-
# test_ctypes fails with PAX kernel (bug #234498).
host-is-pax && skip_tests+=" ctypes"
diff --git a/dev-lang/python/python-2.6.2-r1.ebuild b/dev-lang/python/python-2.6.2-r1.ebuild
index 4cd7fba35fc8..4dc2d228347d 100644
--- a/dev-lang/python/python-2.6.2-r1.ebuild
+++ b/dev-lang/python/python-2.6.2-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/python/python-2.6.2-r1.ebuild,v 1.11 2009/08/28 19:00:17 armin76 Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/python/python-2.6.2-r1.ebuild,v 1.12 2009/08/30 21:34:13 arfrever Exp $
# NOTE about python-portage interactions :
# - Do not add a pkg_setup() check for a certain version of portage
@@ -190,11 +190,6 @@ src_test() {
# (See bug #67970)
local skip_tests="distutils global httpservers mimetools minidom mmap posix pyexpat sax strptime subprocess syntax tcl time urllib urllib2 xml_etree"
- # test_math and test_pow fail on alpha.
- # https://bugs.gentoo.org/show_bug.cgi?id=282786
- # https://bugs.python.org/issue756093
- [[ ${ARCH} == "alpha" ]] && skip_tests+=" math pow"
-
# test_ctypes fails with PAX kernel (bug #234498).
host-is-pax && skip_tests+=" ctypes"
diff --git a/dev-lang/python/python-3.1.1.ebuild b/dev-lang/python/python-3.1.1.ebuild
index 056a1de40ebe..d0030ce8673d 100644
--- a/dev-lang/python/python-3.1.1.ebuild
+++ b/dev-lang/python/python-3.1.1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/python/python-3.1.1.ebuild,v 1.5 2009/08/26 14:47:42 arfrever Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/python/python-3.1.1.ebuild,v 1.6 2009/08/30 21:34:13 arfrever Exp $
EAPI="2"
@@ -175,11 +175,6 @@ src_test() {
# socket.error: [Errno 104] Connection reset by peer
skip_tests+=" telnetlib"
- # test_math and test_pow fail on alpha.
- # https://bugs.gentoo.org/show_bug.cgi?id=282786
- # https://bugs.python.org/issue756093
- [[ ${ARCH} == "alpha" ]] && skip_tests+=" math pow"
-
# test_ctypes fails with PAX kernel (bug #234498).
host-is-pax && skip_tests+=" ctypes"