summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2011-10-31 04:02:01 +0000
committerMike Frysinger <vapier@gentoo.org>2011-10-31 04:02:01 +0000
commit8299b943c3e506e269c133d38da01d91232ab42b (patch)
tree4dfff652e09f9afe02fad1d0372ee3b877273c64 /dev-lang/python
parentVersion bump. (diff)
downloadgentoo-2-8299b943c3e506e269c133d38da01d91232ab42b.tar.gz
gentoo-2-8299b943c3e506e269c133d38da01d91232ab42b.tar.bz2
gentoo-2-8299b943c3e506e269c133d38da01d91232ab42b.zip
Drop unnecessary USE=kernel_linux check in plat-linux3 setup.
(Portage version: 2.2.0_alpha71/cvs/Linux x86_64)
Diffstat (limited to 'dev-lang/python')
-rw-r--r--dev-lang/python/ChangeLog7
-rw-r--r--dev-lang/python/python-2.6.7-r2.ebuild8
-rw-r--r--dev-lang/python/python-2.7.2-r2.ebuild8
-rw-r--r--dev-lang/python/python-2.7.2-r3.ebuild8
-rw-r--r--dev-lang/python/python-3.1.4-r2.ebuild8
-rw-r--r--dev-lang/python/python-3.1.4-r3.ebuild8
-rw-r--r--dev-lang/python/python-3.2-r2.ebuild8
-rw-r--r--dev-lang/python/python-3.2.2.ebuild8
8 files changed, 27 insertions, 36 deletions
diff --git a/dev-lang/python/ChangeLog b/dev-lang/python/ChangeLog
index 168118273aed..9705d706a2b5 100644
--- a/dev-lang/python/ChangeLog
+++ b/dev-lang/python/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-lang/python
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/python/ChangeLog,v 1.556 2011/10/30 15:39:27 armin76 Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/python/ChangeLog,v 1.557 2011/10/31 04:02:01 vapier Exp $
+
+ 31 Oct 2011; Mike Frysinger <vapier@gentoo.org> python-2.6.7-r2.ebuild,
+ python-2.7.2-r2.ebuild, python-2.7.2-r3.ebuild, python-3.1.4-r2.ebuild,
+ python-3.1.4-r3.ebuild, python-3.2-r2.ebuild, python-3.2.2.ebuild:
+ Drop unnecessary USE=kernel_linux check in plat-linux3 setup.
30 Oct 2011; Raúl Porcel <armin76@gentoo.org> python-2.7.2-r3.ebuild:
alpha/ia64/s390/sh/sparc stable wrt #387849
diff --git a/dev-lang/python/python-2.6.7-r2.ebuild b/dev-lang/python/python-2.6.7-r2.ebuild
index 5ca7fe52724f..f02fe09a9932 100644
--- a/dev-lang/python/python-2.6.7-r2.ebuild
+++ b/dev-lang/python/python-2.6.7-r2.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/python/python-2.6.7-r2.ebuild,v 1.3 2011/08/07 09:58:09 naota Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/python/python-2.6.7-r2.ebuild,v 1.4 2011/10/31 04:02:01 vapier Exp $
EAPI="2"
WANT_AUTOMAKE="none"
@@ -144,10 +144,8 @@ src_prepare() {
Modules/getpath.c \
setup.py || die "sed failed to replace @@GENTOO_LIBDIR@@"
- #Linux-3 compat. Bug #374579 (upstream issue12571)
- if use kernel_linux; then
- cp -r "${S}/Lib/plat-linux2" "${S}/Lib/plat-linux3" || die "copy plat-linux failed"
- fi
+ # Linux-3 compat. Bug #374579 (upstream issue12571)
+ cp -r "${S}/Lib/plat-linux2" "${S}/Lib/plat-linux3" || die
eautoreconf
}
diff --git a/dev-lang/python/python-2.7.2-r2.ebuild b/dev-lang/python/python-2.7.2-r2.ebuild
index f99c72e53c5e..8f5f8cb8be71 100644
--- a/dev-lang/python/python-2.7.2-r2.ebuild
+++ b/dev-lang/python/python-2.7.2-r2.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/python/python-2.7.2-r2.ebuild,v 1.4 2011/08/27 21:09:43 neurogeek Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/python/python-2.7.2-r2.ebuild,v 1.5 2011/10/31 04:02:01 vapier Exp $
EAPI="2"
WANT_AUTOMAKE="none"
@@ -148,10 +148,8 @@ src_prepare() {
Modules/getpath.c \
setup.py || die "sed failed to replace @@GENTOO_LIBDIR@@"
- #Linux-3 compat. Bug #374579 (upstream issue12571)
- if use kernel_linux; then
- cp -r "${S}/Lib/plat-linux2" "${S}/Lib/plat-linux3" || die "copy plat-linux failed"
- fi
+ # Linux-3 compat. Bug #374579 (upstream issue12571)
+ cp -r "${S}/Lib/plat-linux2" "${S}/Lib/plat-linux3" || die
eautoreconf
}
diff --git a/dev-lang/python/python-2.7.2-r3.ebuild b/dev-lang/python/python-2.7.2-r3.ebuild
index 79f9d1e726b5..c5a88ccdb053 100644
--- a/dev-lang/python/python-2.7.2-r3.ebuild
+++ b/dev-lang/python/python-2.7.2-r3.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/python/python-2.7.2-r3.ebuild,v 1.6 2011/10/30 15:03:40 armin76 Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/python/python-2.7.2-r3.ebuild,v 1.7 2011/10/31 04:02:01 vapier Exp $
EAPI="2"
WANT_AUTOMAKE="none"
@@ -149,10 +149,8 @@ src_prepare() {
Modules/getpath.c \
setup.py || die "sed failed to replace @@GENTOO_LIBDIR@@"
- #Linux-3 compat. Bug #374579 (upstream issue12571)
- if use kernel_linux; then
- cp -r "${S}/Lib/plat-linux2" "${S}/Lib/plat-linux3" || die "copy plat-linux failed"
- fi
+ # Linux-3 compat. Bug #374579 (upstream issue12571)
+ cp -r "${S}/Lib/plat-linux2" "${S}/Lib/plat-linux3" || die
eautoreconf
}
diff --git a/dev-lang/python/python-3.1.4-r2.ebuild b/dev-lang/python/python-3.1.4-r2.ebuild
index ed0996f287d5..52366a5b7d2e 100644
--- a/dev-lang/python/python-3.1.4-r2.ebuild
+++ b/dev-lang/python/python-3.1.4-r2.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/python/python-3.1.4-r2.ebuild,v 1.4 2011/08/27 21:09:43 neurogeek Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/python/python-3.1.4-r2.ebuild,v 1.5 2011/10/31 04:02:01 vapier Exp $
EAPI="3"
WANT_AUTOMAKE="none"
@@ -114,10 +114,8 @@ src_prepare() {
EPATCH_EXCLUDE="${excluded_patches}" EPATCH_SUFFIX="patch" epatch "${patchset_dir}"
- #Linux-3 compat. Bug #374579 (upstream issue12571)
- if use kernel_linux; then
- cp -r "${S}/Lib/plat-linux2" "${S}/Lib/plat-linux3" || die "copy plat-linux failed"
- fi
+ # Linux-3 compat. Bug #374579 (upstream issue12571)
+ cp -r "${S}/Lib/plat-linux2" "${S}/Lib/plat-linux3" || die
sed -i -e "s:@@GENTOO_LIBDIR@@:$(get_libdir):g" \
Lib/distutils/command/install.py \
diff --git a/dev-lang/python/python-3.1.4-r3.ebuild b/dev-lang/python/python-3.1.4-r3.ebuild
index e8777954838e..077d90c71eff 100644
--- a/dev-lang/python/python-3.1.4-r3.ebuild
+++ b/dev-lang/python/python-3.1.4-r3.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/python/python-3.1.4-r3.ebuild,v 1.4 2011/10/27 15:58:07 chainsaw Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/python/python-3.1.4-r3.ebuild,v 1.5 2011/10/31 04:02:01 vapier Exp $
EAPI="3"
WANT_AUTOMAKE="none"
@@ -115,10 +115,8 @@ src_prepare() {
EPATCH_EXCLUDE="${excluded_patches}" EPATCH_SUFFIX="patch" epatch "${patchset_dir}"
epatch "${FILESDIR}/linux2.patch"
- #Linux-3 compat. Bug #374579 (upstream issue12571)
- if use kernel_linux; then
- cp -r "${S}/Lib/plat-linux2" "${S}/Lib/plat-linux3" || die "copy plat-linux failed"
- fi
+ # Linux-3 compat. Bug #374579 (upstream issue12571)
+ cp -r "${S}/Lib/plat-linux2" "${S}/Lib/plat-linux3" || die
sed -i -e "s:@@GENTOO_LIBDIR@@:$(get_libdir):g" \
Lib/distutils/command/install.py \
diff --git a/dev-lang/python/python-3.2-r2.ebuild b/dev-lang/python/python-3.2-r2.ebuild
index 24cb8d51daac..14abc50baa72 100644
--- a/dev-lang/python/python-3.2-r2.ebuild
+++ b/dev-lang/python/python-3.2-r2.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/python/python-3.2-r2.ebuild,v 1.5 2011/10/27 13:56:55 neurogeek Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/python/python-3.2-r2.ebuild,v 1.6 2011/10/31 04:02:01 vapier Exp $
EAPI="3"
WANT_AUTOMAKE="none"
@@ -106,10 +106,8 @@ src_prepare() {
EPATCH_EXCLUDE="${excluded_patches}" EPATCH_SUFFIX="patch" epatch "${patchset_dir}"
- #Linux-3 compat. Bug #374579 (upstream issue12571)
- if use kernel_linux; then
- cp -r "${S}/Lib/plat-linux2" "${S}/Lib/plat-linux3" || die "copy plat-linux failed"
- fi
+ # Linux-3 compat. Bug #374579 (upstream issue12571)
+ cp -r "${S}/Lib/plat-linux2" "${S}/Lib/plat-linux3" || die
sed -i -e "s:@@GENTOO_LIBDIR@@:$(get_libdir):g" \
Lib/distutils/command/install.py \
diff --git a/dev-lang/python/python-3.2.2.ebuild b/dev-lang/python/python-3.2.2.ebuild
index e4be16e822eb..a18d84eb9f29 100644
--- a/dev-lang/python/python-3.2.2.ebuild
+++ b/dev-lang/python/python-3.2.2.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/python/python-3.2.2.ebuild,v 1.2 2011/10/27 13:56:55 neurogeek Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/python/python-3.2.2.ebuild,v 1.3 2011/10/31 04:02:01 vapier Exp $
EAPI="3"
WANT_AUTOMAKE="none"
@@ -106,10 +106,8 @@ src_prepare() {
EPATCH_EXCLUDE="${excluded_patches}" EPATCH_SUFFIX="patch" epatch "${patchset_dir}"
- #Linux-3 compat. Bug #374579 (upstream issue12571)
- if use kernel_linux; then
- cp -r "${S}/Lib/plat-linux2" "${S}/Lib/plat-linux3" || die "copy plat-linux failed"
- fi
+ # Linux-3 compat. Bug #374579 (upstream issue12571)
+ cp -r "${S}/Lib/plat-linux2" "${S}/Lib/plat-linux3" || die
sed -i -e "s:@@GENTOO_LIBDIR@@:$(get_libdir):g" \
Lib/distutils/command/install.py \