summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Gilbert <floppym@gentoo.org>2013-05-09 21:22:05 +0000
committerMike Gilbert <floppym@gentoo.org>2013-05-09 21:22:05 +0000
commit34e5289db4d1d73189fb721c0163153ad779202c (patch)
tree2aa27004d155da704b30b7a36ce234ecc06c99dd /dev-lang/python
parentupdate of icinga to 1.9.0 (diff)
downloadgentoo-2-34e5289db4d1d73189fb721c0163153ad779202c.tar.gz
gentoo-2-34e5289db4d1d73189fb721c0163153ad779202c.tar.bz2
gentoo-2-34e5289db4d1d73189fb721c0163153ad779202c.zip
Don't build the 'maninstall' target; this installs generic symlinks python.1 and python2.1, which we manage using eselect-python. Bug 469148 by Alphat-PC.
(Portage version: 2.2.0_alpha174/cvs/Linux x86_64, signed Manifest commit with key 0BBEEA1FEA4843A4)
Diffstat (limited to 'dev-lang/python')
-rw-r--r--dev-lang/python/ChangeLog6
-rw-r--r--dev-lang/python/python-2.7.4.ebuild4
2 files changed, 7 insertions, 3 deletions
diff --git a/dev-lang/python/ChangeLog b/dev-lang/python/ChangeLog
index 046cb2b5dfee..d4030f5ab468 100644
--- a/dev-lang/python/ChangeLog
+++ b/dev-lang/python/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for dev-lang/python
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/python/ChangeLog,v 1.655 2013/05/09 17:48:03 mgorny Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/python/ChangeLog,v 1.656 2013/05/09 21:22:05 floppym Exp $
+
+ 09 May 2013; Mike Gilbert <floppym@gentoo.org> python-2.7.4.ebuild:
+ Don't build the 'maninstall' target; this installs generic symlinks python.1
+ and python2.1, which we manage using eselect-python. Bug 469148 by Alphat-PC.
09 May 2013; Michał Górny <mgorny@gentoo.org> python-2.5.4-r5.ebuild,
python-2.6.8-r1.ebuild, python-2.7.4.ebuild, python-3.1.5-r1.ebuild,
diff --git a/dev-lang/python/python-2.7.4.ebuild b/dev-lang/python/python-2.7.4.ebuild
index df1f86bcb4ae..5829ae43cf20 100644
--- a/dev-lang/python/python-2.7.4.ebuild
+++ b/dev-lang/python/python-2.7.4.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/python/python-2.7.4.ebuild,v 1.7 2013/05/09 17:48:03 mgorny Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/python/python-2.7.4.ebuild,v 1.8 2013/05/09 21:22:05 floppym Exp $
EAPI="4"
WANT_AUTOMAKE="none"
@@ -298,7 +298,7 @@ src_install() {
local libdir=${ED}/usr/$(get_libdir)/python${SLOT}
cd "${WORKDIR}"/${CHOST}
- emake DESTDIR="${D}" altinstall maninstall
+ emake DESTDIR="${D}" altinstall
sed -e "s/\(LDFLAGS=\).*/\1/" -i "${libdir}/config/Makefile" || die "sed failed"