summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJon Nelson <jnelson@gentoo.org>2002-10-20 23:07:15 +0000
committerJon Nelson <jnelson@gentoo.org>2002-10-20 23:07:15 +0000
commit1f2b34ec1b95621f9ec7f1d84a74f93d41e8f198 (patch)
treea72e9054c9ee973bcb260754e4dad686203b80d0 /dev-lang/python
parentfix xft-quality.diff for 4.2.1 (diff)
downloadgentoo-2-1f2b34ec1b95621f9ec7f1d84a74f93d41e8f198.tar.gz
gentoo-2-1f2b34ec1b95621f9ec7f1d84a74f93d41e8f198.tar.bz2
gentoo-2-1f2b34ec1b95621f9ec7f1d84a74f93d41e8f198.zip
2.2.2 masked via ~
Diffstat (limited to 'dev-lang/python')
-rw-r--r--dev-lang/python/ChangeLog6
-rw-r--r--dev-lang/python/files/digest-python-2.2.21
-rw-r--r--dev-lang/python/python-2.2.2.ebuild93
3 files changed, 99 insertions, 1 deletions
diff --git a/dev-lang/python/ChangeLog b/dev-lang/python/ChangeLog
index fe7df495dd20..cbea962973b5 100644
--- a/dev-lang/python/ChangeLog
+++ b/dev-lang/python/ChangeLog
@@ -1,7 +1,11 @@
# ChangeLog for dev-lang/python
# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/python/ChangeLog,v 1.16 2002/10/15 19:50:14 azarah Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/python/ChangeLog,v 1.17 2002/10/20 23:07:15 jnelson Exp $
+*python-2.2.2 (20 Oct 2002)
+ 20 Oct 2002; Jon Nelson <jnelson@gentoo.org> :
+ 2.2.2 is released
+
*python-2.2.1-r5 (03 Oct 2002)
15 Oct 2002; Martin Schlemmer <azarah@gentoo.org> :
diff --git a/dev-lang/python/files/digest-python-2.2.2 b/dev-lang/python/files/digest-python-2.2.2
new file mode 100644
index 000000000000..39bd384a93cf
--- /dev/null
+++ b/dev-lang/python/files/digest-python-2.2.2
@@ -0,0 +1 @@
+MD5 1c1067396e5aa0299978486eb5bd1a5c Python-2.2.2.tgz 6669400
diff --git a/dev-lang/python/python-2.2.2.ebuild b/dev-lang/python/python-2.2.2.ebuild
new file mode 100644
index 000000000000..902c3d95e3fe
--- /dev/null
+++ b/dev-lang/python/python-2.2.2.ebuild
@@ -0,0 +1,93 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/python/python-2.2.2.ebuild,v 1.1 2002/10/20 23:07:15 jnelson Exp $
+
+IUSE="readline tcltk berkdb bootstrap"
+
+PYVER_MAJOR="`echo ${PV} | cut -d '.' -f 1`"
+PYVER_MINOR="`echo ${PV} | cut -d '.' -f 2`"
+PYVER="${PYVER_MAJOR}.${PYVER_MINOR}"
+S=${WORKDIR}/Python-${PV}
+DESCRIPTION="A really great language"
+SRC_URI="http://www.python.org/ftp/python/${PV}/Python-${PV}.tgz"
+
+HOMEPAGE="http://www.python.org"
+LICENSE="PSF-2.2"
+KEYWORDS="~x86 ~ppc ~sparc ~sparc64 ~alpha"
+
+DEPEND="virtual/glibc >=sys-libs/zlib-1.1.3
+ readline? ( >=sys-libs/readline-4.1 >=sys-libs/ncurses-5.2 )
+ berkdb? ( >=sys-libs/db-3 )
+ tcltk? ( >=dev-lang/tk-8.0 )"
+if [ -z "`use build`" -a -z "`use bootstrap`" ]; then
+ DEPEND="$DEPEND dev-libs/expat"
+fi
+RDEPEND="$DEPEND dev-python/python-fchksum"
+
+# The dev-python/python-fchksum RDEPEND is needed to that this python provides
+# the functionality expected from previous pythons.
+
+PROVIDE="virtual/python"
+
+SLOT="2.2"
+
+inherit flag-o-matic
+
+src_compile() {
+ filter-flags -malign-double
+
+ if [ "${ARCH}" = "alpha" ]; then
+ CFLAGS="${CFLAGS} -fPIC"
+ CXXFLAGS="${CXXFLAGS} -fPIC"
+ fi
+ export OPT="$CFLAGS"
+
+ # adjust makefile to install pydoc into ${D} correctly
+ t=${S}/Makefile.pre.in
+ cp $t $t.orig || die
+ sed 's:install-platlib.*:& --install-scripts=$(BINDIR):' $t.orig > $t
+
+ local myopts
+ #if we are creating a new build image, we remove the dependency on g++
+ if [ "`use build`" -a ! "`use bootstrap`" ]
+ then
+ myopts="--with-cxx=no"
+ fi
+
+ econf --with-fpectl \
+ --infodir='${prefix}'/share/info \
+ --mandir='${prefix}'/share/man \
+ $myopts || die
+ emake || die "Parallel make failed"
+}
+
+src_install() {
+ dodir /usr
+ make install prefix=${D}/usr || die
+ rm "${D}/usr/bin/python"
+ dosym python${PYVER_MAJOR} /usr/bin/python
+ dosym python${PYVER_MAJOR}.${PYVER_MINOR} /usr/bin/python${PYVER_MAJOR}
+ dodoc README
+
+ # install our own custom python-config
+ exeinto /usr/bin
+ newexe ${FILESDIR}/python-config-${PV} python-config
+
+ # seems like the build do not install Makefile.pre.in anymore
+ # it probably shouldn't - use DistUtils, people!
+ insinto /usr/lib/python${PYVER}/config
+ doins ${S}/Makefile.pre.in
+
+ # While we're working on the config stuff... Let's fix the OPT var
+ # so that it doesn't have any opts listed in it. Prevents the problem
+ # with compiling things with conflicting opts later.
+ dosed -e 's:^OPT=.*:OPT=-DNDEBUG:' /usr/lib/python${PYVER}/config/Makefile
+
+ # If USE tcltk lets install idle
+ # Need to script the python version in the path
+ if use tcltk; then
+ mkdir "${D}/usr/lib/python${PYVER}/tools"
+ mv "${S}/Tools/idle" "${D}/usr/lib/python${PYVER}/tools/"
+ dosym /usr/lib/python${PYVER}/tools/idle/idle.py /usr/bin/idle.py
+ fi
+}