summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2005-05-28 00:30:08 +0000
committerMike Frysinger <vapier@gentoo.org>2005-05-28 00:30:08 +0000
commit82cfbb087f17cab6e844c8698696d0a2cc96bc7a (patch)
tree3f1a92f34ca8bef0e172f9ea064b49d8df997c34 /dev-lang/python/python-2.4.1.ebuild
parentnet-analyzer/piwi masked per bug 66167 and bug 91466 (diff)
downloadgentoo-2-82cfbb087f17cab6e844c8698696d0a2cc96bc7a.tar.gz
gentoo-2-82cfbb087f17cab6e844c8698696d0a2cc96bc7a.tar.bz2
gentoo-2-82cfbb087f17cab6e844c8698696d0a2cc96bc7a.zip
use versionator eclass instead of echo|cut
(Portage version: 2.0.51.22-r1)
Diffstat (limited to 'dev-lang/python/python-2.4.1.ebuild')
-rw-r--r--dev-lang/python/python-2.4.1.ebuild6
1 files changed, 3 insertions, 3 deletions
diff --git a/dev-lang/python/python-2.4.1.ebuild b/dev-lang/python/python-2.4.1.ebuild
index 2652a4499098..61e77447c9c3 100644
--- a/dev-lang/python/python-2.4.1.ebuild
+++ b/dev-lang/python/python-2.4.1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/python/python-2.4.1.ebuild,v 1.5 2005/05/28 00:21:34 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/python/python-2.4.1.ebuild,v 1.6 2005/05/28 00:30:08 vapier Exp $
# NOTE about python-portage interactions :
# - Do not add a pkg_setup() check for a certain version of portage
@@ -10,8 +10,8 @@
inherit eutils flag-o-matic python multilib
# we need this so that we don't depends on python.eclass
-PYVER_MAJOR="`echo ${PV%_*} | cut -d '.' -f 1`"
-PYVER_MINOR="`echo ${PV%_*} | cut -d '.' -f 2`"
+PYVER_MAJOR=$(get_major_version)
+PYVER_MINOR=$(get_version_component_range 2)
PYVER="${PYVER_MAJOR}.${PYVER_MINOR}"
MY_P="Python-${PV}"