summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGrant Goodyear <g2boojum@gentoo.org>2002-02-23 20:38:06 +0000
committerGrant Goodyear <g2boojum@gentoo.org>2002-02-23 20:38:06 +0000
commitaec5f016ce6835334fb8769b571faf660e730a6e (patch)
treefe8292db428b3edb576c1e17324f1dd8e3205c2a /dev-lang/php
parentImap support now works. Old versions removed. (diff)
downloadgentoo-2-aec5f016ce6835334fb8769b571faf660e730a6e.tar.gz
gentoo-2-aec5f016ce6835334fb8769b571faf660e730a6e.tar.bz2
gentoo-2-aec5f016ce6835334fb8769b571faf660e730a6e.zip
Whoops. Forgot to save before committing.
Diffstat (limited to 'dev-lang/php')
-rw-r--r--dev-lang/php/php-4.1.1-r4.ebuild7
1 files changed, 6 insertions, 1 deletions
diff --git a/dev-lang/php/php-4.1.1-r4.ebuild b/dev-lang/php/php-4.1.1-r4.ebuild
index 7705e3de3356..bc254bd89bfa 100644
--- a/dev-lang/php/php-4.1.1-r4.ebuild
+++ b/dev-lang/php/php-4.1.1-r4.ebuild
@@ -2,7 +2,7 @@
# Distributed under the terms of the GNU General Public License, v2 or later
# Maintainer: Tools Team <tools@gentoo.org>
# Author: Achim Gottinger <achim@gentoo.org>
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/php/php-4.1.1-r4.ebuild,v 1.1 2002/02/23 20:35:19 g2boojum Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/php/php-4.1.1-r4.ebuild,v 1.2 2002/02/23 20:38:06 g2boojum Exp $
S=${WORKDIR}/${P}
DESCRIPTION="HTML embedded scripting language"
@@ -112,6 +112,11 @@ src_compile() {
else
echo "imap compiled w/o SSL"
myconf="$myconf --with-imap"
+ # php build will fail if imap doesn't have SSL support
+ echo "unfortunately, the php build will fail due to"
+ echo "strange header errors in /usr/include/imap4r1.h"
+ echo "Please rebuild uw-imap or pine w/ 'ssl' in USE"
+ die
fi
fi
use libwww && myconf="$myconf --with-xml" || myconf="$myconf --disable-xml"