summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDavid Holm <dholm@gentoo.org>2004-04-24 22:11:43 +0000
committerDavid Holm <dholm@gentoo.org>2004-04-24 22:11:43 +0000
commit23f5d9b6c98de841ef03eac00064ca57d411f274 (patch)
tree1bc7089ccd2865db4ac56d9de7fffed14562f560 /dev-lang/pasm/pasm-1.7.ebuild
parentVersion bump (Manifest recommit) (diff)
downloadgentoo-2-23f5d9b6c98de841ef03eac00064ca57d411f274.tar.gz
gentoo-2-23f5d9b6c98de841ef03eac00064ca57d411f274.tar.bz2
gentoo-2-23f5d9b6c98de841ef03eac00064ca57d411f274.zip
Version bump
Diffstat (limited to 'dev-lang/pasm/pasm-1.7.ebuild')
-rw-r--r--dev-lang/pasm/pasm-1.7.ebuild29
1 files changed, 29 insertions, 0 deletions
diff --git a/dev-lang/pasm/pasm-1.7.ebuild b/dev-lang/pasm/pasm-1.7.ebuild
new file mode 100644
index 000000000000..361b66330dc7
--- /dev/null
+++ b/dev-lang/pasm/pasm-1.7.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2004 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/pasm/pasm-1.7.ebuild,v 1.1 2004/04/24 22:09:46 dholm Exp $
+
+inherit eutils
+
+DESCRIPTION="A portable assembler for processors of the PowerPC family"
+SRC_URI="http://devnull.owl.de/~frank/${PN}.tar.gz"
+HOMEPAGE="http://devnull.owl.de/~frank/pasm_e.html"
+LICENSE="GPL-2"
+SLOT="0"
+IUSE=""
+KEYWORDS="~ppc"
+
+src_unpack() {
+ mkdir -p ${S}/LinuxPPC
+ cd ${S}
+ unpack ${A}
+ epatch ${FILESDIR}/${P}-ppc.patch
+}
+
+src_compile() {
+ emake || die "Compilation failed"
+}
+
+src_install () {
+ dobin pasm || die "Failed to install pasm binary"
+ dodoc pasm.doc || die "Failed to install pasm documentation"
+}