summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTorsten Veller <tove@gentoo.org>2010-09-11 10:14:52 +0000
committerTorsten Veller <tove@gentoo.org>2010-09-11 10:14:52 +0000
commitb0b7058867a9dc0dc7e5539526546217e918f3c8 (patch)
treeda158b0547956a0ed98bf961c2ce4104aa6a5608 /dev-lang/parrot
parentppc stable #329703 (diff)
downloadgentoo-2-b0b7058867a9dc0dc7e5539526546217e918f3c8.tar.gz
gentoo-2-b0b7058867a9dc0dc7e5539526546217e918f3c8.tar.bz2
gentoo-2-b0b7058867a9dc0dc7e5539526546217e918f3c8.zip
Configure mandir (#336785). Cleanup
(Portage version: 2.2_rc77/cvs/Linux x86_64)
Diffstat (limited to 'dev-lang/parrot')
-rw-r--r--dev-lang/parrot/ChangeLog6
-rw-r--r--dev-lang/parrot/parrot-2.4.0.ebuild78
-rw-r--r--dev-lang/parrot/parrot-2.5.0.ebuild78
-rw-r--r--dev-lang/parrot/parrot-2.6.0.ebuild3
4 files changed, 7 insertions, 158 deletions
diff --git a/dev-lang/parrot/ChangeLog b/dev-lang/parrot/ChangeLog
index 4ab65922a4fc..ea4e68402e74 100644
--- a/dev-lang/parrot/ChangeLog
+++ b/dev-lang/parrot/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for dev-lang/parrot
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/parrot/ChangeLog,v 1.34 2010/07/23 15:02:04 tove Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/parrot/ChangeLog,v 1.35 2010/09/11 10:14:52 tove Exp $
+
+ 11 Sep 2010; Torsten Veller <tove@gentoo.org> -parrot-2.4.0.ebuild,
+ -parrot-2.5.0.ebuild, parrot-2.6.0.ebuild:
+ Configure mandir (#336785). Cleanup
*parrot-2.6.0 (23 Jul 2010)
diff --git a/dev-lang/parrot/parrot-2.4.0.ebuild b/dev-lang/parrot/parrot-2.4.0.ebuild
deleted file mode 100644
index 8c7f465d4458..000000000000
--- a/dev-lang/parrot/parrot-2.4.0.ebuild
+++ /dev/null
@@ -1,78 +0,0 @@
-# Copyright 1999-2010 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/parrot/parrot-2.4.0.ebuild,v 1.1 2010/05/19 12:58:00 patrick Exp $
-
-EAPI=3
-
-inherit eutils multilib
-
-DESCRIPTION="Virtual machine designed to efficiently compile and execute bytecode for dynamic languages"
-HOMEPAGE="http://www.parrot.org/"
-SRC_URI="ftp://ftp.parrot.org/pub/parrot/releases/devel/${PV}/${P}.tar.bz2"
-
-LICENSE="Artistic-2"
-SLOT="0"
-KEYWORDS="~amd64 ~ppc ~ppc64 ~sparc ~x86"
-IUSE="opengl nls doc examples gdbm gmp ssl +unicode pcre"
-
-RDEPEND="sys-libs/readline
- opengl? ( virtual/glut )
- nls? ( sys-devel/gettext )
- unicode? ( >=dev-libs/icu-2.6 )
- gdbm? ( >=sys-libs/gdbm-1.8.3-r1 )
- gmp? ( >=dev-libs/gmp-4.1.4 )
- ssl? ( dev-libs/openssl )
- pcre? ( dev-libs/libpcre )"
-
-DEPEND="dev-lang/perl[doc?]
- ${RDEPEND}"
-
-src_configure() {
- myconf="--disable-rpath"
- use unicode || myconf+=" --without-icu"
- use ssl || myconf+=" --without-crypto"
- use gdbm || myconf+=" --without-gdbm"
- use nls || myconf+=" --without-gettext"
- use gmp || myconf+=" --without-gmp"
- use opengl || myconf+=" --without-opengl"
- use pcre || myconf+=" --without-pcre"
-
- perl Configure.pl \
- --ccflags="${CFLAGS}" \
- --linkflags="${LDFLAGS}" \
- --prefix="${EROOT}"/usr \
- --libdir="${EROOT}"/usr/$(get_libdir) \
- --sysconfdir="${EROOT}"/etc \
- --sharedstatedir="${EROOT}"/var/lib/parrot \
- --pkgconfigdir=pkgconfig \
- $myconf || die
-}
-
-src_compile() {
- export LD_LIBRARY_PATH=${LD_LIBRARY_PATH:+$LD_LIBRARY_PATH:}"${S}"/blib/lib
- # occasionally dies in parallel make
- emake -j1 || die
- if use doc ; then
- emake -j1 html || die
- fi
-}
-
-src_test() {
- emake -j1 test || die
-}
-
-src_install() {
- emake -j1 install-dev DESTDIR="${ED}" DOC_DIR="${EROOT}/usr/share/doc/${PF}" || die
- dodoc CREDITS DEPRECATED.pod DONORS.pod NEWS PBC_COMPAT PLATFORMS RESPONSIBLE_PARTIES TODO || die
- if use examples; then
- insinto "${EROOT}/usr/share/doc/${PF}/examples"
- doins -r examples/* || die
- fi
- if use doc; then
- insinto "${EROOT}/usr/share/doc/${PF}/editor"
- doins -r editor || die
- cd docs/html
- dohtml -r developer.html DONORS.pod.html index.html ops.html parrotbug.html pdds.html \
- pmc.html tools.html docs src tools || die
- fi
-}
diff --git a/dev-lang/parrot/parrot-2.5.0.ebuild b/dev-lang/parrot/parrot-2.5.0.ebuild
deleted file mode 100644
index cb29ef6c715b..000000000000
--- a/dev-lang/parrot/parrot-2.5.0.ebuild
+++ /dev/null
@@ -1,78 +0,0 @@
-# Copyright 1999-2010 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/parrot/parrot-2.5.0.ebuild,v 1.1 2010/06/18 07:58:35 patrick Exp $
-
-EAPI=3
-
-inherit eutils multilib
-
-DESCRIPTION="Virtual machine designed to efficiently compile and execute bytecode for dynamic languages"
-HOMEPAGE="http://www.parrot.org/"
-SRC_URI="ftp://ftp.parrot.org/pub/parrot/releases/devel/${PV}/${P}.tar.bz2"
-
-LICENSE="Artistic-2"
-SLOT="0"
-KEYWORDS="~amd64 ~ppc ~ppc64 ~sparc ~x86"
-IUSE="opengl nls doc examples gdbm gmp ssl +unicode pcre"
-
-RDEPEND="sys-libs/readline
- opengl? ( virtual/glut )
- nls? ( sys-devel/gettext )
- unicode? ( >=dev-libs/icu-2.6 )
- gdbm? ( >=sys-libs/gdbm-1.8.3-r1 )
- gmp? ( >=dev-libs/gmp-4.1.4 )
- ssl? ( dev-libs/openssl )
- pcre? ( dev-libs/libpcre )"
-
-DEPEND="dev-lang/perl[doc?]
- ${RDEPEND}"
-
-src_configure() {
- myconf="--disable-rpath"
- use unicode || myconf+=" --without-icu"
- use ssl || myconf+=" --without-crypto"
- use gdbm || myconf+=" --without-gdbm"
- use nls || myconf+=" --without-gettext"
- use gmp || myconf+=" --without-gmp"
- use opengl || myconf+=" --without-opengl"
- use pcre || myconf+=" --without-pcre"
-
- perl Configure.pl \
- --ccflags="${CFLAGS}" \
- --linkflags="${LDFLAGS}" \
- --prefix="${EROOT}"/usr \
- --libdir="${EROOT}"/usr/$(get_libdir) \
- --sysconfdir="${EROOT}"/etc \
- --sharedstatedir="${EROOT}"/var/lib/parrot \
- --pkgconfigdir=pkgconfig \
- $myconf || die
-}
-
-src_compile() {
- export LD_LIBRARY_PATH=${LD_LIBRARY_PATH:+$LD_LIBRARY_PATH:}"${S}"/blib/lib
- # occasionally dies in parallel make
- emake -j1 || die
- if use doc ; then
- emake -j1 html || die
- fi
-}
-
-src_test() {
- emake -j1 test || die
-}
-
-src_install() {
- emake -j1 install-dev DESTDIR="${ED}" DOC_DIR="${EROOT}/usr/share/doc/${PF}" || die
- dodoc CREDITS DEPRECATED.pod DONORS.pod NEWS PBC_COMPAT PLATFORMS RESPONSIBLE_PARTIES TODO || die
- if use examples; then
- insinto "${EROOT}/usr/share/doc/${PF}/examples"
- doins -r examples/* || die
- fi
- if use doc; then
- insinto "${EROOT}/usr/share/doc/${PF}/editor"
- doins -r editor || die
- cd docs/html
- dohtml -r developer.html DONORS.pod.html index.html ops.html parrotbug.html pdds.html \
- pmc.html tools.html docs src tools || die
- fi
-}
diff --git a/dev-lang/parrot/parrot-2.6.0.ebuild b/dev-lang/parrot/parrot-2.6.0.ebuild
index 48282c7cd08a..f89b3b106b26 100644
--- a/dev-lang/parrot/parrot-2.6.0.ebuild
+++ b/dev-lang/parrot/parrot-2.6.0.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/parrot/parrot-2.6.0.ebuild,v 1.1 2010/07/23 15:02:04 tove Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/parrot/parrot-2.6.0.ebuild,v 1.2 2010/09/11 10:14:52 tove Exp $
EAPI=3
@@ -42,6 +42,7 @@ src_configure() {
--linkflags="${LDFLAGS}" \
--prefix="${EROOT}"/usr \
--libdir="${EROOT}"/usr/$(get_libdir) \
+ --mandir="${EROOT}"/usr/share/man \
--sysconfdir="${EROOT}"/etc \
--sharedstatedir="${EROOT}"/var/lib/parrot \
--pkgconfigdir=pkgconfig \