summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthieu Sozeau <mattam@gentoo.org>2004-08-08 09:06:00 +0000
committerMatthieu Sozeau <mattam@gentoo.org>2004-08-08 09:06:00 +0000
commita11f390fe7ef07acefbe74b21aed9fa731917420 (patch)
treefe7897eb9b9465d034e0a0624328af0f3b46901c /dev-lang/ocaml
parentocaml latex use flag (diff)
downloadgentoo-2-a11f390fe7ef07acefbe74b21aed9fa731917420.tar.gz
gentoo-2-a11f390fe7ef07acefbe74b21aed9fa731917420.tar.bz2
gentoo-2-a11f390fe7ef07acefbe74b21aed9fa731917420.zip
Fix bug #50028.
Diffstat (limited to 'dev-lang/ocaml')
-rw-r--r--dev-lang/ocaml/ChangeLog6
-rw-r--r--dev-lang/ocaml/ocaml-3.06-r2.ebuild10
-rw-r--r--dev-lang/ocaml/ocaml-3.07-r1.ebuild9
-rw-r--r--dev-lang/ocaml/ocaml-3.08.ebuild8
4 files changed, 26 insertions, 7 deletions
diff --git a/dev-lang/ocaml/ChangeLog b/dev-lang/ocaml/ChangeLog
index 74c4b5834c3e..f30019d13c7f 100644
--- a/dev-lang/ocaml/ChangeLog
+++ b/dev-lang/ocaml/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for dev-lang/ocaml
# Copyright 2002-2004 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/ocaml/ChangeLog,v 1.40 2004/08/08 07:53:44 mattam Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/ocaml/ChangeLog,v 1.41 2004/08/08 09:06:00 mattam Exp $
+
+ 08 Aug 2004; Matthieu Sozeau <mattam@gentoo.org> ocaml-3.06-r2.ebuild,
+ ocaml-3.07-r1.ebuild, ocaml-3.08.ebuild:
+ Add support for ocamldoc and latex via a new use flag.
*ocaml-3.08 (08 Aug 2004)
diff --git a/dev-lang/ocaml/ocaml-3.06-r2.ebuild b/dev-lang/ocaml/ocaml-3.06-r2.ebuild
index d4705ffa6848..470e147c5f71 100644
--- a/dev-lang/ocaml/ocaml-3.06-r2.ebuild
+++ b/dev-lang/ocaml/ocaml-3.06-r2.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/ocaml/ocaml-3.06-r2.ebuild,v 1.7 2004/07/06 20:51:30 mattam Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/ocaml/ocaml-3.06-r2.ebuild,v 1.8 2004/08/08 09:06:00 mattam Exp $
inherit flag-o-matic eutils
@@ -11,7 +11,7 @@ SRC_URI="http://caml.inria.fr/distrib/${P}/${P}.tar.gz"
LICENSE="QPL-1.0 LGPL-2"
SLOT="0"
KEYWORDS="x86 sparc ppc alpha"
-IUSE="tcltk"
+IUSE="tcltk latex"
DEPEND="virtual/libc
tcltk? ( >=dev-lang/tk-3.3.3 )"
@@ -62,3 +62,9 @@ src_install() {
# documentation
dodoc Changes INSTALL LICENSE README Upgrading
}
+
+pkg_postinst() {
+ if use latex; then
+ echo "TEXINPUTS=/usr/lib/ocaml/ocamldoc:" > /etc/env.d/99ocamldoc
+ fi
+} \ No newline at end of file
diff --git a/dev-lang/ocaml/ocaml-3.07-r1.ebuild b/dev-lang/ocaml/ocaml-3.07-r1.ebuild
index dd699dcffc86..8cfb36853926 100644
--- a/dev-lang/ocaml/ocaml-3.07-r1.ebuild
+++ b/dev-lang/ocaml/ocaml-3.07-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/ocaml/ocaml-3.07-r1.ebuild,v 1.19 2004/07/27 13:14:34 alexander Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/ocaml/ocaml-3.07-r1.ebuild,v 1.20 2004/08/08 09:06:00 mattam Exp $
inherit flag-o-matic eutils
@@ -13,7 +13,7 @@ SRC_URI="http://caml.inria.fr/distrib/${P}/${P}.tar.gz
LICENSE="QPL-1.0 LGPL-2"
SLOT="0"
KEYWORDS="x86 ~sparc ~ppc alpha ~ia64 ~amd64 hppa ~macos"
-IUSE="tcltk"
+IUSE="tcltk latex"
DEPEND="virtual/libc
tcltk? ( >=dev-lang/tk-3.3.3 )"
@@ -81,6 +81,11 @@ pkg_postinst() {
ranlib /usr/lib/ocaml/stdlib.a
ranlib /usr/lib/ocaml/libasmrun.a
+
+ if use latex; then
+ echo "TEXINPUTS=/usr/lib/ocaml/ocamldoc:" > /etc/env.d/99ocamldoc
+ fi
+
echo
einfo "OCaml is not binary compatible from version to version,"
einfo "so you (may) need to rebuild all packages depending on it that"
diff --git a/dev-lang/ocaml/ocaml-3.08.ebuild b/dev-lang/ocaml/ocaml-3.08.ebuild
index b9831707c267..867c26c8ea10 100644
--- a/dev-lang/ocaml/ocaml-3.08.ebuild
+++ b/dev-lang/ocaml/ocaml-3.08.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/ocaml/ocaml-3.08.ebuild,v 1.1 2004/08/08 07:53:44 mattam Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/ocaml/ocaml-3.08.ebuild,v 1.2 2004/08/08 09:06:00 mattam Exp $
inherit flag-o-matic eutils
@@ -12,7 +12,7 @@ SRC_URI="http://caml.inria.fr/distrib/ocaml-3.08/${P}.0.tar.gz"
LICENSE="QPL-1.0 LGPL-2"
SLOT="0"
KEYWORDS="~x86 ~sparc ~ppc ~alpha ~ia64 ~amd64 ~hppa ~macos"
-IUSE="tcltk"
+IUSE="tcltk latex"
DEPEND="virtual/libc
tcltk? ( >=dev-lang/tk-3.3.3 )"
@@ -60,6 +60,10 @@ src_install() {
pkg_postinst() {
ranlib /usr/lib/ocaml/*.a
+ if use latex; then
+ echo "TEXINPUTS=/usr/lib/ocaml/ocamldoc:" > /etc/env.d/99ocamldoc
+ fi
+
echo
einfo "OCaml is not binary compatible from version to version,"
einfo "so you (may) need to rebuild all packages depending on it that"