summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthieu Sozeau <mattam@gentoo.org>2004-08-18 19:39:28 +0000
committerMatthieu Sozeau <mattam@gentoo.org>2004-08-18 19:39:28 +0000
commit2b7247d45cef97ec4c9dca5d77c866a19d2bfa64 (patch)
tree95da510d157cd12d4d649bce1b30e997c62c388a /dev-lang/ocaml/ocaml-3.07-r1.ebuild
parentmanifest recommit (Manifest recommit) (diff)
downloadgentoo-2-2b7247d45cef97ec4c9dca5d77c866a19d2bfa64.tar.gz
gentoo-2-2b7247d45cef97ec4c9dca5d77c866a19d2bfa64.tar.bz2
gentoo-2-2b7247d45cef97ec4c9dca5d77c866a19d2bfa64.zip
Add handling of CFLAGS, resolves bug #51593
Diffstat (limited to 'dev-lang/ocaml/ocaml-3.07-r1.ebuild')
-rw-r--r--dev-lang/ocaml/ocaml-3.07-r1.ebuild12
1 files changed, 11 insertions, 1 deletions
diff --git a/dev-lang/ocaml/ocaml-3.07-r1.ebuild b/dev-lang/ocaml/ocaml-3.07-r1.ebuild
index f793d4298d09..e27fb047f0a6 100644
--- a/dev-lang/ocaml/ocaml-3.07-r1.ebuild
+++ b/dev-lang/ocaml/ocaml-3.07-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/ocaml/ocaml-3.07-r1.ebuild,v 1.22 2004/08/14 04:45:52 weeve Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/ocaml/ocaml-3.07-r1.ebuild,v 1.23 2004/08/18 19:39:28 mattam Exp $
inherit flag-o-matic eutils
@@ -18,6 +18,13 @@ IUSE="tcltk latex"
DEPEND="virtual/libc
tcltk? ( >=dev-lang/tk-3.3.3 )"
+pkg_setup() {
+ ewarn
+ ewarn "Building ocaml with unsafe CFLAGS can have unexpected results"
+ ewarn "Please retry building with safer CFLAGS before reporting bugs"
+ ewarn
+}
+
src_unpack() {
unpack ${P}.tar.gz
cd ${S}
@@ -46,6 +53,9 @@ src_compile() {
-mandir /usr/share/man \
--with-pthread ${myconf} || die
+ sed -i -e "s/\(BYTECCCOMPOPTS=.*\)/\1 ${CFLAGS}/" config/Makefile
+ sed -i -e "s/\(NATIVECCCOMPOPTS=.*\)/\1 ${CFLAGS}/" config/Makefile
+
make world || die
make opt || die
make opt.opt || die