summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSaleem Abdulrasool <compnerd@gentoo.org>2007-05-16 22:29:53 +0000
committerSaleem Abdulrasool <compnerd@gentoo.org>2007-05-16 22:29:53 +0000
commit4ab54a431f4c11be30cf32130aefe7eaafab02e5 (patch)
treec262f565dcd0d243ac1ac4b4ae6f96d07bdce039 /dev-lang/mono
parentAdded latest version. (diff)
downloadgentoo-2-4ab54a431f4c11be30cf32130aefe7eaafab02e5.tar.gz
gentoo-2-4ab54a431f4c11be30cf32130aefe7eaafab02e5.tar.bz2
gentoo-2-4ab54a431f4c11be30cf32130aefe7eaafab02e5.zip
prune unused version
(Portage version: 2.1.2.7)
Diffstat (limited to 'dev-lang/mono')
-rw-r--r--dev-lang/mono/ChangeLog5
-rw-r--r--dev-lang/mono/files/digest-mono-1.2.33
-rw-r--r--dev-lang/mono/mono-1.2.3.ebuild103
3 files changed, 4 insertions, 107 deletions
diff --git a/dev-lang/mono/ChangeLog b/dev-lang/mono/ChangeLog
index 1ab076e7cf26..24246726fdce 100644
--- a/dev-lang/mono/ChangeLog
+++ b/dev-lang/mono/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for dev-lang/mono
# Copyright 2002-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/mono/ChangeLog,v 1.110 2007/05/16 22:24:19 compnerd Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/mono/ChangeLog,v 1.111 2007/05/16 22:29:53 compnerd Exp $
+
+ 16 May 2007; Saleem Abdulrasool <compnerd@gentoo.org> -mono-1.2.3.ebuild:
+ prune unused version
*mono-1.2.4 (16 May 2007)
diff --git a/dev-lang/mono/files/digest-mono-1.2.3 b/dev-lang/mono/files/digest-mono-1.2.3
deleted file mode 100644
index e7200cd74b93..000000000000
--- a/dev-lang/mono/files/digest-mono-1.2.3
+++ /dev/null
@@ -1,3 +0,0 @@
-MD5 d7af3ebcf37967e3548a02f5d61a0ebc mono-1.2.3.tar.gz 20692405
-RMD160 42ee15ed21bd82972c64074870e9282d8668893b mono-1.2.3.tar.gz 20692405
-SHA256 843cbd707e3d6e4fc00c7961b9ed8e5a48498d6bcaadc1f4c00d561d4f3e7f15 mono-1.2.3.tar.gz 20692405
diff --git a/dev-lang/mono/mono-1.2.3.ebuild b/dev-lang/mono/mono-1.2.3.ebuild
deleted file mode 100644
index cf65d2495243..000000000000
--- a/dev-lang/mono/mono-1.2.3.ebuild
+++ /dev/null
@@ -1,103 +0,0 @@
-# Copyright 1999-2007 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/mono/mono-1.2.3.ebuild,v 1.2 2007/02/14 19:38:30 gustavoz Exp $
-
-inherit eutils flag-o-matic multilib autotools
-
-DESCRIPTION="Mono runtime and class libraries, a C# compiler/interpreter"
-HOMEPAGE="http://www.go-mono.com"
-SRC_URI="http://www.go-mono.com/sources/mono/${P}.tar.gz"
-
-LICENSE="|| ( GPL-2 LGPL-2 X11 )"
-SLOT="0"
-KEYWORDS="~amd64 ~ppc ~sparc ~x86"
-IUSE="X nptl"
-
-RDEPEND="!<dev-dotnet/pnet-0.6.12
- >=dev-libs/glib-2.6
- nptl? ( >=sys-devel/gcc-3.3.5-r1 )
- ppc? (
- >=sys-devel/gcc-3.2.3-r4
- >=sys-libs/glibc-2.3.3_pre20040420
- )
- X? ( >=dev-dotnet/libgdiplus-1.2.3 )"
-DEPEND="${RDEPEND}
- sys-devel/bc
- >=dev-util/pkgconfig-0.19"
-PDEPEND="dev-dotnet/pe-format"
-
-# Parallel build unfriendly
-MAKEOPTS="${MAKEOPTS} -j1"
-
-# confcache causes build errors
-RESTRICT="confcache"
-
-function get-memory-total() {
- cat /proc/meminfo | grep MemTotal | sed -r "s/[^0-9]*([[0-9]+).*/\1/"
-}
-
-src_unpack() {
- unpack ${A}
- cd ${S}
-
- # Fix the install path, install into $(libdir)
- sed -i -e 's:$(prefix)/lib:$(libdir):' \
- -i -e 's:$(exec_prefix)/lib:$(libdir):' \
- -i -e "s:'mono_libdir=\${exec_prefix}/lib':\"mono_libdir=\$libdir\":" \
- ${S}/{scripts,mono/metadata}/Makefile.am ${S}/configure.in \
- || die "sed failed"
-
- sed -i -e 's:^libdir.*:libdir=@libdir@:' \
- -i -e 's:${prefix}/lib/:${libdir}/:g' \
- ${S}/{scripts,}/*.pc.in \
- || die "sed failed"
-
- # Remove dummy ltconfig and let libtool handle it
- rm -f ${S}/libgc/ltconfig
-
- einfo "Regenerating the build files, this will take some time..."
- eautoreconf
-}
-
-src_compile() {
- # mono's build system is finiky, strip the flags
- strip-flags
-
- # Enable the 2.0 FX, use the system glib and the gc
- local myconf="--with-preview=yes --with-glib=system --with-gc=included"
-
- # Threading support
- if use amd64 ; then
- # force __thread on amd64 (bug #83770)
- myconf="${myconf} --with-tls=__thread"
- else
- if use nptl ; then
- myconf="${myconf} --with-tls=__thread"
- else
- myconf="${myconf} --with-tls=pthread"
- fi
- fi
-
- # Enable large heaps if memory is more than >=3GB
- if [[ $(get-memory-total) -ge 3145728 ]] ; then
- myconf="${myconf} --with-large-heap=yes"
- fi
-
- # Force the use of monolite mcs to prevent issues with classlibs (bug #118062)
- touch ${S}/mcs/build/deps/use-monolite
-
- econf ${myconf} || die "configure failed"
- emake || die "compile failed"
-}
-
-src_install() {
- emake DESTDIR=${D} install || die "install failed"
-
- dodoc AUTHORS ChangeLog NEWS README
-
- docinto docs
- dodoc docs/*
-
- docinto libgc
- dodoc libgc/ChangeLog
-}