summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJon Portnoy <avenj@gentoo.org>2003-03-29 19:07:33 +0000
committerJon Portnoy <avenj@gentoo.org>2003-03-29 19:07:33 +0000
commit8468b06fcfe4462aa0c1f3d121da20bfbd4206ff (patch)
treef7d57634e297b473ee023a6e373c16dfa356584d /dev-lang/ifc
parentheader fixes for repoman and requirements on sed (diff)
downloadgentoo-2-8468b06fcfe4462aa0c1f3d121da20bfbd4206ff.tar.gz
gentoo-2-8468b06fcfe4462aa0c1f3d121da20bfbd4206ff.tar.bz2
gentoo-2-8468b06fcfe4462aa0c1f3d121da20bfbd4206ff.zip
Bug fix
Diffstat (limited to 'dev-lang/ifc')
-rw-r--r--dev-lang/ifc/ChangeLog8
-rw-r--r--dev-lang/ifc/files/7.0.064-r1/05icc-ifc6
-rw-r--r--dev-lang/ifc/files/7.0.064-r1/ifc4
-rw-r--r--dev-lang/ifc/files/digest-ifc-7.0.064-r11
-rw-r--r--dev-lang/ifc/ifc-7.0.064-r1.ebuild98
5 files changed, 116 insertions, 1 deletions
diff --git a/dev-lang/ifc/ChangeLog b/dev-lang/ifc/ChangeLog
index e3e9326f3c80..de5046594aba 100644
--- a/dev-lang/ifc/ChangeLog
+++ b/dev-lang/ifc/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-lang/ifc
# Copyright 2002-2003 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/ifc/ChangeLog,v 1.7 2003/03/19 15:58:55 avenj Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/ifc/ChangeLog,v 1.8 2003/03/29 19:07:33 avenj Exp $
+
+*ifc-7.0.064-r1 (29 Mar 2003)
+
+ 29 March 2003; Jon Portnoy <avenj@gentoo.org> ifc-7.0.064-r1.ebuild :
+
+ Fixes a bug in the primary ifc executable.
19 March 2003; Jon Portnoy <avenj@gentoo.org> ifc-7.0.064.ebuild :
diff --git a/dev-lang/ifc/files/7.0.064-r1/05icc-ifc b/dev-lang/ifc/files/7.0.064-r1/05icc-ifc
new file mode 100644
index 000000000000..7134ac814afd
--- /dev/null
+++ b/dev-lang/ifc/files/7.0.064-r1/05icc-ifc
@@ -0,0 +1,6 @@
+IA32ROOT=/opt/intel/compiler70/ia32
+INTEL_FLEXLM_LICENSE=/opt/intel/licenses
+LDPATH=/opt/intel/compiler70/ia32/lib
+MANPATH=/opt/intel/compiler70/man
+PATH=/opt/intel/compiler70/ia32/bin
+ROOTPATH=/opt/intel/compiler70/ia32/bin
diff --git a/dev-lang/ifc/files/7.0.064-r1/ifc b/dev-lang/ifc/files/7.0.064-r1/ifc
new file mode 100644
index 000000000000..03a76f00bc51
--- /dev/null
+++ b/dev-lang/ifc/files/7.0.064-r1/ifc
@@ -0,0 +1,4 @@
+#!/bin/sh
+export INTEL_LICENSE_FILE="/opt/intel/licenses"
+export LD_LIBRARY_PATH="/opt/intel/compiler70/ia32/lib"
+/opt/intel/compiler70/ia32/bin/ifcbin $*
diff --git a/dev-lang/ifc/files/digest-ifc-7.0.064-r1 b/dev-lang/ifc/files/digest-ifc-7.0.064-r1
new file mode 100644
index 000000000000..57c793e8ecf4
--- /dev/null
+++ b/dev-lang/ifc/files/digest-ifc-7.0.064-r1
@@ -0,0 +1 @@
+MD5 43a618fbdd8ce01917c5ae656f58bfe4 l_fc_p_7.0.064.tar 88709120
diff --git a/dev-lang/ifc/ifc-7.0.064-r1.ebuild b/dev-lang/ifc/ifc-7.0.064-r1.ebuild
new file mode 100644
index 000000000000..ebaea69b4233
--- /dev/null
+++ b/dev-lang/ifc/ifc-7.0.064-r1.ebuild
@@ -0,0 +1,98 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header:
+
+S=${WORKDIR}
+DESCRIPTION="Intel Fortran Compiler - The Pentium optimized compiler for Linux"
+
+SRC_URI1="http://developer.intel.com/software/products/compilers/downloads/l_fc_p_7.0.064.tar"
+SRC_URI2="ftp://download.intel.com/software/products/compilers/downloads/l_fc_p_7.0.064.tar"
+SRC_URI3="ftp://download.intel.co.jp/software/products/compilers/downloads/l_fc_p_7.0.064.tar"
+SRC_URI="${SRC_URI1} ${SRC_URI2} ${SRC_URI3}"
+
+HOMEPAGE="http://developer.intel.com/software/products/compilers/flin/"
+
+ # Effectively the same license as icc
+LICENSE="icc-7.0"
+SLOT="0"
+KEYWORDS="-* x86"
+
+
+DEPEND=">=virtual/linux-sources-2.4
+ >=sys-libs/glibc-2.2.4
+ sys-apps/cpio
+ app-arch/rpm"
+
+RDEPEND=">=virtual/linux-sources-2.4
+ >=sys-libs/glibc-2.2.4"
+
+src_compile() {
+ # Keep disk space to a minimum
+ rm -f intel-*.ia64.rpm
+
+ mkdir opt
+
+ for x in intel-*.i386.rpm
+ do
+ einfo "Extracting: ${x}"
+ rpm2cpio ${x} | cpio --extract --make-directories --unconditional
+ done
+
+ # From UNTAG_CFG_FILES in 'install'
+ SD=${S}/opt/intel # Build DESTINATION
+ RD=/opt/intel # Real DESTINATION
+ for FILE in $(find $SD/compiler70/ia??/bin/ -regex '.*[ei][cf]p?c$\|.*cfg$\|.*pcl$\|.*vars[^/]*.c?sh$' 2>/dev/null)
+ do
+ sed s@\<INSTALLDIR\>@$RD@g ${FILE} > ${FILE}.abs
+ mv -f ${FILE}.abs ${FILE}
+ chmod 755 ${FILE}
+ done
+
+ # From UNTAG_SUPPORT in 'install'
+ eval `grep "^[ ]*COMBOPACKAGEID=" install`
+
+ SUPPORTFILE=${SD}/compiler70/docs/fsupport
+ sed s@\<INSTALLTIMECOMBOPACKAGEID\>@$COMBOPACKAGEID@g $SUPPORTFILE > $SUPPORTFILE.abs
+ mv $SUPPORTFILE.abs $SUPPORTFILE
+ chmod 644 $SUPPORTFILE
+
+ SUPPORTFILE=${SD}/compiler70/docs/idbsupport
+ sed s@\<INSTALLTIMECOMBOPACKAGEID\>@$COMBOPACKAGEID@g $SUPPORTFILE > $SUPPORTFILE.abs
+ mv $SUPPORTFILE.abs $SUPPORTFILE
+ chmod 644 $SUPPORTFILE
+}
+
+src_install () {
+ dodoc flicense
+ cp -a opt ${D}
+
+ # ifc enviroment
+ insinto /etc/env.d
+ doins ${FILESDIR}/${PVR}/05icc-ifc
+ # fix the issue with the primary ifc executable
+ exeinto /opt/intel/compiler70/ia32/bin
+ doexe ${FILESDIR}/${PVR}/ifc
+}
+
+pkg_postinst () {
+ einfo
+ einfo "http://www.intel.com/software/products/compilers/flin/noncom.htm"
+ einfo "From the above url you can get a free, non-time limited, non-commercial"
+ einfo "personal use license key that comes with no support. You will need to read"
+ einfo "and agree to the license and then fill in your info to have one emailed to"
+ einfo "you. Read the website for the details."
+ einfo
+ einfo "Documentation can be found in /opt/intel/compiler70/docs/"
+ einfo
+ einfo "You will need to place your license in /opt/intel/licenses/"
+ einfo
+ ewarn
+ ewarn "Packages compiled with older versions of icc will need"
+ ewarn "to be recompiled. Until you do that, old packages will"
+ ewarn "work if you edit /etc/ld.so.conf and change 'compiler70'"
+ ewarn "to 'compiler60' and run 'ldconfig.' Note that this edit"
+ ewarn "won't persist and will require you to re-edit after each"
+ ewarn "package you re-install."
+ ewarn "Due to a bug in ifc 7.0, the primary executable (ifc) may not work."
+ ewarn "Instead of invoking the compiler as ifc, use ifcbin."
+}