summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGeorge Shapovalov <george@gentoo.org>2006-04-01 12:22:18 +0000
committerGeorge Shapovalov <george@gentoo.org>2006-04-01 12:22:18 +0000
commitc0e5417f62d20b20c12a3dfc2491ff3a4c9b57f7 (patch)
treef001d6e96c76c8313be63ecaab5a927929deac21 /dev-lang/icon/icon-9.4.3-r1.ebuild
parenthanging repoman probably invalidated manifest (diff)
downloadgentoo-2-c0e5417f62d20b20c12a3dfc2491ff3a4c9b57f7.tar.gz
gentoo-2-c0e5417f62d20b20c12a3dfc2491ff3a4c9b57f7.tar.bz2
gentoo-2-c0e5417f62d20b20c12a3dfc2491ff3a4c9b57f7.zip
new revision - failing back to stable CFLAGS, disabled experimental features
(Portage version: 2.1_pre7-r2)
Diffstat (limited to 'dev-lang/icon/icon-9.4.3-r1.ebuild')
-rw-r--r--dev-lang/icon/icon-9.4.3-r1.ebuild91
1 files changed, 91 insertions, 0 deletions
diff --git a/dev-lang/icon/icon-9.4.3-r1.ebuild b/dev-lang/icon/icon-9.4.3-r1.ebuild
new file mode 100644
index 000000000000..53221504308e
--- /dev/null
+++ b/dev-lang/icon/icon-9.4.3-r1.ebuild
@@ -0,0 +1,91 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/icon/icon-9.4.3-r1.ebuild,v 1.1 2006/04/01 12:22:18 george Exp $
+
+MY_PV=${PV//./}
+SRC_URI="http://www.cs.arizona.edu/icon/ftp/packages/unix/icon.v${MY_PV}src.tgz"
+HOMEPAGE="http://www.cs.arizona.edu/icon/"
+DESCRIPTION="very high level language"
+
+LICENSE="as-is"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~ppc-macos ~sparc ~x86"
+IUSE="X iplsrc"
+
+S=${WORKDIR}/icon.v${MY_PV}src
+
+DEPEND="X? ( || (
+ ( x11-proto/xextproto
+ x11-proto/xproto
+ x11-libs/libX11
+ x11-libs/libXpm
+ x11-libs/libXt )
+ virtual/x11 )
+ )
+ sys-devel/gcc"
+
+src_compile() {
+ # select the right compile target. Note there are many platforms
+ # available
+ local mytarget;
+ if use ppc-macos; then
+ mytarget="ppc_macos"
+ else
+ mytarget="linux"
+ fi
+
+ if use X; then
+ emake X-Configure name=${mytarget} -j1 || die
+ else
+ emake Configure name=${mytarget} -j1 || die
+ fi
+
+ # These features are still experimental and cause some minor test failures
+ # Enable if you are sure you need them
+# echo "#define MultiThread 1" >> src/h/define.h
+# echo "#define EventMon 1" >> src/h/define.h
+# echo "#define Eve 1" >> src/h/define.h
+
+ emake -j1 || die "Make Failed"
+}
+
+src_test() {
+ make Samples || die "Samples failed"
+ make Test || die "Test failed"
+}
+
+src_install() {
+ dodir /usr
+ dodir /usr/bin
+ dodir /usr/lib
+
+ make Install dest="${D}/usr/lib/icon" || die "Make install failed"
+ dosym /usr/lib/icon/bin/icont /usr/bin/icont
+ dosym /usr/lib/icon/bin/iconx /usr/bin/iconx
+ dosym /usr/lib/icon/bin/icon /usr/bin/icon
+ dosym /usr/lib/icon/bin/vib /usr/bin/vib
+
+ cd "${S}/man/man1"
+ doman icont.1
+ doman icon.1
+ rm -rf ${D}/usr/lib/icon/man
+
+ cd "${S}/doc"
+ dodoc *.txt *.sed ../README
+ # dohtml ignores all anything except .html files, no use here
+ mkdir -p ${D}/usr/share/doc/${PF}/html
+ cp -dpR *.htm *.gif *.jpg *.css ${D}/usr/share/doc/${PF}/html
+ rm -rf ${D}/usr/lib/icon/{doc,README}
+
+ # optional Icon Programming Library
+ if use iplsrc; then
+ cd "${S}"
+ dodir /usr/lib/icon/ipl
+ rm ipl/BuildBin
+ rm ipl/BuildExe
+ rm ipl/CheckAll
+ rm ipl/Makefile
+ insinto /usr/lib/icon
+ doins -r ipl
+ fi
+}