summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLuis Francisco Araujo <araujo@gentoo.org>2008-03-09 23:56:20 +0000
committerLuis Francisco Araujo <araujo@gentoo.org>2008-03-09 23:56:20 +0000
commit2404218cde5794d113601a9f157aadd5c4bc38c0 (patch)
tree13108f4a062764249f62938b1b4eca0167b1deed /dev-lang/gwydion-dylan
parentDrop to ~mips due to unstable deps (diff)
downloadgentoo-2-2404218cde5794d113601a9f157aadd5c4bc38c0.tar.gz
gentoo-2-2404218cde5794d113601a9f157aadd5c4bc38c0.tar.bz2
gentoo-2-2404218cde5794d113601a9f157aadd5c4bc38c0.zip
Revision bump and fixing bug #189153
(Portage version: 2.1.4.4)
Diffstat (limited to 'dev-lang/gwydion-dylan')
-rw-r--r--dev-lang/gwydion-dylan/ChangeLog10
-rw-r--r--dev-lang/gwydion-dylan/files/gd-gc.patch30
-rw-r--r--dev-lang/gwydion-dylan/gwydion-dylan-2.4.0-r1.ebuild60
3 files changed, 98 insertions, 2 deletions
diff --git a/dev-lang/gwydion-dylan/ChangeLog b/dev-lang/gwydion-dylan/ChangeLog
index 953e4fabfcaf..d472eec87a39 100644
--- a/dev-lang/gwydion-dylan/ChangeLog
+++ b/dev-lang/gwydion-dylan/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-lang/gwydion-dylan
-# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/gwydion-dylan/ChangeLog,v 1.3 2007/07/05 23:52:47 ulm Exp $
+# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/gwydion-dylan/ChangeLog,v 1.4 2008/03/09 23:56:19 araujo Exp $
+
+*gwydion-dylan-2.4.0-r1 (09 Mar 2008)
+
+ 09 Mar 2008; Luis F. Araujo <araujo@gentoo.org> +files/gd-gc.patch,
+ +gwydion-dylan-2.4.0-r1.ebuild:
+ New revision bump fixing bug #189153
05 Jul 2007; Ulrich Mueller <ulm@gentoo.org>
files/50gwydion-dylan-gentoo.el, gwydion-dylan-2.4.0.ebuild:
diff --git a/dev-lang/gwydion-dylan/files/gd-gc.patch b/dev-lang/gwydion-dylan/files/gd-gc.patch
new file mode 100644
index 000000000000..91f4ef736cda
--- /dev/null
+++ b/dev-lang/gwydion-dylan/files/gd-gc.patch
@@ -0,0 +1,30 @@
+diff -Nruwp gwydion-dylan-2.4.0/d2c/runtime/garbage-collection/garbage-collection-exports.dylan gwydion-dylan-2.4.0.orig/d2c/runtime/garbage-collection/garbage-collection-exports.dylan
+--- gwydion-dylan-2.4.0/d2c/runtime/garbage-collection/garbage-collection-exports.dylan 2002-01-25 11:38:07.000000000 +0000
++++ gwydion-dylan-2.4.0.orig/d2c/runtime/garbage-collection/garbage-collection-exports.dylan 2008-03-09 18:28:27.000000000 +0000
+@@ -14,7 +14,6 @@ define module garbage-collection
+
+ export GC-gc-no,
+ // GC-oom-fn, GC-oom-fn-setter,
+- GC-quiet, GC-quiet-setter,
+ GC-dont-gc, GC-dont-gc-setter,
+ GC-dont-expand, GC-dont-expand-setter,
+ GC-full-freq, GC-full-freq-setter,
+diff -Nruwp gwydion-dylan-2.4.0/d2c/runtime/garbage-collection/garbage-collection.dylan gwydion-dylan-2.4.0.orig/d2c/runtime/garbage-collection/garbage-collection.dylan
+--- gwydion-dylan-2.4.0/d2c/runtime/garbage-collection/garbage-collection.dylan 2003-04-08 23:22:30.000000000 +0000
++++ gwydion-dylan-2.4.0.orig/d2c/runtime/garbage-collection/garbage-collection.dylan 2008-03-09 18:22:02.000000000 +0000
+@@ -57,15 +57,6 @@ define sealed method GC-all-interior-poi
+ value;
+ end method GC-all-interior-pointers-setter;
+
+-define sealed method GC-quiet () => (result :: <integer>);
+- as(<integer>, c-variable-ref(int: "&GC_quiet"));
+-end method GC-quiet;
+-
+-define sealed method GC-quiet-setter (value :: <integer>) => (result :: <integer>);
+- c-variable-ref(int: "&GC_quiet") := value;
+- value;
+-end method GC-quiet-setter;
+-
+ define sealed method GC-finalize-on-demand () => (result :: <integer>);
+ as(<integer>, c-variable-ref(int: "&GC_finalize_on_demand"));
+ end method GC-finalize-on-demand;
diff --git a/dev-lang/gwydion-dylan/gwydion-dylan-2.4.0-r1.ebuild b/dev-lang/gwydion-dylan/gwydion-dylan-2.4.0-r1.ebuild
new file mode 100644
index 000000000000..22e525325747
--- /dev/null
+++ b/dev-lang/gwydion-dylan/gwydion-dylan-2.4.0-r1.ebuild
@@ -0,0 +1,60 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/gwydion-dylan/gwydion-dylan-2.4.0-r1.ebuild,v 1.1 2008/03/09 23:56:19 araujo Exp $
+
+inherit eutils elisp-common
+
+DESCRIPTION="The Dylan Programming Language Compiler"
+HOMEPAGE="http://www.gwydiondylan.org/"
+SRC_URI="http://www.gwydiondylan.org/downloads/src/tar/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~x86"
+IUSE="gtk emacs"
+
+DEPEND="( || ( dev-lang/gwydion-dylan-bin
+ dev-lang/gwydion-dylan ) )
+ >=dev-libs/boehm-gc-6.4
+ emacs? ( virtual/emacs )
+ gtk? ( =x11-libs/gtk+-1.2* )"
+RDEPEND=""
+
+SITEFILE=50gwydion-dylan-gentoo.el
+
+src_unpack() {
+ unpack ${A}
+ epatch "${FILESDIR}/gd-gc.patch"
+}
+
+src_compile() {
+ ./configure \
+ --prefix=/usr \
+ --build="${CHOST}" \
+ --infodir=/usr/share/info \
+ --mandir=/usr/share/man \
+ $(use_with gtk) \
+ || die "./configure failed"
+ emake -j1 || die "emake failed"
+ if use emacs; then
+ elisp-compile "${S}"/tools/elisp/*.el
+ fi
+}
+
+src_install() {
+ make DESTDIR="${D}" install \
+ || die "make failed"
+ if use emacs; then
+ elisp-install "${PN}" "${S}"/tools/elisp/*.el "${S}"/tools/elisp/*.elc
+ elisp-site-file-install "${FILESDIR}/${SITEFILE}"
+ fi
+ doenvd "${FILESDIR}/20gwydion-dylan"
+}
+
+pkg_postinst() {
+ use emacs && elisp-site-regen
+}
+
+pkg_postrm() {
+ use emacs && elisp-site-regen
+}