summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSergei Trofimovich <slyfox@gentoo.org>2014-02-12 07:46:29 +0000
committerSergei Trofimovich <slyfox@gentoo.org>2014-02-12 07:46:29 +0000
commit1c13b7da3952db52c4269ccd0a2e656555290e72 (patch)
tree3d45845705053d7a85d15381997e51fb74c8d92c /dev-lang/ghc/ghc-7.4.1.ebuild
parentRemove old. (diff)
downloadgentoo-2-1c13b7da3952db52c4269ccd0a2e656555290e72.tar.gz
gentoo-2-1c13b7da3952db52c4269ccd0a2e656555290e72.tar.bz2
gentoo-2-1c13b7da3952db52c4269ccd0a2e656555290e72.zip
Demote -ggdb3+ down to -ggdb2 (CMM parser currently can't handle line numbers). Bug #482086 by Alexis Ballier.
(Portage version: 2.2.8-r1/cvs/Linux x86_64, signed Manifest commit with key 611FF3AA)
Diffstat (limited to 'dev-lang/ghc/ghc-7.4.1.ebuild')
-rw-r--r--dev-lang/ghc/ghc-7.4.1.ebuild7
1 files changed, 5 insertions, 2 deletions
diff --git a/dev-lang/ghc/ghc-7.4.1.ebuild b/dev-lang/ghc/ghc-7.4.1.ebuild
index dfca51ec41a9..04e3eb1f58ea 100644
--- a/dev-lang/ghc/ghc-7.4.1.ebuild
+++ b/dev-lang/ghc/ghc-7.4.1.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2012 Gentoo Foundation
+# Copyright 1999-2014 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/ghc/ghc-7.4.1.ebuild,v 1.4 2012/04/13 19:01:18 slyfox Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/ghc/ghc-7.4.1.ebuild,v 1.5 2014/02/12 07:46:29 slyfox Exp $
# Brief explanation of the bootstrap logic:
#
@@ -130,6 +130,9 @@ ghc_setup_cflags() {
strip-flags
strip-unsupported-flags
+ # Cmm can't parse line numbers #482086
+ replace-flags -ggdb[3-9] -ggdb2
+
GHC_FLAGS=""
for flag in ${CFLAGS}; do
case ${flag} in