summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChris White <chriswhite@gentoo.org>2004-10-31 04:20:05 +0000
committerChris White <chriswhite@gentoo.org>2004-10-31 04:20:05 +0000
commitec4917176ea70ee85ce076987f1162d3e416f0a7 (patch)
tree2be54c1c608b635db2e00d06af1ff649c8341174 /dev-lang/fpcsrc/fpcsrc-1.9.4.ebuild
parentstable on amd64 (Manifest recommit) (diff)
downloadgentoo-2-ec4917176ea70ee85ce076987f1162d3e416f0a7.tar.gz
gentoo-2-ec4917176ea70ee85ce076987f1162d3e416f0a7.tar.bz2
gentoo-2-ec4917176ea70ee85ce076987f1162d3e416f0a7.zip
You thought fpc was fun! Now you get fpc-source, fpscrc, and fpc! Whose happy now :D. This closes bug #69336 btw :).
Diffstat (limited to 'dev-lang/fpcsrc/fpcsrc-1.9.4.ebuild')
-rw-r--r--dev-lang/fpcsrc/fpcsrc-1.9.4.ebuild33
1 files changed, 33 insertions, 0 deletions
diff --git a/dev-lang/fpcsrc/fpcsrc-1.9.4.ebuild b/dev-lang/fpcsrc/fpcsrc-1.9.4.ebuild
new file mode 100644
index 000000000000..64eab1619260
--- /dev/null
+++ b/dev-lang/fpcsrc/fpcsrc-1.9.4.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2004 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/fpcsrc/fpcsrc-1.9.4.ebuild,v 1.1 2004/10/31 04:20:05 chriswhite Exp $
+
+inherit rpm
+
+DESCRIPTION="The sources of the Free Pascal compiler"
+HOMEPAGE="http://www.freepascal.org/"
+SRC_URI="ftp://ftp.freepascal.org/pub/fpc/beta/linux-i386-${PV}/fpc-${PV}-0.src.rpm"
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86"
+IUSE=""
+DEPEND=""
+
+src_unpack() {
+ rpm_unpack ${DISTDIR}/fpc-${PV}-0.src.rpm
+}
+
+src_compile() {
+ einfo "Nothing to compile"
+}
+
+src_install() {
+ cd ${WORKDIR}
+ tar -zxf fpc-${PV}-src.tar.gz
+ dodir /usr/share/src/fpc-${PV}
+ mv ${WORKDIR}/compiler ${D}usr/share/src/fpc-${PV}
+ mv ${WORKDIR}/demo ${D}usr/share/src/fpc-${PV}
+ mv ${WORKDIR}/fcl ${D}usr/share/src/fpc-${PV}
+ mv ${WORKDIR}/packages ${D}usr/share/src/fpc-${PV}
+ mv ${WORKDIR}/rtl ${D}usr/share/src/fpc-${PV}
+}