summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDonnie Berkholz <spyderous@gentoo.org>2006-05-14 07:31:31 +0000
committerDonnie Berkholz <spyderous@gentoo.org>2006-05-14 07:31:31 +0000
commit370f98254d8a1883ca48fcdf01c66271b77bf980 (patch)
treefb2bc7209a6f44c9c36b8aed1905882a85b6ad9e /dev-lang/f2c/f2c-20060507.ebuild
parentRemoved old version. (diff)
downloadgentoo-2-370f98254d8a1883ca48fcdf01c66271b77bf980.tar.gz
gentoo-2-370f98254d8a1883ca48fcdf01c66271b77bf980.tar.bz2
gentoo-2-370f98254d8a1883ca48fcdf01c66271b77bf980.zip
Bump. Incorporates security fix from 20030320-r1, adds some fixes for unusual situations and adds --help and --version.
(Portage version: 2.1_pre10-r5)
Diffstat (limited to 'dev-lang/f2c/f2c-20060507.ebuild')
-rw-r--r--dev-lang/f2c/f2c-20060507.ebuild37
1 files changed, 37 insertions, 0 deletions
diff --git a/dev-lang/f2c/f2c-20060507.ebuild b/dev-lang/f2c/f2c-20060507.ebuild
new file mode 100644
index 000000000000..1338d5380f7e
--- /dev/null
+++ b/dev-lang/f2c/f2c-20060507.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/f2c/f2c-20060507.ebuild,v 1.1 2006/05/14 07:31:31 spyderous Exp $
+
+inherit eutils toolchain-funcs
+
+DESCRIPTION="Fortran to C converter"
+HOMEPAGE="http://www.netlib.org/f2c"
+#SRC_URI="ftp://netlib.bell-labs.com/netlib/f2c/src.tar"
+# To create, download src.tar, ungzip everything inside, then tar.bz2 the whole
+# thing.
+SRC_URI="mirror://gentoo/${P}.tar.bz2"
+
+LICENSE="libf2c"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~ppc ~ppc64 ~sparc ~x86"
+
+IUSE=""
+RDEPEND="dev-libs/libf2c"
+DEPEND="${RDEPEND}"
+
+S="${WORKDIR}/src"
+
+src_compile() {
+ emake \
+ -f makefile.u \
+ CC=$(tc-getCC) \
+ CFLAGS="${CFLAGS}" \
+ || die "make failed"
+}
+
+src_install() {
+ mv -f f2c.1t f2c.1
+ doman f2c.1
+ dobin f2c
+ dodoc README Notice
+}