summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthew Kennedy <mkennedy@gentoo.org>2006-05-27 04:27:43 +0000
committerMatthew Kennedy <mkennedy@gentoo.org>2006-05-27 04:27:43 +0000
commitccd3b16c1d1ca6e0fd2747ce53fc8649547ceacc (patch)
treeeb8990bbb2a8c6da83cab46e183c9d61dd7df082 /dev-lang/erlang
parentManifest regenerated (diff)
downloadgentoo-2-ccd3b16c1d1ca6e0fd2747ce53fc8649547ceacc.tar.gz
gentoo-2-ccd3b16c1d1ca6e0fd2747ce53fc8649547ceacc.tar.bz2
gentoo-2-ccd3b16c1d1ca6e0fd2747ce53fc8649547ceacc.zip
New upstream version.
(Portage version: 2.1_rc2-r3)
Diffstat (limited to 'dev-lang/erlang')
-rw-r--r--dev-lang/erlang/ChangeLog7
-rw-r--r--dev-lang/erlang/erlang-11.2.0.ebuild111
-rw-r--r--dev-lang/erlang/files/digest-erlang-11.2.09
3 files changed, 126 insertions, 1 deletions
diff --git a/dev-lang/erlang/ChangeLog b/dev-lang/erlang/ChangeLog
index 3d2e752cc3dd..ab11be4a3680 100644
--- a/dev-lang/erlang/ChangeLog
+++ b/dev-lang/erlang/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-lang/erlang
# Copyright 1999-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/erlang/ChangeLog,v 1.29 2006/04/10 20:42:54 mkennedy Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/erlang/ChangeLog,v 1.30 2006/05/27 04:27:43 mkennedy Exp $
+
+*erlang-11.2.0 (27 May 2006)
+
+ 27 May 2006; Matthew Kennedy <mkennedy@gentoo.org> +erlang-11.2.0.ebuild:
+ New upstream version.
*erlang-10.2.10 (10 Apr 2006)
diff --git a/dev-lang/erlang/erlang-11.2.0.ebuild b/dev-lang/erlang/erlang-11.2.0.ebuild
new file mode 100644
index 000000000000..64e1e3f82215
--- /dev/null
+++ b/dev-lang/erlang/erlang-11.2.0.ebuild
@@ -0,0 +1,111 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/erlang/erlang-11.2.0.ebuild,v 1.1 2006/05/27 04:27:43 mkennedy Exp $
+
+inherit eutils multilib flag-o-matic elisp-common versionator
+
+#erlang uses a really weird versioning scheme which caused quite a few problems already
+#Thus we do a slight modification converting all letters to digits to make it more sane (see e.g. #26420)
+#the next line selects the right source.
+MY_PV="R$(get_major_version)B-$(get_version_component_range 3)"
+# ATTN!! Take care when processing the C, etc version!
+MY_P=otp_src_${MY_PV}
+DESCRIPTION="Erlang programming language, runtime environment, and large collection of libraries"
+HOMEPAGE="http://www.erlang.org/"
+SRC_URI="http://www.erlang.org/download/${MY_P}.tar.gz
+ doc? ( http://erlang.org/download/otp_doc_man_${MY_PV}.tar.gz
+ http://erlang.org/download/otp_doc_html_${MY_PV}.tar.gz )"
+# Not yet available for 11.2.0
+# http://developer.sipphone.com/ejabberd/erlang_epoll_patch/otp_src_${MY_PV}_epoll.patch"
+
+LICENSE="EPL"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~ppc ~sparc ~x86"
+IUSE="doc emacs java odbc ssl tcltk"
+
+RDEPEND=">=dev-lang/perl-5.6.1
+ ssl? ( >=dev-libs/openssl-0.9.7d )
+ emacs? ( virtual/emacs )
+ java? ( >=virtual/jdk-1.2 )
+ odbc? ( dev-db/unixODBC )"
+DEPEND="${RDEPEND}
+ tcltk? ( dev-lang/tk )"
+
+S=${WORKDIR}/${MY_P}
+
+SITEFILE=50erlang-gentoo.el
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ epatch "${FILESDIR}/${PN}-10.2.7-export-TARGET.patch"
+ epatch "${FILESDIR}/10.2.7-manpage-emacs-gentoo.patch"
+ use odbc || sed -i 's: odbc : :' lib/Makefile
+# epatch "${DISTDIR}"/otp_src_${MY_PV}_epoll.patch
+}
+
+src_compile() {
+ use java || export JAVAC=false
+ econf \
+ --enable-threads \
+ $(use_with ssl) \
+ || die
+ make || die
+
+ if use emacs ; then
+ pushd lib/tools/emacs
+ elisp-compile *.el
+ popd
+ fi
+}
+
+src_install() {
+ local ERL_LIBDIR=/usr/$(get_libdir)/erlang
+
+ make INSTALL_PREFIX="${D}" install || die
+ dodoc AUTHORS EPLICENCE README
+
+ dosym ${ERL_LIBDIR}/bin/erl /usr/bin/erl
+ dosym ${ERL_LIBDIR}/bin/erlc /usr/bin/erlc
+ dosym ${ERL_LIBDIR}/bin/ecc /usr/bin/ecc
+ dosym ${ERL_LIBDIR}/bin/elink /usr/bin/elink
+ dosym ${ERL_LIBDIR}/bin/ear /usr/bin/ear
+ dosym ${ERL_LIBDIR}/bin/escript /usr/bin/escript
+
+ ## Remove ${D} from the following files
+ dosed ${ERL_LIBDIR}/bin/erl
+ dosed ${ERL_LIBDIR}/bin/start
+ cd ${ERL_LIBDIR}/erts-*
+ grep -rle "${D}" "${D}"/${ERL_LIBDIR}/erts-* | xargs sed -i -e "s:${D}::g"
+
+ ## Clean up the no longer needed files
+ rm "${D}"/${ERL_LIBDIR}/Install
+
+ if use doc ; then
+ for file in "${WORKDIR}"/man/man*/*.[1-9]; do
+ # Avoid namespace collisions
+ local newfile=${file}erl
+ cp $file $newfile
+ # Man page processing tools expect a capitalized "SEE ALSO" section
+ # header
+ sed -i -e 's,\.SH See Also,\.SH SEE ALSO,g' $newfile
+ doman ${newfile}
+ done
+ dohtml -A README,erl,hrl,c,h,kwc,info -r "${WORKDIR}"/doc "${WORKDIR}"/lib "${WORKDIR}"/erts-*
+ fi
+
+ if use emacs ; then
+ pushd "${S}"
+ elisp-install erlang lib/tools/emacs/*.{el,elc}
+ elisp-site-file-install "${FILESDIR}"/${SITEFILE}
+ popd
+ fi
+}
+
+pkg_postinst() {
+ use emacs && elisp-site-regen
+}
+
+pkg_postrm() {
+ use emacs && elisp-site-regen
+}
diff --git a/dev-lang/erlang/files/digest-erlang-11.2.0 b/dev-lang/erlang/files/digest-erlang-11.2.0
new file mode 100644
index 000000000000..1c5db659031f
--- /dev/null
+++ b/dev-lang/erlang/files/digest-erlang-11.2.0
@@ -0,0 +1,9 @@
+MD5 8d163f4d16c98ba2e979688842a55a9f otp_doc_html_R11B-0.tar.gz 4662110
+RMD160 ec39aa3e693a0b836b8ca9c360c14c2612c1b813 otp_doc_html_R11B-0.tar.gz 4662110
+SHA256 68cb74d5979dd2ea75c03e892e7ce1446eff27af37d9bdd4fd9778a433a19f68 otp_doc_html_R11B-0.tar.gz 4662110
+MD5 172591538db42e81b814a77f30da4fa4 otp_doc_man_R11B-0.tar.gz 624684
+RMD160 38d9218391147e192d21c438d436c98d7c0f982a otp_doc_man_R11B-0.tar.gz 624684
+SHA256 09b93f43b6bb048d3b66296e94bb6379dbac11217e2ffbe074c2492fe777ee39 otp_doc_man_R11B-0.tar.gz 624684
+MD5 367d9d3ba979cd278b78d6d0393982ba otp_src_R11B-0.tar.gz 10844070
+RMD160 cb2c163f9404feea9b56a5adddb3bdd505e0b494 otp_src_R11B-0.tar.gz 10844070
+SHA256 1806ea681b72be216e5365b29479dcb5253f0d828c021282711f5eae984c9f11 otp_src_R11B-0.tar.gz 10844070