summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMiroslav Šulc <fordfrog@gentoo.org>2015-02-23 21:21:01 +0000
committerMiroslav Šulc <fordfrog@gentoo.org>2015-02-23 21:21:01 +0000
commiteb143ca7ec5ba933aa652d50383acf8a7cf7645f (patch)
tree301ebd49ccec13cc9e308bc5bd0d20957c3235ac /dev-java
parentUpdate the providers (diff)
downloadgentoo-2-eb143ca7ec5ba933aa652d50383acf8a7cf7645f.tar.gz
gentoo-2-eb143ca7ec5ba933aa652d50383acf8a7cf7645f.tar.bz2
gentoo-2-eb143ca7ec5ba933aa652d50383acf8a7cf7645f.zip
dev-java/icedtea: copied ebuilds (by Andrew John Hughes <gnu_andrew@member.fsf.org>) from java-overlay
(Portage version: 2.2.17/cvs/Linux x86_64, signed Manifest commit with key CFE47E2F)
Diffstat (limited to 'dev-java')
-rw-r--r--dev-java/icedtea/ChangeLog12
-rw-r--r--dev-java/icedtea/icedtea-6.1.13.6.ebuild372
-rw-r--r--dev-java/icedtea/icedtea-7.2.5.4.ebuild405
3 files changed, 787 insertions, 2 deletions
diff --git a/dev-java/icedtea/ChangeLog b/dev-java/icedtea/ChangeLog
index 8a25ed92c8c5..5ea11a368ed3 100644
--- a/dev-java/icedtea/ChangeLog
+++ b/dev-java/icedtea/ChangeLog
@@ -1,6 +1,14 @@
# ChangeLog for dev-java/icedtea
-# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-java/icedtea/ChangeLog,v 1.130 2014/11/21 09:52:17 vapier Exp $
+# Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-java/icedtea/ChangeLog,v 1.131 2015/02/23 21:21:01 fordfrog Exp $
+
+*icedtea-7.2.5.4 (23 Feb 2015)
+*icedtea-6.1.13.6 (23 Feb 2015)
+
+ 23 Feb 2015; Miroslav Šulc <fordfrog@gentoo.org> +icedtea-6.1.13.6.ebuild,
+ +icedtea-7.2.5.4.ebuild:
+ copied ebuilds (by Andrew John Hughes <gnu_andrew@member.fsf.org>) from
+ java-overlay
21 Nov 2014; Mike Frysinger <vapier@gentoo.org> icedtea-6.1.12.7.ebuild,
icedtea-6.1.13.3.ebuild, icedtea-6.1.13.4.ebuild, icedtea-7.2.4.3.ebuild,
diff --git a/dev-java/icedtea/icedtea-6.1.13.6.ebuild b/dev-java/icedtea/icedtea-6.1.13.6.ebuild
new file mode 100644
index 000000000000..a5bb6097da65
--- /dev/null
+++ b/dev-java/icedtea/icedtea-6.1.13.6.ebuild
@@ -0,0 +1,372 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-java/icedtea/icedtea-6.1.13.6.ebuild,v 1.1 2015/02/23 21:21:01 fordfrog Exp $
+# Build written by Andrew John Hughes (gnu_andrew@member.fsf.org)
+
+# *********************************************************
+# * IF YOU CHANGE THIS EBUILD, CHANGE ICEDTEA-7.* AS WELL *
+# *********************************************************
+
+EAPI="5"
+
+inherit check-reqs java-pkg-2 java-vm-2 multiprocessing pax-utils prefix versionator virtualx
+
+ICEDTEA_PKG=${PN}$(replace_version_separator 1 -)
+ICEDTEA_BRANCH=$(get_version_component_range 1-3)
+OPENJDK_BUILD="34"
+OPENJDK_DATE="20_jan_2015"
+OPENJDK_TARBALL="openjdk-6-src-b${OPENJDK_BUILD}-${OPENJDK_DATE}.tar.xz"
+# Download cacao and jamvm regardless for use with EXTRA_ECONF
+CACAO_TARBALL="68fe50ac34ec.tar.gz"
+JAMVM_TARBALL="jamvm-ec18fb9e49e62dce16c5094ef1527eed619463aa.tar.gz"
+
+CACAO_GENTOO_TARBALL="icedtea-${ICEDTEA_BRANCH}-cacao-${CACAO_TARBALL}"
+JAMVM_GENTOO_TARBALL="icedtea-${ICEDTEA_BRANCH}-${JAMVM_TARBALL}"
+
+DESCRIPTION="A harness to build OpenJDK using Free Software build tools and dependencies"
+HOMEPAGE="http://icedtea.classpath.org"
+SRC_PKG="${ICEDTEA_PKG}.tar.xz"
+SRC_URI="
+ http://icedtea.classpath.org/download/source/${SRC_PKG}
+ https://java.net/downloads/openjdk6/${OPENJDK_TARBALL}
+ http://icedtea.classpath.org/download/drops/cacao/${CACAO_TARBALL} -> ${CACAO_GENTOO_TARBALL}
+ http://icedtea.classpath.org/download/drops/jamvm/${JAMVM_TARBALL} -> ${JAMVM_GENTOO_TARBALL}"
+
+LICENSE="Apache-1.1 Apache-2.0 GPL-1 GPL-2 GPL-2-with-linking-exception LGPL-2 MPL-1.0 MPL-1.1 public-domain W3C"
+SLOT="6"
+KEYWORDS="~amd64 ~x86"
+
+IUSE="+X +alsa cacao cjk +cups debug doc examples javascript +jbootstrap kerberos +nsplugin
+ +nss pax_kernel pulseaudio selinux +source systemtap test zero +webstart"
+
+# Ideally the following were optional at build time.
+ALSA_COMMON_DEP="
+ >=media-libs/alsa-lib-1.0"
+CUPS_COMMON_DEP="
+ >=net-print/cups-1.2.12"
+X_COMMON_DEP="
+ dev-libs/glib
+ >=media-libs/freetype-2.3.5:2=
+ >=x11-libs/gtk+-2.8:2=
+ >=x11-libs/libX11-1.1.3
+ >=x11-libs/libXext-1.1.1
+ >=x11-libs/libXi-1.1.3
+ >=x11-libs/libXrender-0.9.4
+ >=x11-libs/libXtst-1.0.3
+ x11-libs/libXt"
+X_DEPEND="
+ >=x11-libs/libXau-1.0.3
+ >=x11-libs/libXdmcp-1.0.2
+ >=x11-libs/libXinerama-1.0.2
+ x11-proto/inputproto
+ >=x11-proto/xextproto-7.1.1
+ x11-proto/xineramaproto
+ x11-proto/xproto"
+
+COMMON_DEP="
+ >=media-libs/giflib-4.1.6:=
+ >=media-libs/libpng-1.2:=
+ >=sys-libs/zlib-1.2.3:=
+ virtual/jpeg:0=
+ >=media-libs/lcms-2.5
+ javascript? ( dev-java/rhino:1.6 )
+ kerberos? ( virtual/krb5 )
+ nss? ( >=dev-libs/nss-3.12.5-r1 )
+ pulseaudio? ( >=media-sound/pulseaudio-0.9.11:= )
+ systemtap? ( >=dev-util/systemtap-1 )
+ !dev-java/icedtea-web:6"
+
+# media-fonts/lklug needs ppc ppc64 keywords
+RDEPEND="${COMMON_DEP}
+ !dev-java/icedtea6
+ X? (
+ ${X_COMMON_DEP}
+ media-fonts/dejavu
+ cjk? (
+ media-fonts/arphicfonts
+ media-fonts/baekmuk-fonts
+ !ppc? ( !ppc64? ( media-fonts/lklug ) )
+ media-fonts/lohit-fonts
+ media-fonts/sazanami
+ )
+ )
+ alsa? ( ${ALSA_COMMON_DEP} )
+ cups? ( ${CUPS_COMMON_DEP} )
+ selinux? ( sec-policy/selinux-java )"
+
+# Only ant-core-1.8.1 has fixed ant -diagnostics when xerces+xalan are not present.
+# ca-certificates, perl and openssl are used for the cacerts keystore generation
+# xext headers have two variants depending on version - bug #288855
+# !eclipse-ecj-3.7 - bug #392587
+# autoconf - as long as we use eautoreconf, version restrictions for bug #294918
+DEPEND="${COMMON_DEP} ${ALSA_COMMON_DEP} ${CUPS_COMMON_DEP} ${X_COMMON_DEP}
+ || (
+ >=dev-java/gcj-jdk-4.3
+ dev-java/icedtea-bin:6
+ dev-java/icedtea:6
+ )
+ app-arch/cpio
+ app-arch/unzip
+ app-arch/zip
+ app-misc/ca-certificates
+ >=dev-java/ant-core-1.8.2
+ dev-lang/perl
+ >=dev-libs/libxslt-1.1.26
+ dev-libs/openssl
+ virtual/pkgconfig
+ sys-apps/lsb-release
+ ${X_DEPEND}
+ pax_kernel? ( sys-apps/elfix )"
+
+PDEPEND="webstart? ( dev-java/icedtea-web:0 )
+ nsplugin? ( dev-java/icedtea-web:0[nsplugin] )"
+
+S="${WORKDIR}"/${ICEDTEA_PKG}
+
+icedtea_check_requirements() {
+ local CHECKREQS_DISK_BUILD
+
+ if use doc; then
+ CHECKREQS_DISK_BUILD="8500M"
+ else
+ CHECKREQS_DISK_BUILD="8000M"
+ fi
+
+ check-reqs_pkg_${EBUILD_PHASE}
+}
+
+pkg_pretend() {
+ icedtea_check_requirements
+}
+
+pkg_setup() {
+ icedtea_check_requirements
+
+ JAVA_PKG_WANT_BUILD_VM="
+ icedtea-6 icedtea-bin-6 icedtea6 icedtea6-bin
+ gcj-jdk"
+ JAVA_PKG_WANT_SOURCE="1.5"
+ JAVA_PKG_WANT_TARGET="1.5"
+
+ java-vm-2_pkg_setup
+ java-pkg-2_pkg_setup
+}
+
+src_unpack() {
+ unpack ${SRC_PKG}
+}
+
+java_prepare() {
+ # For bootstrap builds as the sandbox control file might not yet exist.
+ addpredict /proc/self/coredump_filter
+
+ # icedtea doesn't like some locales. #330433 #389717
+ export LANG="C" LC_ALL="C"
+}
+
+bootstrap_impossible() {
+ # Fill this according to testing what works and what not
+ has "${1}" # icedtea6 icedtea-6 icedtea6-bin icedtea-bin-6
+}
+
+src_configure() {
+ local bootstrap cacao_config config hotspot_port use_cacao use_zero zero_config
+ local vm=$(java-pkg_get-current-vm)
+
+ # IcedTea6 can't be built using IcedTea7; its class files are too new
+ # Whether to bootstrap
+ bootstrap="disable"
+ if use jbootstrap; then
+ if bootstrap_impossible "${vm}"; then
+ einfo "Bootstrap with ${vm} is currently not possible and thus disabled, ignoring USE=jbootstrap"
+ else
+ bootstrap="enable"
+ fi
+ fi
+
+ if has "${vm}" gcj-jdk; then
+ # gcj-jdk ensures ecj is present.
+ use jbootstrap || einfo "bootstrap is necessary when building with ${vm}, ignoring USE=\"-jbootstrap\""
+ bootstrap="enable"
+ fi
+
+ config+=" --${bootstrap}-bootstrap"
+
+ # Use Zero if requested
+ if use zero; then
+ use_zero="yes"
+ fi
+
+ # Use CACAO if requested
+ if use cacao; then
+ use_cacao="yes"
+ fi
+
+ # Are we on a architecture with a HotSpot port?
+ # In-tree JIT ports are available for amd64, arm, sparc and x86.
+ if { use amd64 || use arm || use sparc || use x86; }; then
+ hotspot_port="yes"
+ fi
+
+ # Always use HotSpot as the primary VM if available. #389521 #368669 #357633 ...
+ # Otherwise use CACAO on ppc and Zero on anything else
+ if test "x${hotspot_port}" != "xyes"; then
+ if { use ppc || use ppc64; }; then
+ use_cacao="yes"
+ else
+ use_zero="yes"
+ fi
+ fi
+
+ # Turn on CACAO if needed (non-HS archs) or requested
+ if test "x${use_cacao}" = "xyes"; then
+ if test "x${hotspot_port}" = "xyes"; then
+ ewarn 'Enabling CACAO on an architecture with HotSpot support; issues may result.'
+ ewarn 'If so, please rebuild with USE="-cacao"'
+ fi
+ cacao_config="--enable-cacao"
+ fi
+
+ # Turn on Zero if needed (non-HS/CACAO archs) or requested
+ if test "x${use_zero}" = "xyes"; then
+ zero_config="--enable-zero"
+ fi
+
+ config+=" --with-parallel-jobs=$(makeopts_jobs)"
+
+ if use javascript ; then
+ config+=" --with-rhino=$(java-pkg_getjar rhino-1.6 js.jar)"
+ else
+ config+=" --without-rhino"
+ fi
+
+ unset JAVA_HOME JDK_HOME CLASSPATH JAVAC JAVACFLAGS
+
+ econf ${config} \
+ --with-openjdk-src-zip="${DISTDIR}/${OPENJDK_TARBALL}" \
+ --with-cacao-src-zip="${DISTDIR}/${CACAO_GENTOO_TARBALL}" \
+ --with-jamvm-src-zip="${DISTDIR}/${JAMVM_GENTOO_TARBALL}" \
+ --with-jdk-home="$(java-config -O)" \
+ --with-abs-install-dir="${EPREFIX}/usr/$(get_libdir)/icedtea${SLOT}" \
+ --with-pkgversion="Gentoo package ${PF}" \
+ --disable-downloading --disable-Werror \
+ $(use_enable !debug optimizations) \
+ $(use_enable doc docs) \
+ $(use_enable kerberos system-kerberos) \
+ $(use_enable nss) \
+ $(use_enable pulseaudio pulse-java) \
+ $(use_enable systemtap) \
+ $(use_with pax_kernel pax "${EPREFIX}/usr/sbin/paxmark.sh") \
+ ${zero_config} ${cacao_config}
+}
+
+src_compile() {
+ # Would use GENTOO_VM otherwise.
+ export ANT_RESPECT_JAVA_HOME=TRUE
+
+ # With ant >=1.8.2 all required tasks are part of ant-core
+ export ANT_TASKS="none"
+
+ emake
+}
+
+src_test() {
+ # Use Xvfb for tests
+ unset DISPLAY
+
+ Xemake check
+}
+
+src_install() {
+ local dest="/usr/$(get_libdir)/icedtea${SLOT}"
+ local ddest="${ED}/${dest}"
+ dodir "${dest}"
+
+ dodoc README NEWS AUTHORS
+ dosym /usr/share/doc/${PF} /usr/share/doc/${PN}${SLOT}
+
+ cd openjdk.build/j2sdk-image || die
+
+ # Ensures HeadlessGraphicsEnvironment is used.
+ if ! use X; then
+ rm -r jre/lib/$(get_system_arch)/xawt || die
+ fi
+
+ # Don't hide classes
+ rm lib/ct.sym || die
+
+ #402507
+ mkdir jre/.systemPrefs || die
+ touch jre/.systemPrefs/.system.lock || die
+ touch jre/.systemPrefs/.systemRootModFile || die
+
+ # doins can't handle symlinks.
+ cp -vRP bin include jre lib man "${ddest}" || die
+
+ dodoc ASSEMBLY_EXCEPTION THIRD_PARTY_README
+
+ if use doc; then
+ # java-pkg_dohtml needed for package-list #302654
+ java-pkg_dohtml -A dtd -r ../docs/* || die
+ fi
+
+ if use examples; then
+ dodir "${dest}/share"
+ cp -vRP demo sample "${ddest}/share/" || die
+ fi
+
+ if use source; then
+ cp src.zip "${ddest}" || die
+ fi
+
+ # provided by icedtea-web but we need it in JAVA_HOME to work with run-java-tool
+ if use webstart || use nsplugin; then
+ dosym /usr/libexec/icedtea-web/itweb-settings ${dest}/bin/itweb-settings
+ dosym /usr/libexec/icedtea-web/itweb-settings ${dest}/jre/bin/itweb-settings
+ fi
+ if use webstart; then
+ dosym /usr/libexec/icedtea-web/javaws ${dest}/bin/javaws
+ dosym /usr/libexec/icedtea-web/javaws ${dest}/jre/bin/javaws
+ fi
+
+ # Fix the permissions.
+ find "${ddest}" \! -type l \( -perm /111 -exec chmod 755 {} \; -o -exec chmod 644 {} \; \) || die
+
+ # Needs to be done before generating cacerts
+ java-vm_set-pax-markings "${ddest}"
+
+ # We need to generate keystore - bug #273306
+ einfo "Generating cacerts file from certificates in ${EPREFIX}/usr/share/ca-certificates/"
+ mkdir "${T}/certgen" && cd "${T}/certgen" || die
+ cp "${FILESDIR}/generate-cacerts.pl" . && chmod +x generate-cacerts.pl || die
+ for c in "${EPREFIX}"/usr/share/ca-certificates/*/*.crt; do
+ openssl x509 -text -in "${c}" >> all.crt || die
+ done
+ ./generate-cacerts.pl "${ddest}/bin/keytool" all.crt || die
+ cp -vRP cacerts "${ddest}/jre/lib/security/" || die
+ chmod 644 "${ddest}/jre/lib/security/cacerts" || die
+
+ # Bug 390663
+ cp "${FILESDIR}"/fontconfig.Gentoo.properties.src "${T}"/fontconfig.Gentoo.properties || die
+ eprefixify "${T}"/fontconfig.Gentoo.properties
+ insinto "${dest}"/jre/lib
+ doins "${T}"/fontconfig.Gentoo.properties
+
+ set_java_env "${FILESDIR}/icedtea.env"
+ if ! use X || ! use alsa || ! use cups; then
+ java-vm_revdep-mask "${dest}"
+ fi
+ java-vm_sandbox-predict /proc/self/coredump_filter
+}
+
+pkg_preinst() {
+ if has_version "<=dev-java/icedtea-6.1.10.4:${SLOT}"; then
+ # portage would preserve the symlink otherwise, related to bug #384397
+ rm -f "${EROOT}/usr/lib/jvm/icedtea6"
+ elog "To unify the layout and simplify scripts, the identifier of Icedtea-6*"
+ elog "has changed from 'icedtea6' to 'icedtea-6' starting from version 6.1.10.4-r1"
+ elog "If you had icedtea6 as system VM, the change should be automatic, however"
+ elog "build VM settings in /etc/java-config-2/build/jdk.conf are not changed"
+ elog "and the same holds for any user VM settings. Sorry for the inconvenience."
+ fi
+}
diff --git a/dev-java/icedtea/icedtea-7.2.5.4.ebuild b/dev-java/icedtea/icedtea-7.2.5.4.ebuild
new file mode 100644
index 000000000000..9cf36f13191f
--- /dev/null
+++ b/dev-java/icedtea/icedtea-7.2.5.4.ebuild
@@ -0,0 +1,405 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-java/icedtea/icedtea-7.2.5.4.ebuild,v 1.1 2015/02/23 21:21:01 fordfrog Exp $
+# Build written by Andrew John Hughes (gnu_andrew@member.fsf.org)
+
+# *********************************************************
+# * IF YOU CHANGE THIS EBUILD, CHANGE ICEDTEA-6.* AS WELL *
+# *********************************************************
+
+EAPI="5"
+SLOT="7"
+
+inherit check-reqs java-pkg-2 java-vm-2 multiprocessing pax-utils prefix versionator virtualx
+
+ICEDTEA_VER=$(get_version_component_range 2-)
+ICEDTEA_BRANCH=$(get_version_component_range 2-3)
+ICEDTEA_PKG=icedtea-${ICEDTEA_VER}
+CORBA_TARBALL="3c9f523bf96e.tar.bz2"
+JAXP_TARBALL="ca26767d3375.tar.bz2"
+JAXWS_TARBALL="9a6c90336922.tar.bz2"
+JDK_TARBALL="1e6db4f8b0f3.tar.bz2"
+LANGTOOLS_TARBALL="960cdffa8b3f.tar.bz2"
+OPENJDK_TARBALL="6cf2880aab5e.tar.bz2"
+HOTSPOT_TARBALL="6144ca9b6a72.tar.bz2"
+CACAO_TARBALL="e215e36be9fc.tar.gz"
+JAMVM_TARBALL="jamvm-ec18fb9e49e62dce16c5094ef1527eed619463aa.tar.gz"
+
+CORBA_GENTOO_TARBALL="icedtea-${ICEDTEA_BRANCH}-corba-${CORBA_TARBALL}"
+JAXP_GENTOO_TARBALL="icedtea-${ICEDTEA_BRANCH}-jaxp-${JAXP_TARBALL}"
+JAXWS_GENTOO_TARBALL="icedtea-${ICEDTEA_BRANCH}-jaxws-${JAXWS_TARBALL}"
+JDK_GENTOO_TARBALL="icedtea-${ICEDTEA_BRANCH}-jdk-${JDK_TARBALL}"
+LANGTOOLS_GENTOO_TARBALL="icedtea-${ICEDTEA_BRANCH}-langtools-${LANGTOOLS_TARBALL}"
+OPENJDK_GENTOO_TARBALL="icedtea-${ICEDTEA_BRANCH}-openjdk-${OPENJDK_TARBALL}"
+HOTSPOT_GENTOO_TARBALL="icedtea-${ICEDTEA_BRANCH}-hotspot-${HOTSPOT_TARBALL}"
+CACAO_GENTOO_TARBALL="icedtea-${ICEDTEA_BRANCH}-cacao-${CACAO_TARBALL}"
+JAMVM_GENTOO_TARBALL="icedtea-${ICEDTEA_BRANCH}-${JAMVM_TARBALL}"
+
+DROP_URL="http://icedtea.classpath.org/download/drops"
+ICEDTEA_URL="${DROP_URL}/icedtea${SLOT}/${ICEDTEA_VER}"
+
+DESCRIPTION="A harness to build OpenJDK using Free Software build tools and dependencies"
+HOMEPAGE="http://icedtea.classpath.org"
+SRC_PKG="${ICEDTEA_PKG}.tar.xz"
+SRC_URI="
+ http://icedtea.classpath.org/download/source/${SRC_PKG}
+ ${ICEDTEA_URL}/openjdk.tar.bz2 -> ${OPENJDK_GENTOO_TARBALL}
+ ${ICEDTEA_URL}/corba.tar.bz2 -> ${CORBA_GENTOO_TARBALL}
+ ${ICEDTEA_URL}/jaxp.tar.bz2 -> ${JAXP_GENTOO_TARBALL}
+ ${ICEDTEA_URL}/jaxws.tar.bz2 -> ${JAXWS_GENTOO_TARBALL}
+ ${ICEDTEA_URL}/jdk.tar.bz2 -> ${JDK_GENTOO_TARBALL}
+ ${ICEDTEA_URL}/hotspot.tar.bz2 -> ${HOTSPOT_GENTOO_TARBALL}
+ ${ICEDTEA_URL}/langtools.tar.bz2 -> ${LANGTOOLS_GENTOO_TARBALL}
+ ${DROP_URL}/cacao/${CACAO_TARBALL} -> ${CACAO_GENTOO_TARBALL}
+ ${DROP_URL}/jamvm/${JAMVM_TARBALL} -> ${JAMVM_GENTOO_TARBALL}"
+
+LICENSE="Apache-1.1 Apache-2.0 GPL-1 GPL-2 GPL-2-with-linking-exception LGPL-2 MPL-1.0 MPL-1.1 public-domain W3C"
+KEYWORDS="~amd64 ~x86"
+
+IUSE="+X +alsa cacao cjk +cups debug doc examples infinality jamvm javascript +jbootstrap kerberos +nsplugin
+ +nss pax_kernel pulseaudio selinux smartcard +source sunec test zero +webstart"
+
+# Ideally the following were optional at build time.
+ALSA_COMMON_DEP="
+ >=media-libs/alsa-lib-1.0"
+CUPS_COMMON_DEP="
+ >=net-print/cups-1.2.12"
+X_COMMON_DEP="
+ >=dev-libs/atk-1.30.0
+ >=dev-libs/glib-2.26
+ media-libs/fontconfig
+ >=media-libs/freetype-2.5.3:2=[infinality?]
+ >=x11-libs/cairo-1.8.8:=
+ x11-libs/gdk-pixbuf:2
+ >=x11-libs/gtk+-2.8:2=
+ >=x11-libs/libX11-1.1.3
+ >=x11-libs/libXext-1.1.1
+ >=x11-libs/libXi-1.1.3
+ >=x11-libs/libXrender-0.9.4
+ >=x11-libs/libXtst-1.0.3
+ x11-libs/libXt
+ >=x11-libs/pango-1.24.5"
+X_DEPEND="
+ >=x11-libs/libXau-1.0.3
+ >=x11-libs/libXdmcp-1.0.2
+ >=x11-libs/libXinerama-1.0.2
+ x11-proto/inputproto
+ >=x11-proto/xextproto-7.1.1
+ x11-proto/xineramaproto
+ x11-proto/xproto"
+
+COMMON_DEP="
+ >=media-libs/giflib-4.1.6:=
+ >=media-libs/lcms-2.5
+ >=media-libs/libpng-1.2:=
+ >=sys-libs/zlib-1.2.3:=
+ virtual/jpeg:0=
+ javascript? ( dev-java/rhino:1.6 )
+ nss? ( >=dev-libs/nss-3.12.5-r1 )
+ kerberos? ( virtual/krb5 )
+ >=dev-util/systemtap-1
+ smartcard? ( sys-apps/pcsc-lite )
+ sunec? ( >=dev-libs/nss-3.16.1-r1 )
+ !dev-java/icedtea-web:7"
+
+# cups is needed for X. #390945 #390975
+RDEPEND="${COMMON_DEP}
+ !dev-java/icedtea:0
+ X? (
+ ${CUPS_COMMON_DEP}
+ ${X_COMMON_DEP}
+ media-fonts/dejavu
+ cjk? (
+ media-fonts/arphicfonts
+ media-fonts/baekmuk-fonts
+ media-fonts/lklug
+ media-fonts/lohit-fonts
+ media-fonts/sazanami
+ )
+ )
+ alsa? ( ${ALSA_COMMON_DEP} )
+ cups? ( ${CUPS_COMMON_DEP} )
+ selinux? ( sec-policy/selinux-java )"
+
+# Only ant-core-1.8.1 has fixed ant -diagnostics when xerces+xalan are not present.
+# ca-certificates, perl and openssl are used for the cacerts keystore generation
+# xext headers have two variants depending on version - bug #288855
+# autoconf - as long as we use eautoreconf, version restrictions for bug #294918
+DEPEND="${COMMON_DEP} ${ALSA_COMMON_DEP} ${CUPS_COMMON_DEP} ${X_COMMON_DEP}
+ || (
+ >=dev-java/gcj-jdk-4.3
+ dev-java/icedtea-bin:7
+ dev-java/icedtea-bin:6
+ dev-java/icedtea:7
+ dev-java/icedtea:6
+ )
+ app-arch/cpio
+ app-arch/unzip
+ app-arch/zip
+ app-misc/ca-certificates
+ >=dev-java/ant-core-1.8.2
+ dev-lang/perl
+ >=dev-libs/libxslt-1.1.26
+ dev-libs/openssl
+ virtual/pkgconfig
+ sys-apps/attr
+ sys-apps/lsb-release
+ ${X_DEPEND}
+ pax_kernel? ( sys-apps/elfix )"
+
+PDEPEND="webstart? ( dev-java/icedtea-web:0[icedtea7] )
+ nsplugin? ( dev-java/icedtea-web:0[icedtea7,nsplugin] )
+ pulseaudio? ( dev-java/icedtea-sound )"
+
+S="${WORKDIR}"/${ICEDTEA_PKG}
+
+icedtea_check_requirements() {
+ local CHECKREQS_DISK_BUILD
+
+ if use doc; then
+ CHECKREQS_DISK_BUILD="9000M"
+ else
+ CHECKREQS_DISK_BUILD="8500M"
+ fi
+
+ check-reqs_pkg_${EBUILD_PHASE}
+}
+
+pkg_pretend() {
+ icedtea_check_requirements
+}
+
+pkg_setup() {
+ icedtea_check_requirements
+
+ JAVA_PKG_WANT_BUILD_VM="
+ icedtea-7 icedtea-bin-7 icedtea7
+ icedtea-6 icedtea-bin-6 icedtea6 icedtea6-bin
+ gcj-jdk"
+ JAVA_PKG_WANT_SOURCE="1.5"
+ JAVA_PKG_WANT_TARGET="1.5"
+
+ java-vm-2_pkg_setup
+ java-pkg-2_pkg_setup
+}
+
+src_unpack() {
+ unpack ${SRC_PKG}
+}
+
+java_prepare() {
+ # For bootstrap builds as the sandbox control file might not yet exist.
+ addpredict /proc/self/coredump_filter
+
+ # icedtea doesn't like some locales. #330433 #389717
+ export LANG="C" LC_ALL="C"
+}
+
+src_configure() {
+ local bootstrap cacao_config config hotspot_port use_cacao use_zero zero_config
+ local vm=$(java-pkg_get-current-vm)
+
+ # Whether to bootstrap
+ bootstrap="disable"
+ if use jbootstrap; then
+ bootstrap="enable"
+ fi
+
+ if has "${vm}" gcj-jdk; then
+ # gcj-jdk ensures ecj is present.
+ use jbootstrap || einfo "bootstrap is necessary when building with ${vm}, ignoring USE=\"-jbootstrap\""
+ bootstrap="enable"
+ local ecj_jar="$(readlink "${EPREFIX}"/usr/share/eclipse-ecj/ecj.jar)"
+ config+=" --with-ecj-jar=${ecj_jar}"
+ fi
+
+ config+=" --${bootstrap}-bootstrap"
+
+ # Use Zero if requested
+ if use zero; then
+ use_zero="yes"
+ fi
+
+ # Use CACAO if requested
+ if use cacao; then
+ use_cacao="yes"
+ fi
+
+ # Are we on a architecture with a HotSpot port?
+ # In-tree JIT ports are available for amd64, arm, arm64, ppc64 (be&le), SPARC and x86.
+ if { use amd64 || use arm || use arm64 || use ppc64 || use sparc || use x86; }; then
+ hotspot_port="yes"
+ fi
+
+ # Always use HotSpot as the primary VM if available. #389521 #368669 #357633 ...
+ # Otherwise use CACAO on ppc and Zero on anything else
+ if test "x${hotspot_port}" != "xyes"; then
+ if use ppc; then
+ use_cacao="yes"
+ else
+ use_zero="yes"
+ fi
+ fi
+
+ # Turn on CACAO if needed (non-HS archs) or requested
+ if test "x${use_cacao}" = "xyes"; then
+ if test "x${hotspot_port}" = "xyes"; then
+ ewarn 'Enabling CACAO on an architecture with HotSpot support; issues may result.'
+ ewarn 'If so, please rebuild with USE="-cacao"'
+ fi
+ cacao_config="--enable-cacao"
+ fi
+
+ # Turn on Zero if needed (non-HS/CACAO archs) or requested
+ if test "x${use_zero}" = "xyes"; then
+ zero_config="--enable-zero"
+ fi
+
+ config+=" --with-parallel-jobs=$(makeopts_jobs)"
+
+ if use javascript ; then
+ config+=" --with-rhino=$(java-pkg_getjar rhino-1.6 js.jar)"
+ else
+ config+=" --without-rhino"
+ fi
+
+ unset JAVA_HOME JDK_HOME CLASSPATH JAVAC JAVACFLAGS
+
+ econf ${config} \
+ --with-openjdk-src-zip="${DISTDIR}/${OPENJDK_GENTOO_TARBALL}" \
+ --with-corba-src-zip="${DISTDIR}/${CORBA_GENTOO_TARBALL}" \
+ --with-jaxp-src-zip="${DISTDIR}/${JAXP_GENTOO_TARBALL}" \
+ --with-jaxws-src-zip="${DISTDIR}/${JAXWS_GENTOO_TARBALL}" \
+ --with-jdk-src-zip="${DISTDIR}/${JDK_GENTOO_TARBALL}" \
+ --with-hotspot-src-zip="${DISTDIR}/${HOTSPOT_GENTOO_TARBALL}" \
+ --with-langtools-src-zip="${DISTDIR}/${LANGTOOLS_GENTOO_TARBALL}" \
+ --with-cacao-src-zip="${DISTDIR}/${CACAO_GENTOO_TARBALL}" \
+ --with-jamvm-src-zip="${DISTDIR}/${JAMVM_GENTOO_TARBALL}" \
+ --with-jdk-home="$(java-config -O)" \
+ --prefix="${EPREFIX}/usr/$(get_libdir)/icedtea${SLOT}" \
+ --with-pkgversion="Gentoo package ${PF}" \
+ --disable-downloading --disable-Werror \
+ --enable-system-lcms \
+ $(use_enable !debug optimizations) \
+ $(use_enable doc docs) \
+ $(use_enable nss) \
+ $(use_enable jamvm) \
+ $(use_enable kerberos system-kerberos) \
+ $(use_with pax_kernel pax "${EPREFIX}/usr/sbin/paxmark.sh") \
+ $(use_enable smartcard system-pcsc) \
+ $(use_enable sunec) \
+ $(use_enable infinality) \
+ ${zero_config} ${cacao_config}
+}
+
+src_compile() {
+ # Would use GENTOO_VM otherwise.
+ export ANT_RESPECT_JAVA_HOME=TRUE
+
+ # With ant >=1.8.2 all required tasks are part of ant-core
+ export ANT_TASKS="none"
+
+ emake
+}
+
+src_test() {
+ # Use Xvfb for tests
+ unset DISPLAY
+
+ Xemake check
+}
+
+src_install() {
+ local dest="/usr/$(get_libdir)/icedtea${SLOT}"
+ local ddest="${ED}/${dest}"
+ dodir "${dest}"
+
+ dodoc README NEWS AUTHORS
+ dosym /usr/share/doc/${PF} /usr/share/doc/${PN}${SLOT}
+
+ cd openjdk.build/j2sdk-image || die
+
+ # Ensures HeadlessGraphicsEnvironment is used.
+ if ! use X; then
+ rm -r jre/lib/$(get_system_arch)/xawt || die
+ fi
+
+ # Don't hide classes
+ rm lib/ct.sym || die
+
+ #402507
+ mkdir jre/.systemPrefs || die
+ touch jre/.systemPrefs/.system.lock || die
+ touch jre/.systemPrefs/.systemRootModFile || die
+
+ # doins can't handle symlinks.
+ cp -vRP bin include jre lib man "${ddest}" || die
+
+ dodoc ASSEMBLY_EXCEPTION THIRD_PARTY_README
+
+ if use doc; then
+ # java-pkg_dohtml needed for package-list #302654
+ java-pkg_dohtml -A dtd -r ../docs/* || die
+ fi
+
+ if use examples; then
+ dodir "${dest}/share"
+ cp -vRP demo sample "${ddest}/share/" || die
+ fi
+
+ if use source; then
+ cp src.zip "${ddest}" || die
+ fi
+
+ # provided by icedtea-web but we need it in JAVA_HOME to work with run-java-tool
+ if use webstart || use nsplugin; then
+ dosym /usr/libexec/icedtea-web/itweb-settings ${dest}/bin/itweb-settings
+ dosym /usr/libexec/icedtea-web/itweb-settings ${dest}/jre/bin/itweb-settings
+ fi
+ if use webstart; then
+ dosym /usr/libexec/icedtea-web/javaws ${dest}/bin/javaws
+ dosym /usr/libexec/icedtea-web/javaws ${dest}/jre/bin/javaws
+ fi
+
+ # Fix the permissions.
+ find "${ddest}" \! -type l \( -perm /111 -exec chmod 755 {} \; -o -exec chmod 644 {} \; \) || die
+
+ # Needs to be done before generating cacerts
+ java-vm_set-pax-markings "${ddest}"
+
+ # We need to generate keystore - bug #273306
+ einfo "Generating cacerts file from certificates in ${EPREFIX}/usr/share/ca-certificates/"
+ mkdir "${T}/certgen" && cd "${T}/certgen" || die
+ cp "${FILESDIR}/generate-cacerts.pl" . && chmod +x generate-cacerts.pl || die
+ for c in "${EPREFIX}"/usr/share/ca-certificates/*/*.crt; do
+ openssl x509 -text -in "${c}" >> all.crt || die
+ done
+ ./generate-cacerts.pl "${ddest}/bin/keytool" all.crt || die
+ cp -vRP cacerts "${ddest}/jre/lib/security/" || die
+ chmod 644 "${ddest}/jre/lib/security/cacerts" || die
+
+ # OpenJDK7 should be able to use fontconfig instead, but wont hurt to
+ # install it anyway. Bug 390663
+ cp "${FILESDIR}"/fontconfig.Gentoo.properties.src "${T}"/fontconfig.Gentoo.properties || die
+ eprefixify "${T}"/fontconfig.Gentoo.properties
+ insinto "${dest}"/jre/lib
+ doins "${T}"/fontconfig.Gentoo.properties
+
+ set_java_env "${FILESDIR}/icedtea.env"
+ if ! use X || ! use alsa || ! use cups; then
+ java-vm_revdep-mask "${dest}"
+ fi
+ java-vm_sandbox-predict /proc/self/coredump_filter
+}
+
+pkg_preinst() {
+ if has_version "<=dev-java/icedtea-7.2.0:7"; then
+ # portage would preserve the symlink otherwise, related to bug #384397
+ rm -f "${EROOT}/usr/lib/jvm/icedtea7"
+ elog "To unify the layout and simplify scripts, the identifier of Icedtea-7*"
+ elog "has changed from 'icedtea7' to 'icedtea-7' starting from version 7.2.0-r1"
+ elog "If you had icedtea7 as system VM, the change should be automatic, however"
+ elog "build VM settings in /etc/java-config-2/build/jdk.conf are not changed"
+ elog "and the same holds for any user VM settings. Sorry for the inconvenience."
+ fi
+}