summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTom Wijsman <tomwij@gentoo.org>2013-12-30 17:23:46 +0000
committerTom Wijsman <tomwij@gentoo.org>2013-12-30 17:23:46 +0000
commitc11f4c28ecd7a4c2132a2baba348374447f2f735 (patch)
treeb73c9010b57a0380d66b9dafccdc1b32d62d1c27 /dev-java
parentDrop old (diff)
downloadgentoo-2-c11f4c28ecd7a4c2132a2baba348374447f2f735.tar.gz
gentoo-2-c11f4c28ecd7a4c2132a2baba348374447f2f735.tar.bz2
gentoo-2-c11f4c28ecd7a4c2132a2baba348374447f2f735.zip
Dropped vulnerable 1.3.1* (and unused local USE-descriptions gtk2 and gtk3) for security bug #483198.
(Portage version: HEAD/cvs/Linux x86_64, signed Manifest commit with key 6D34E57D)
Diffstat (limited to 'dev-java')
-rw-r--r--dev-java/icedtea-web/ChangeLog7
-rw-r--r--dev-java/icedtea-web/icedtea-web-1.3.1-r7.ebuild128
-rw-r--r--dev-java/icedtea-web/icedtea-web-1.3.1.ebuild128
-rw-r--r--dev-java/icedtea-web/metadata.xml2
4 files changed, 6 insertions, 259 deletions
diff --git a/dev-java/icedtea-web/ChangeLog b/dev-java/icedtea-web/ChangeLog
index eab9f586c6fa..6cf24100d41e 100644
--- a/dev-java/icedtea-web/ChangeLog
+++ b/dev-java/icedtea-web/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-java/icedtea-web
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-java/icedtea-web/ChangeLog,v 1.37 2013/11/11 07:05:55 caster Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-java/icedtea-web/ChangeLog,v 1.38 2013/12/30 17:23:46 tomwij Exp $
+
+ 30 Dec 2013; Tom Wijsman <TomWij@gentoo.org> -icedtea-web-1.3.1-r7.ebuild,
+ -icedtea-web-1.3.1.ebuild, metadata.xml:
+ Dropped vulnerable 1.3.1* (and unused local USE-descriptions gtk2 and gtk3)
+ for security bug #483198.
11 Nov 2013; Vlastimil Babka <caster@gentoo.org> icedtea-web-1.4.1.ebuild,
metadata.xml:
diff --git a/dev-java/icedtea-web/icedtea-web-1.3.1-r7.ebuild b/dev-java/icedtea-web/icedtea-web-1.3.1-r7.ebuild
deleted file mode 100644
index 2b18ad60ad56..000000000000
--- a/dev-java/icedtea-web/icedtea-web-1.3.1-r7.ebuild
+++ /dev/null
@@ -1,128 +0,0 @@
-# Copyright 1999-2012 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-java/icedtea-web/icedtea-web-1.3.1-r7.ebuild,v 1.1 2012/11/14 21:59:24 caster Exp $
-# Build written by Andrew John Hughes (ahughes@redhat.com)
-
-EAPI="4"
-
-inherit autotools eutils java-pkg-2 java-vm-2
-
-DESCRIPTION="FOSS Java browser plugin and Web Start implementation"
-HOMEPAGE="http://icedtea.classpath.org"
-SRC_URI="http://icedtea.classpath.org/download/source/${P}.tar.gz"
-
-LICENSE="GPL-2 GPL-2-with-linking-exception LGPL-2"
-SLOT="7"
-KEYWORDS="~amd64 ~ia64 ~x86"
-
-IUSE="build doc gtk2 gtk3 javascript +nsplugin test"
-
-COMMON_DEP="
- dev-java/icedtea:${SLOT}
- nsplugin? (
- >=dev-libs/glib-2.16
- gtk2? (
- !gtk3? ( >=x11-libs/gtk+-2.6:2 )
- gtk3? ( x11-libs/gtk+:3 )
- )
- !gtk2? ( x11-libs/gtk+:3 )
- )"
-RDEPEND="${COMMON_DEP}"
-# Need system junit 4.8+. Bug #389795
-DEPEND="${COMMON_DEP}
- virtual/pkgconfig
- javascript? ( dev-java/rhino:1.6 )
- nsplugin? ( net-misc/npapi-sdk )
- test? ( >=dev-java/junit-4.8:4 )"
-
-pkg_setup() {
- JAVA_PKG_WANT_BUILD_VM="icedtea-${SLOT} icedtea${SLOT}"
- JAVA_PKG_WANT_SOURCE="1.6"
- JAVA_PKG_WANT_TARGET="1.6"
-
- java-vm-2_pkg_setup
- java-pkg-2_pkg_setup
-
- VMHANDLE="icedtea-${SLOT}"
-}
-
-src_prepare() {
- # bug #356645
- epatch "${FILESDIR}"/0002-Respect-LDFLAGS.patch
- eautoreconf
-}
-
-src_configure() {
- local vmhome=$(java-config -O)
-
- if use build; then
- icedteadir="${ICEDTEA_BIN_DIR}"
- [[ -z ${icedteadir} ]] && die "USE=build is an internal flag and should not be enabled"
- installdir="/opt/icedtea-web-bin-${SLOT}"
- else
- icedteadir="/usr/$(get_libdir)/icedtea${SLOT}"
- installdir="/usr/$(get_libdir)/icedtea${SLOT}-web"
- [[ "${vmhome}" == "${icedteadir}" ]] \
- || die "Unexpected install location of IcedTea ${SLOT} '${vmhome}'"
- fi
-
- einfo "Installing IcedTea-Web in '${installdir}'"
- einfo "Installing IcedTea-Web for IcedTea${SLOT} in '${icedteadir}'"
-
- local gtk_ver=3
- use gtk2 && gtk_ver=2
- use gtk3 && gtk_ver=3
-
- local myconf=(
- # we need to override all *dir variables that econf sets.
- # man page (javaws) is installed directly to icedteadir because it's
- # easier than symlinking, as we don't know the suffix the man page will
- # end up compressed with, anyway
- --prefix="${installdir}"
- --mandir="${icedteadir}"/man
- --infodir="${installdir}"/share/info
- --datadir="${installdir}"/share
- --with-jdk-home="${icedteadir}"
- --with-gtk=${gtk_ver}
- $(use_enable doc docs)
- $(use_enable nsplugin plugin)
- $(use_with javascript rhino)
- )
-
- unset JAVA_HOME JDK_HOME CLASSPATH JAVAC JAVACFLAGS
- econf "${myconf[@]}"
-}
-
-src_compile() {
- # we need this to override the src_compile from java-pkg-2
- default
-}
-
-src_install() {
- # bug #440906
- MAKEOPTS+=" -j1" default
-
- if use nsplugin; then
- install_mozilla_plugin "${installdir}/$(get_libdir)/IcedTeaPlugin.so";
- fi
-
- for binary in javaws itweb-settings; do
- dosym ${installdir}/bin/${binary} ${icedteadir}/bin/${binary}
- dosym ${installdir}/bin/${binary} ${icedteadir}/jre/bin/${binary}
- done
-}
-
-pkg_postinst() {
- java-vm_check-nsplugin
- java_mozilla_clean_
-
- if use nsplugin; then
- elog "The icedtea browser plugin (NPPlugin) can be enabled using eselect java-nsplugin"
- fi
-}
-
-pkg_prerm() {
- # override the java-vm-2 eclass check for removing a system VM, as it
- # doesn't make sense here.
- :;
-}
diff --git a/dev-java/icedtea-web/icedtea-web-1.3.1.ebuild b/dev-java/icedtea-web/icedtea-web-1.3.1.ebuild
deleted file mode 100644
index 3419761ef915..000000000000
--- a/dev-java/icedtea-web/icedtea-web-1.3.1.ebuild
+++ /dev/null
@@ -1,128 +0,0 @@
-# Copyright 1999-2013 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-java/icedtea-web/icedtea-web-1.3.1.ebuild,v 1.2 2013/02/05 07:31:48 zerochaos Exp $
-# Build written by Andrew John Hughes (ahughes@redhat.com)
-
-EAPI="4"
-
-inherit autotools eutils java-pkg-2 java-vm-2
-
-DESCRIPTION="FOSS Java browser plugin and Web Start implementation"
-HOMEPAGE="http://icedtea.classpath.org"
-SRC_URI="http://icedtea.classpath.org/download/source/${P}.tar.gz"
-
-LICENSE="GPL-2 GPL-2-with-linking-exception LGPL-2"
-SLOT="6"
-KEYWORDS="~amd64 ~arm ~ia64 ~ppc ~ppc64 ~x86"
-
-IUSE="build doc gtk2 gtk3 javascript +nsplugin test"
-
-COMMON_DEP="
- dev-java/icedtea:${SLOT}
- nsplugin? (
- >=dev-libs/glib-2.16
- gtk2? (
- !gtk3? ( >=x11-libs/gtk+-2.6:2 )
- gtk3? ( x11-libs/gtk+:3 )
- )
- !gtk2? ( x11-libs/gtk+:3 )
- )"
-RDEPEND="${COMMON_DEP}"
-# Need system junit 4.8+. Bug #389795
-DEPEND="${COMMON_DEP}
- virtual/pkgconfig
- javascript? ( dev-java/rhino:1.6 )
- nsplugin? ( net-misc/npapi-sdk )
- test? ( >=dev-java/junit-4.8:4 )"
-
-pkg_setup() {
- JAVA_PKG_WANT_BUILD_VM="icedtea-${SLOT} icedtea${SLOT}"
- JAVA_PKG_WANT_SOURCE="1.6"
- JAVA_PKG_WANT_TARGET="1.6"
-
- java-vm-2_pkg_setup
- java-pkg-2_pkg_setup
-
- VMHANDLE="icedtea-${SLOT}"
-}
-
-src_prepare() {
- # bug #356645
- epatch "${FILESDIR}"/0002-Respect-LDFLAGS.patch
- eautoreconf
-}
-
-src_configure() {
- local vmhome=$(java-config -O)
-
- if use build; then
- icedteadir="${ICEDTEA_BIN_DIR}"
- [[ -z ${icedteadir} ]] && die "USE=build is an internal flag and should not be enabled"
- installdir="/opt/icedtea-web-bin-${SLOT}"
- else
- icedteadir="/usr/$(get_libdir)/icedtea${SLOT}"
- installdir="/usr/$(get_libdir)/icedtea${SLOT}-web"
- [[ "${vmhome}" == "${icedteadir}" ]] \
- || die "Unexpected install location of IcedTea ${SLOT} '${vmhome}'"
- fi
-
- einfo "Installing IcedTea-Web in '${installdir}'"
- einfo "Installing IcedTea-Web for IcedTea${SLOT} in '${icedteadir}'"
-
- local gtk_ver=3
- use gtk2 && gtk_ver=2
- use gtk3 && gtk_ver=3
-
- local myconf=(
- # we need to override all *dir variables that econf sets.
- # man page (javaws) is installed directly to icedteadir because it's
- # easier than symlinking, as we don't know the suffix the man page will
- # end up compressed with, anyway
- --prefix="${installdir}"
- --mandir="${icedteadir}"/man
- --infodir="${installdir}"/share/info
- --datadir="${installdir}"/share
- --with-jdk-home="${icedteadir}"
- --with-gtk=${gtk_ver}
- $(use_enable doc docs)
- $(use_enable nsplugin plugin)
- $(use_with javascript rhino)
- )
-
- unset JAVA_HOME JDK_HOME CLASSPATH JAVAC JAVACFLAGS
- econf "${myconf[@]}"
-}
-
-src_compile() {
- # we need this to override the src_compile from java-pkg-2
- default
-}
-
-src_install() {
- # bug #440906
- MAKEOPTS+=" -j1" default
-
- if use nsplugin; then
- install_mozilla_plugin "${installdir}/$(get_libdir)/IcedTeaPlugin.so";
- fi
-
- for binary in javaws itweb-settings; do
- dosym ${installdir}/bin/${binary} ${icedteadir}/bin/${binary}
- dosym ${installdir}/bin/${binary} ${icedteadir}/jre/bin/${binary}
- done
-}
-
-pkg_postinst() {
- java-vm_check-nsplugin
- java_mozilla_clean_
-
- if use nsplugin; then
- elog "The icedtea browser plugin (NPPlugin) can be enabled using eselect java-nsplugin"
- fi
-}
-
-pkg_prerm() {
- # override the java-vm-2 eclass check for removing a system VM, as it
- # doesn't make sense here.
- :;
-}
diff --git a/dev-java/icedtea-web/metadata.xml b/dev-java/icedtea-web/metadata.xml
index d2acb1b2f067..0f54936abfe5 100644
--- a/dev-java/icedtea-web/metadata.xml
+++ b/dev-java/icedtea-web/metadata.xml
@@ -9,7 +9,5 @@
<flag name="javascript">Enable support for using proxy auto config (PAC) files.</flag>
<flag name="icedtea7">Build icedtea-7 support in addition to icedtea-6 support. Requires icedtea{-bin}-7</flag>
<flag name="nsplugin">Enable the browser plugin (NPPlugin).</flag>
- <flag name="gtk2">Use x11-libs/gtk+:2 instead of x11-libs/gtk+:3</flag>
- <flag name="gtk3">Use x11-libs/gtk+:3 (default)</flag>
</use>
</pkgmetadata>