summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMiroslav Šulc <fordfrog@gentoo.org>2014-09-26 11:02:04 +0000
committerMiroslav Šulc <fordfrog@gentoo.org>2014-09-26 11:02:04 +0000
commita2882a1a3a32b5023ba21d021e7f20a4649c8607 (patch)
tree9eb527a09bbafb79a02267b3cb848576428db7bc /dev-java
parentFix linking on Darwin, bug #523730 (diff)
downloadgentoo-2-a2882a1a3a32b5023ba21d021e7f20a4649c8607.tar.gz
gentoo-2-a2882a1a3a32b5023ba21d021e7f20a4649c8607.tar.bz2
gentoo-2-a2882a1a3a32b5023ba21d021e7f20a4649c8607.zip
dev-java/java-sdk-docs: version bump
(Portage version: 2.2.12/cvs/Linux x86_64, signed Manifest commit with key CFE47E2F)
Diffstat (limited to 'dev-java')
-rw-r--r--dev-java/java-sdk-docs/ChangeLog8
-rw-r--r--dev-java/java-sdk-docs/java-sdk-docs-1.7.0.67.ebuild47
2 files changed, 54 insertions, 1 deletions
diff --git a/dev-java/java-sdk-docs/ChangeLog b/dev-java/java-sdk-docs/ChangeLog
index 765652a89469..6c7aa09bfe34 100644
--- a/dev-java/java-sdk-docs/ChangeLog
+++ b/dev-java/java-sdk-docs/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-java/java-sdk-docs
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-java/java-sdk-docs/ChangeLog,v 1.108 2014/09/26 10:53:22 fordfrog Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-java/java-sdk-docs/ChangeLog,v 1.109 2014/09/26 11:02:04 fordfrog Exp $
+
+*java-sdk-docs-1.7.0.67 (26 Sep 2014)
+
+ 26 Sep 2014; Miroslav Šulc <fordfrog@gentoo.org>
+ +java-sdk-docs-1.7.0.67.ebuild:
+ version bump
*java-sdk-docs-1.8.0.20 (26 Sep 2014)
diff --git a/dev-java/java-sdk-docs/java-sdk-docs-1.7.0.67.ebuild b/dev-java/java-sdk-docs/java-sdk-docs-1.7.0.67.ebuild
new file mode 100644
index 000000000000..5b18e9fb1716
--- /dev/null
+++ b/dev-java/java-sdk-docs/java-sdk-docs-1.7.0.67.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-java/java-sdk-docs/java-sdk-docs-1.7.0.67.ebuild,v 1.1 2014/09/26 11:02:04 fordfrog Exp $
+
+EAPI=5
+
+inherit versionator
+
+DOWNLOAD_URL="http://www.oracle.com/technetwork/java/javase/documentation/java-se-7-doc-download-435117.html"
+ORIG_NAME="jdk-7u$(get_version_component_range 4)-apidocs.zip"
+
+DESCRIPTION="Oracle's documentation bundle (including API) for Java SE"
+HOMEPAGE="http://download.oracle.com/javase/7/docs/"
+SRC_URI="${ORIG_NAME}"
+
+LICENSE="oracle-java-documentation-7"
+SLOT="1.7"
+KEYWORDS="~amd64 ~arm ~ppc ~ppc64 ~x86 ~amd64-linux ~x86-linux"
+IUSE=""
+
+DEPEND="app-arch/unzip"
+
+RESTRICT="fetch"
+
+S="${WORKDIR}/docs"
+
+pkg_nofetch() {
+ einfo "Please download ${ORIG_NAME} from "
+ einfo "${DOWNLOAD_URL}"
+ einfo "(agree to the license) and place it in ${DISTDIR}"
+
+ einfo "If you find the file on the download page replaced with a higher"
+ einfo "version, please report to the bug 67266 (link below)."
+ einfo "If emerge fails because of a checksum error it is possible that"
+ einfo "the upstream release changed without renaming. Try downloading the file"
+ einfo "again (or a newer revision if available). Otherwise report this to"
+ einfo "http://bugs.gentoo.org/67266 and we will make a new revision."
+}
+
+src_install(){
+ insinto /usr/share/doc/${P}/html
+ doins index.html
+
+ for i in *; do
+ [[ -d $i ]] && doins -r $i
+ done
+}