summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMiroslav Šulc <fordfrog@gentoo.org>2014-09-24 11:31:01 +0000
committerMiroslav Šulc <fordfrog@gentoo.org>2014-09-24 11:31:01 +0000
commit6c8f5857f5b250c479eee068aa0feac17dc1e4cc (patch)
tree5f30db93d7e42201651f19a82fbaaa2a48f5783e /dev-java
parentVersion bump, drop old (diff)
downloadgentoo-2-6c8f5857f5b250c479eee068aa0feac17dc1e4cc.tar.gz
gentoo-2-6c8f5857f5b250c479eee068aa0feac17dc1e4cc.tar.bz2
gentoo-2-6c8f5857f5b250c479eee068aa0feac17dc1e4cc.zip
dev-java/tomcat-native: version bump
(Portage version: 2.2.13/cvs/Linux x86_64, signed Manifest commit with key CFE47E2F)
Diffstat (limited to 'dev-java')
-rw-r--r--dev-java/tomcat-native/ChangeLog8
-rw-r--r--dev-java/tomcat-native/tomcat-native-1.1.31.ebuild47
2 files changed, 54 insertions, 1 deletions
diff --git a/dev-java/tomcat-native/ChangeLog b/dev-java/tomcat-native/ChangeLog
index 32a848f77598..b62c1f356499 100644
--- a/dev-java/tomcat-native/ChangeLog
+++ b/dev-java/tomcat-native/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-java/tomcat-native
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-java/tomcat-native/ChangeLog,v 1.48 2014/04/18 14:54:53 fordfrog Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-java/tomcat-native/ChangeLog,v 1.49 2014/09/24 11:31:01 fordfrog Exp $
+
+*tomcat-native-1.1.31 (24 Sep 2014)
+
+ 24 Sep 2014; Miroslav Šulc <fordfrog@gentoo.org>
+ +tomcat-native-1.1.31.ebuild:
+ Version bump
18 Apr 2014; Miroslav Šulc <fordfrog@gentoo.org>
-tomcat-native-1.1.23.ebuild, -tomcat-native-1.1.24.ebuild,
diff --git a/dev-java/tomcat-native/tomcat-native-1.1.31.ebuild b/dev-java/tomcat-native/tomcat-native-1.1.31.ebuild
new file mode 100644
index 000000000000..6bfe3aba4193
--- /dev/null
+++ b/dev-java/tomcat-native/tomcat-native-1.1.31.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-java/tomcat-native/tomcat-native-1.1.31.ebuild,v 1.1 2014/09/24 11:31:01 fordfrog Exp $
+
+EAPI="5"
+
+inherit base eutils java-pkg-2
+
+DESCRIPTION="Native APR library for Tomcat"
+
+SLOT="0"
+SRC_URI="mirror://apache/tomcat/tomcat-connectors/native/${PV}/source/${P}-src.tar.gz"
+HOMEPAGE="http://tomcat.apache.org/"
+KEYWORDS="~amd64 ~x86"
+LICENSE="Apache-2.0"
+IUSE=""
+
+RDEPEND="=dev-libs/apr-1*
+ dev-libs/openssl
+ >=virtual/jre-1.5"
+
+DEPEND=">=virtual/jdk-1.5
+ ${RDEPEND}"
+
+S=${WORKDIR}/${P}-src/jni/native
+
+src_configure(){
+ econf --with-apr=/usr/bin/apr-1-config \
+ --with-ssl=/usr || die "Could not configure native sources"
+}
+
+src_compile() {
+ base_src_compile
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "Could not install libtcnative-1.so"
+}
+
+pkg_postinst() {
+ elog
+ elog " APR should be available with Tomcat, for more information"
+ elog " please see http://tomcat.apache.org/tomcat-6.0-doc/apr.html"
+ elog
+ elog " Please report any bugs to http://bugs.gentoo.org/"
+ elog
+}