summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorThomas Matthijs <axxo@gentoo.org>2006-05-02 13:14:39 +0000
committerThomas Matthijs <axxo@gentoo.org>2006-05-02 13:14:39 +0000
commit4d177c71b565143b5a09aea7c201e2f71d72096e (patch)
treeaa477cf62cac1eb61538bcffccff35db1a37c9dc /dev-java
parentRC_COLDPLUG is now a pure pattern list which defaults to "*" (diff)
downloadgentoo-2-4d177c71b565143b5a09aea7c201e2f71d72096e.tar.gz
gentoo-2-4d177c71b565143b5a09aea7c201e2f71d72096e.tar.bz2
gentoo-2-4d177c71b565143b5a09aea7c201e2f71d72096e.zip
fix source zip to include the actual sources
(Portage version: 2.1_pre10-r2)
Diffstat (limited to 'dev-java')
-rw-r--r--dev-java/jdictrayapi/jdictrayapi-0.9.1.ebuild6
1 files changed, 3 insertions, 3 deletions
diff --git a/dev-java/jdictrayapi/jdictrayapi-0.9.1.ebuild b/dev-java/jdictrayapi/jdictrayapi-0.9.1.ebuild
index 6d99064746ae..95ee9199b4aa 100644
--- a/dev-java/jdictrayapi/jdictrayapi-0.9.1.ebuild
+++ b/dev-java/jdictrayapi/jdictrayapi-0.9.1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-java/jdictrayapi/jdictrayapi-0.9.1.ebuild,v 1.2 2006/04/27 13:12:37 axxo Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-java/jdictrayapi/jdictrayapi-0.9.1.ebuild,v 1.3 2006/05/02 13:14:39 axxo Exp $
inherit eutils java-pkg
@@ -29,7 +29,7 @@ src_unpack() {
cd ${S}
epatch ${FILESDIR}/0.8.7-gentoo.patch
- find -type d -name CVS -exec rm -r {} \;
+ find -type d -name CVS -exec rm -r {} \; >/dev/null 2>&1
}
src_compile() {
@@ -47,7 +47,7 @@ src_install() {
java-pkg_doso libtray.so
use doc && java-pkg_dohtml -r docs/*
- use source && java-pkg_dosrc ${S}/src/unix/*
+ use source && java-pkg_dosrc ${S}/src/share/classes/* ${S}/src/unix/classes/*
if use examples; then
dodir /usr/share/doc/${PF}/examples
cp -r ${S}/demo/* ${D}/usr/share/doc/${PF}/examples