summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMiroslav Šulc <fordfrog@gentoo.org>2008-10-22 12:31:06 +0000
committerMiroslav Šulc <fordfrog@gentoo.org>2008-10-22 12:31:06 +0000
commit123831f2f25e154760bee9a011003a99b1dcb747 (patch)
tree287c5ec7773b4a4d088af7f1cec4a643865b6a51 /dev-java
parentMigrated to EAPI-1 and restricted to dev-java/poi:0 because of incompatibilit... (diff)
downloadgentoo-2-123831f2f25e154760bee9a011003a99b1dcb747.tar.gz
gentoo-2-123831f2f25e154760bee9a011003a99b1dcb747.tar.bz2
gentoo-2-123831f2f25e154760bee9a011003a99b1dcb747.zip
Version bump. Packages depending on dev-java/poi are not compatible with this release so this release is slotted 3.2.
(Portage version: 2.2_rc12/cvs/Linux 2.6.27-gentoo x86_64)
Diffstat (limited to 'dev-java')
-rw-r--r--dev-java/poi/ChangeLog8
-rw-r--r--dev-java/poi/poi-3.2.ebuild62
2 files changed, 69 insertions, 1 deletions
diff --git a/dev-java/poi/ChangeLog b/dev-java/poi/ChangeLog
index 1c6578533af7..0bba25cba7b5 100644
--- a/dev-java/poi/ChangeLog
+++ b/dev-java/poi/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-java/poi
# Copyright 2000-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-java/poi/ChangeLog,v 1.46 2008/05/01 15:49:06 ranger Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-java/poi/ChangeLog,v 1.47 2008/10/22 12:31:06 fordfrog Exp $
+
+*poi-3.2 (22 Oct 2008)
+
+ 22 Oct 2008; Miroslav Šulc <fordfrog@gentoo.org> +poi-3.2.ebuild:
+ Version bump. Packages depending on dev-java/poi are not compatible with
+ this release so this release is slotted 3.2.
01 May 2008; Brent Baude <ranger@gentoo.org> poi-3.0.2-r1.ebuild:
stable ppc64, bug 219664
diff --git a/dev-java/poi/poi-3.2.ebuild b/dev-java/poi/poi-3.2.ebuild
new file mode 100644
index 000000000000..6561ba9eba53
--- /dev/null
+++ b/dev-java/poi/poi-3.2.ebuild
@@ -0,0 +1,62 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-java/poi/poi-3.2.ebuild,v 1.1 2008/10/22 12:31:06 fordfrog Exp $
+
+EAPI=1
+JAVA_PKG_IUSE="doc examples source"
+inherit java-pkg-2 java-ant-2
+
+DESCRIPTION="Java API To Access Microsoft Format Files"
+HOMEPAGE="http://jakarta.apache.org/poi/"
+RELEASE_DATE="20081019"
+SRC_URI="mirror://apache/poi/release/src/${PN}-src-${PV}-FINAL-${RELEASE_DATE}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="3.2"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~x86"
+IUSE="test"
+
+COMMON_DEPEND="
+ >=dev-java/commons-logging-1.1"
+RDEPEND=">=virtual/jre-1.4
+ ${COMMON_DEPEND}"
+DEPEND=">=virtual/jdk-1.4
+ ${COMMON_DEPEND}
+ test? ( dev-java/ant-junit )"
+
+S=${WORKDIR}/${P}-FINAL
+
+src_unpack() {
+ unpack ${A}
+
+ cd "${S}"
+ find -name "*.jar" | xargs rm -v
+
+ cd "${S}/lib"
+ java-pkg_jar-from commons-logging commons-logging.jar commons-logging-1.1.jar
+ use test && java-pkg_jar-from --build-only junit junit.jar junit-3.8.1.jar
+
+ java-pkg_filter-compiler jikes
+}
+
+src_compile() {
+ # the same target compiles the source and the test so we just mess with
+ # the source directory
+ eant jar $(use_doc javadocs) -Ddisconnected=true \
+ $(use !test && echo -Dmain.src.test=legal -Dscratchpad.src.test=legal)
+}
+
+src_test() {
+ ANT_TASKS="ant-junit" eant test -Ddisconnected=true
+}
+
+src_install() {
+ use doc && java-pkg_dojavadoc build/tmp/site/build/site/apidocs
+ use examples && java-pkg_doexamples src/examples/* src/scratchpad/examples/*
+ use source && java-pkg_dosrc src/contrib/src/org src/java/org src/scratchpad/src/org
+
+ cd build/dist || die "Cannot change to dist directory"
+ java-pkg_newjar poi-scratchpad-${PV}* ${PN}-scratchpad.jar
+ java-pkg_newjar poi-contrib-${PV}* ${PN}-contrib.jar
+ java-pkg_newjar poi-${PV}* ${PN}.jar
+}