summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2010-01-23 12:54:46 +0000
committerAlexis Ballier <aballier@gentoo.org>2010-01-23 12:54:46 +0000
commit66f68094c9d79efbac0e88ed4cb1817edeb3a12a (patch)
tree8ae635995b8f44615e1f9412638f1568487fc9ed /dev-java/junit
parentkeyword ~x86-fbsd and fix find call to be bsd-compatible (diff)
downloadgentoo-2-66f68094c9d79efbac0e88ed4cb1817edeb3a12a.tar.gz
gentoo-2-66f68094c9d79efbac0e88ed4cb1817edeb3a12a.tar.bz2
gentoo-2-66f68094c9d79efbac0e88ed4cb1817edeb3a12a.zip
keyword ~x86-fbsd, bug #129773 and fix find call to be bsd-compatible
(Portage version: 2.2_rc61/cvs/Linux x86_64)
Diffstat (limited to 'dev-java/junit')
-rw-r--r--dev-java/junit/ChangeLog5
-rw-r--r--dev-java/junit/junit-4.6.ebuild6
2 files changed, 7 insertions, 4 deletions
diff --git a/dev-java/junit/ChangeLog b/dev-java/junit/ChangeLog
index 259bb551ebdd..5dd936fa07e6 100644
--- a/dev-java/junit/ChangeLog
+++ b/dev-java/junit/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for dev-java/junit
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-java/junit/ChangeLog,v 1.55 2010/01/03 20:52:12 fauli Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-java/junit/ChangeLog,v 1.56 2010/01/23 12:54:46 aballier Exp $
+
+ 23 Jan 2010; Alexis Ballier <aballier@gentoo.org> junit-4.6.ebuild:
+ keyword ~x86-fbsd, bug #129773 and fix find call to be bsd-compatible
03 Jan 2010; Christian Faulhammer <fauli@gentoo.org>
junit-3.8.2-r1.ebuild, junit-4.6.ebuild:
diff --git a/dev-java/junit/junit-4.6.ebuild b/dev-java/junit/junit-4.6.ebuild
index 3c0b7d70659e..3e31548cbf80 100644
--- a/dev-java/junit/junit-4.6.ebuild
+++ b/dev-java/junit/junit-4.6.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-java/junit/junit-4.6.ebuild,v 1.5 2010/01/03 20:52:12 fauli Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-java/junit/junit-4.6.ebuild,v 1.6 2010/01/23 12:54:46 aballier Exp $
# WARNING: JUNIT.JAR IS _NOT_ SYMLINKED TO ANT-CORE LIB FOLDER AS JUNIT3 IS
@@ -14,7 +14,7 @@ SRC_URI="mirror://sourceforge/${PN}/${MY_P}.zip"
HOMEPAGE="http://www.junit.org/"
LICENSE="CPL-1.0"
SLOT="4"
-KEYWORDS="amd64 ~ia64 ppc ppc64 x86 ~x86-freebsd ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos ~sparc-solaris ~x64-solaris ~x86-solaris"
+KEYWORDS="amd64 ~ia64 ppc ppc64 x86 ~x86-fbsd ~x86-freebsd ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos ~sparc-solaris ~x64-solaris ~x86-solaris"
IUSE=""
CDEPEND="dev-java/hamcrest-core"
@@ -51,7 +51,7 @@ src_test() {
mkdir classes || die
cd junit/tests || die
local cp=$(java-pkg_getjars hamcrest-core):${S}/${PN}${PV}/${PN}-dep-${PV}.jar
- ejavac -sourcepath java -classpath ${cp} -d "${S}"/classes $(find -name "*.java")
+ ejavac -sourcepath java -classpath ${cp} -d "${S}"/classes $(find . -name "*.java")
cd "${S}"/classes || die
for FILE in $(find . -name "AllTests\.class"); do