summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2003-03-01 04:52:55 +0000
committerMike Frysinger <vapier@gentoo.org>2003-03-01 04:52:55 +0000
commit72cab9ef05387e778b9c2dd2f8ba0b5e0988fd80 (patch)
tree9f0cc009f651099e4bc53d8fda9e5d11e6cb1ee8 /dev-java/junit/junit-3.8.1.ebuild
parenttouchups (diff)
downloadgentoo-2-72cab9ef05387e778b9c2dd2f8ba0b5e0988fd80.tar.gz
gentoo-2-72cab9ef05387e778b9c2dd2f8ba0b5e0988fd80.tar.bz2
gentoo-2-72cab9ef05387e778b9c2dd2f8ba0b5e0988fd80.zip
touchups
Diffstat (limited to 'dev-java/junit/junit-3.8.1.ebuild')
-rw-r--r--dev-java/junit/junit-3.8.1.ebuild16
1 files changed, 8 insertions, 8 deletions
diff --git a/dev-java/junit/junit-3.8.1.ebuild b/dev-java/junit/junit-3.8.1.ebuild
index 3d5921a204e3..f1d6db36bbfc 100644
--- a/dev-java/junit/junit-3.8.1.ebuild
+++ b/dev-java/junit/junit-3.8.1.ebuild
@@ -1,20 +1,21 @@
# Copyright 1999-2003 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-java/junit/junit-3.8.1.ebuild,v 1.4 2003/02/13 10:12:19 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-java/junit/junit-3.8.1.ebuild,v 1.5 2003/03/01 04:52:11 vapier Exp $
NP=${P/-/}
S=${WORKDIR}/${NP}
DESCRIPTION="JUnit is a simple framework to write repeatable tests."
SRC_URI="http://download.sourceforge.net/junit/${NP}.zip"
HOMEPAGE="http://www.junit.org/"
+
+LICENSE="CPL-1.0"
+SLOT="0"
+KEYWORDS="~x86"
+
DEPEND=">=virtual/jdk-1.3
>=dev-java/ant-1.4
>=app-arch/unzip-5.50-r1"
RDEPEND=">=virtual/jdk-1.3"
-LICENSE="CPL-1.0"
-SLOT="0"
-KEYWORDS="~x86"
-IUSE=""
src_unpack() {
unpack ${A}
@@ -24,14 +25,13 @@ src_unpack() {
src_compile() {
rm junit.jar
- ant
+ ant || die
}
-src_install () {
+src_install() {
cd ${NP}
dojar junit.jar
dodir /usr/share/ant/lib
dosym /usr/share/junit/lib/junit.jar /usr/share/ant/lib/
dohtml -r README.html cpl-v10.html doc javadoc
}
-