summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJan Brinkmann <luckyduck@gentoo.org>2005-04-16 21:41:32 +0000
committerJan Brinkmann <luckyduck@gentoo.org>2005-04-16 21:41:32 +0000
commit776bd44e7eb77a7dc601cb2d019634efb4ef857e (patch)
tree4e49c6b21047a237af5957a1d84c1f1957a972aa /dev-java/javolution/javolution-2.2.4.ebuild
parentdocs go in /usr/share/doc/${PF} (diff)
downloadgentoo-2-776bd44e7eb77a7dc601cb2d019634efb4ef857e.tar.gz
gentoo-2-776bd44e7eb77a7dc601cb2d019634efb4ef857e.tar.bz2
gentoo-2-776bd44e7eb77a7dc601cb2d019634efb4ef857e.zip
new upstream version. marked 2.2.0 stable on amd64 and x86. done some cosmetic changes and introduced support for the source useflag.
(Portage version: 2.0.51.19)
Diffstat (limited to 'dev-java/javolution/javolution-2.2.4.ebuild')
-rw-r--r--dev-java/javolution/javolution-2.2.4.ebuild36
1 files changed, 36 insertions, 0 deletions
diff --git a/dev-java/javolution/javolution-2.2.4.ebuild b/dev-java/javolution/javolution-2.2.4.ebuild
new file mode 100644
index 000000000000..3ca311b4722a
--- /dev/null
+++ b/dev-java/javolution/javolution-2.2.4.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-java/javolution/javolution-2.2.4.ebuild,v 1.1 2005/04/16 21:41:32 luckyduck Exp $
+
+inherit eutils java-pkg
+
+DESCRIPTION="Java Solution for Real-Time and Embedded Systems"
+SRC_URI="http://javolution.org/${P}-src.zip"
+HOMEPAGE="http://javolution.org"
+LICENSE="LGPL-2.1"
+SLOT="2.2.4"
+KEYWORDS="~x86 ~amd64"
+IUSE="doc source"
+DEPEND=">=virtual/jdk-1.4
+ >=dev-java/ant-core-1.4
+ app-arch/unzip
+ source? ( app-arch/zip )"
+ #jikes?( >=dev-java/jikes-1.21 )"
+RDEPEND=">=virtual/jdk-1.4"
+
+S=${WORKDIR}/javolution-${PV%.*}
+
+src_compile() {
+ antflags="init_1.4 compile jar"
+ use doc && antflags="${antflags} doc"
+ # disabled jikes for now till i've the time to write an patch for this
+ #use jikes && antflags="${antflags} -Dbuild.compiler=jikes"
+ ant ${antflags} || die "ant build failed"
+}
+
+src_install() {
+ java-pkg_dojar javolution.jar
+ dodoc doc/coding_standard.txt
+ use doc && java-pkg_dohtml -r index.html api/*
+ use source && java-pkg_dosrc ${S}/src/javolution
+}