summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlistair Bush <ali_bush@gentoo.org>2008-01-29 07:28:48 +0000
committerAlistair Bush <ali_bush@gentoo.org>2008-01-29 07:28:48 +0000
commita6e424da44debd30687d6ad61c720ecfe1b698ac (patch)
tree78ba047594af48511abf707382427be217440eaf /dev-java/java-config
parentremove unused license (diff)
downloadgentoo-2-a6e424da44debd30687d6ad61c720ecfe1b698ac.tar.gz
gentoo-2-a6e424da44debd30687d6ad61c720ecfe1b698ac.tar.bz2
gentoo-2-a6e424da44debd30687d6ad61c720ecfe1b698ac.zip
Version Bump.
(Portage version: 2.1.4)
Diffstat (limited to 'dev-java/java-config')
-rw-r--r--dev-java/java-config/files/digest-java-config-2.1.43
-rw-r--r--dev-java/java-config/java-config-2.1.4.ebuild47
2 files changed, 50 insertions, 0 deletions
diff --git a/dev-java/java-config/files/digest-java-config-2.1.4 b/dev-java/java-config/files/digest-java-config-2.1.4
new file mode 100644
index 000000000000..9b51df454f17
--- /dev/null
+++ b/dev-java/java-config/files/digest-java-config-2.1.4
@@ -0,0 +1,3 @@
+MD5 a4d37faf810cfc0e6b83563454e03757 java-config-2.1.4.tar.bz2 41558
+RMD160 3b8533ecabc7eaf729e3a46009dcfe96b10f57ae java-config-2.1.4.tar.bz2 41558
+SHA256 e5dc436cb1927989769097941af8758e7070fc5c1e984d7b421bebcf0e816509 java-config-2.1.4.tar.bz2 41558
diff --git a/dev-java/java-config/java-config-2.1.4.ebuild b/dev-java/java-config/java-config-2.1.4.ebuild
new file mode 100644
index 000000000000..c86b6594e7d0
--- /dev/null
+++ b/dev-java/java-config/java-config-2.1.4.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-java/java-config/java-config-2.1.4.ebuild,v 1.1 2008/01/29 07:28:47 ali_bush Exp $
+
+inherit distutils eutils
+
+DESCRIPTION="Java environment configuration tool"
+HOMEPAGE="http://www.gentoo.org/proj/en/java/"
+SRC_URI="mirror://gentoo/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="2"
+KEYWORDS="~amd64 ~arm ~ia64 ~ppc ~ppc64 ~x86 ~x86-fbsd"
+IUSE=""
+
+DEPEND="dev-lang/python"
+RDEPEND="${DEPEND}
+ >=dev-java/java-config-wrapper-0.15"
+
+PYTHON_MODNAME="java_config_2"
+
+src_install() {
+ distutils_src_install
+
+ insinto /usr/share/java-config-2/config/
+ newins config/jdk-defaults-${ARCH}.conf jdk-defaults.conf || die "arch config not found"
+}
+
+pkg_postrm() {
+ distutils_python_version
+ distutils_pkg_postrm
+}
+
+pkg_postinst() {
+ distutils_pkg_postinst
+
+ elog "The way Java is handled on Gentoo has been recently updated."
+ elog "If you have not done so already, you should follow the"
+ elog "instructions available at:"
+ elog "\thttp://www.gentoo.org/proj/en/java/java-upgrade.xml"
+ elog
+ elog "While we are moving towards the new Java system, we only allow"
+ elog "1.3 or 1.4 JDKs to be used with java-config-1 to ensure"
+ elog "backwards compatibility with the old system."
+ elog "For more details about this, please see:"
+ elog "\thttp://www.gentoo.org/proj/en/java/why-we-need-java-14.xml"
+}