summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlistair Bush <ali_bush@gentoo.org>2007-11-28 09:33:35 +0000
committerAlistair Bush <ali_bush@gentoo.org>2007-11-28 09:33:35 +0000
commit222c41ba48f9a55ec37b1722c68dc8a40b07c2e8 (patch)
tree9edda8047edbad1619726a810ae1525af1ca2944 /dev-java/java-config/java-config-2.1.3.ebuild
parentBump java-config-wrapper to support java-virtuals. (diff)
downloadgentoo-2-222c41ba48f9a55ec37b1722c68dc8a40b07c2e8.tar.gz
gentoo-2-222c41ba48f9a55ec37b1722c68dc8a40b07c2e8.tar.bz2
gentoo-2-222c41ba48f9a55ec37b1722c68dc8a40b07c2e8.zip
Version bump java-config.
(Portage version: 2.1.4_rc3)
Diffstat (limited to 'dev-java/java-config/java-config-2.1.3.ebuild')
-rw-r--r--dev-java/java-config/java-config-2.1.3.ebuild47
1 files changed, 47 insertions, 0 deletions
diff --git a/dev-java/java-config/java-config-2.1.3.ebuild b/dev-java/java-config/java-config-2.1.3.ebuild
new file mode 100644
index 000000000000..b1eee1af5a88
--- /dev/null
+++ b/dev-java/java-config/java-config-2.1.3.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-java/java-config/java-config-2.1.3.ebuild,v 1.1 2007/11/28 09:33:34 ali_bush Exp $
+
+inherit distutils eutils
+
+DESCRIPTION="Java environment configuration tool"
+HOMEPAGE="http://www.gentoo.org/proj/en/java/"
+SRC_URI="mirror://gentoo/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="2"
+KEYWORDS="~amd64 ~arm ~ia64 ~ppc ~ppc64 ~x86 ~x86-fbsd"
+IUSE=""
+
+DEPEND="dev-lang/python"
+RDEPEND="${DEPEND}
+ >=dev-java/java-config-wrapper-0.15"
+
+PYTHON_MODNAME="java_config_2"
+
+src_install() {
+ distutils_src_install
+
+ insinto /usr/share/java-config-2/config/
+ newins config/jdk-defaults-${ARCH}.conf jdk-defaults.conf || die "arch config not found"
+}
+
+pkg_postrm() {
+ distutils_python_version
+ distutils_pkg_postrm
+}
+
+pkg_postinst() {
+ distutils_pkg_postinst
+
+ elog "The way Java is handled on Gentoo has been recently updated."
+ elog "If you have not done so already, you should follow the"
+ elog "instructions available at:"
+ elog "\thttp://www.gentoo.org/proj/en/java/java-upgrade.xml"
+ elog
+ elog "While we are moving towards the new Java system, we only allow"
+ elog "1.3 or 1.4 JDKs to be used with java-config-1 to ensure"
+ elog "backwards compatibility with the old system."
+ elog "For more details about this, please see:"
+ elog "\thttp://www.gentoo.org/proj/en/java/why-we-need-java-14.xml"
+}