summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJames Le Cuirot <chewi@gentoo.org>2015-06-20 13:45:07 +0000
committerJames Le Cuirot <chewi@gentoo.org>2015-06-20 13:45:07 +0000
commitf2b7b2fa2c251faaa755321fdf99699c97ce79c3 (patch)
tree80a409a5d9515555fe5374810aea51e90bfd226b /dev-java/icedtea/icedtea-7.2.5.5.ebuild
parent~ppc64 keyword. Remove unused older version. (diff)
downloadgentoo-2-f2b7b2fa2c251faaa755321fdf99699c97ce79c3.tar.gz
gentoo-2-f2b7b2fa2c251faaa755321fdf99699c97ce79c3.tar.bz2
gentoo-2-f2b7b2fa2c251faaa755321fdf99699c97ce79c3.zip
Remove redundant --with-ecj-jar code as javac from gcj-jdk always
takes precedence. Remove redundant bootstrap_impossible code as this is no longer relevant. Remove references to the old VM handles as the dependencies will ensure that the new ones are always present anyway. (Portage version: 2.2.20/cvs/Linux x86_64, signed Manifest commit with key 9C6D7DE4)
Diffstat (limited to 'dev-java/icedtea/icedtea-7.2.5.5.ebuild')
-rw-r--r--dev-java/icedtea/icedtea-7.2.5.5.ebuild24
1 files changed, 8 insertions, 16 deletions
diff --git a/dev-java/icedtea/icedtea-7.2.5.5.ebuild b/dev-java/icedtea/icedtea-7.2.5.5.ebuild
index d65d1a199e50..26e30e2508a9 100644
--- a/dev-java/icedtea/icedtea-7.2.5.5.ebuild
+++ b/dev-java/icedtea/icedtea-7.2.5.5.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2015 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-java/icedtea/icedtea-7.2.5.5.ebuild,v 1.4 2015/05/23 23:05:43 chewi Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-java/icedtea/icedtea-7.2.5.5.ebuild,v 1.5 2015/06/20 13:45:07 chewi Exp $
# Build written by Andrew John Hughes (gnu_andrew@member.fsf.org)
# *********************************************************
@@ -179,7 +179,7 @@ pkg_setup() {
icedtea_check_requirements
JAVA_PKG_WANT_BUILD_VM="
- icedtea-7 icedtea-bin-7 icedtea7
+ icedtea-7 icedtea-bin-7
gcj-jdk"
JAVA_PKG_WANT_SOURCE="1.5"
JAVA_PKG_WANT_TARGET="1.5"
@@ -204,25 +204,17 @@ java_prepare() {
}
src_configure() {
- local bootstrap cacao_config config hotspot_port hs_tarball use_cacao use_zero zero_config
+ local cacao_config config hotspot_port hs_tarball use_cacao use_zero zero_config
local vm=$(java-pkg_get-current-vm)
- # Whether to bootstrap
- bootstrap="disable"
- if use jbootstrap; then
- bootstrap="enable"
- fi
-
- if has "${vm}" gcj-jdk; then
- # gcj-jdk ensures ecj is present.
+ # gcj-jdk ensures ecj is present.
+ if use jbootstrap || has "${vm}" gcj-jdk; then
use jbootstrap || einfo "bootstrap is necessary when building with ${vm}, ignoring USE=\"-jbootstrap\""
- bootstrap="enable"
- local ecj_jar="$(readlink "${EPREFIX}"/usr/share/eclipse-ecj/ecj.jar)"
- config+=" --with-ecj-jar=${ecj_jar}"
+ config+=" --enable-bootstrap"
+ else
+ config+=" --disable-bootstrap"
fi
- config+=" --${bootstrap}-bootstrap"
-
# Use Zero if requested
if use zero; then
use_zero="yes"