summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorVlastimil Babka <caster@gentoo.org>2011-03-29 09:13:40 +0000
committerVlastimil Babka <caster@gentoo.org>2011-03-29 09:13:40 +0000
commita40bdfd22c2c6bfef5ae3a498e70749f230010a0 (patch)
tree8e90e5f145f8d52d7b81a90e4a9db59eca9e61a8 /dev-java/gnu-classpath
parentSlot GTK+ deps. (diff)
downloadgentoo-2-a40bdfd22c2c6bfef5ae3a498e70749f230010a0.tar.gz
gentoo-2-a40bdfd22c2c6bfef5ae3a498e70749f230010a0.tar.bz2
gentoo-2-a40bdfd22c2c6bfef5ae3a498e70749f230010a0.zip
Slot GTK+ deps.
(Portage version: 2.2.0_alpha29/cvs/Linux x86_64)
Diffstat (limited to 'dev-java/gnu-classpath')
-rw-r--r--dev-java/gnu-classpath/ChangeLog8
-rw-r--r--dev-java/gnu-classpath/gnu-classpath-0.98-r2.ebuild110
-rw-r--r--dev-java/gnu-classpath/gnu-classpath-0.98-r3.ebuild8
3 files changed, 10 insertions, 116 deletions
diff --git a/dev-java/gnu-classpath/ChangeLog b/dev-java/gnu-classpath/ChangeLog
index 88b8a0c15a9d..33b9abfae3ae 100644
--- a/dev-java/gnu-classpath/ChangeLog
+++ b/dev-java/gnu-classpath/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for dev-java/gnu-classpath
-# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-java/gnu-classpath/ChangeLog,v 1.115 2010/11/06 17:17:53 halcy0n Exp $
+# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-java/gnu-classpath/ChangeLog,v 1.116 2011/03/29 09:13:40 caster Exp $
+
+ 29 Mar 2011; Vlastimil Babka <caster@gentoo.org>
+ -gnu-classpath-0.98-r2.ebuild, gnu-classpath-0.98-r3.ebuild:
+ Slot GTK+ deps.
06 Nov 2010; Mark Loeser <halcy0n@gentoo.org>
gnu-classpath-0.98-r3.ebuild:
diff --git a/dev-java/gnu-classpath/gnu-classpath-0.98-r2.ebuild b/dev-java/gnu-classpath/gnu-classpath-0.98-r2.ebuild
deleted file mode 100644
index 9abf40631c90..000000000000
--- a/dev-java/gnu-classpath/gnu-classpath-0.98-r2.ebuild
+++ /dev/null
@@ -1,110 +0,0 @@
-# Copyright 1999-2010 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-java/gnu-classpath/gnu-classpath-0.98-r2.ebuild,v 1.7 2010/05/22 15:38:36 pacho Exp $
-
-EAPI=2
-
-inherit eutils java-pkg-2 base multilib
-
-MY_P=${P/gnu-/}
-DESCRIPTION="Free core class libraries for use with virtual machines and compilers for the Java language"
-SRC_URI="mirror://gnu/classpath/${MY_P}.tar.gz"
-HOMEPAGE="http://www.gnu.org/software/classpath"
-
-LICENSE="GPL-2-with-linking-exception"
-SLOT="0.98"
-KEYWORDS="amd64 ppc ppc64 x86"
-
-IUSE="alsa debug doc dssi examples gconf gjdoc gmp gtk gstreamer qt4 xml"
-
-RDEPEND="alsa? ( media-libs/alsa-lib )
- doc? ( >=dev-java/gjdoc-0.7.9-r2 )
- dssi? ( >=media-libs/dssi-0.9 )
- gconf? ( gnome-base/gconf )
- gjdoc? ( >=dev-java/antlr-2.7.1:0 )
- gmp? ( >=dev-libs/gmp-4.2.4 )
- gstreamer? (
- >=media-libs/gstreamer-0.10.10
- >=media-libs/gst-plugins-base-0.10.10
- x11-libs/gtk+
- )
- gtk? (
- >=x11-libs/gtk+-2.8
- >=dev-libs/glib-2.0
- media-libs/freetype
- >=x11-libs/cairo-1.1.9
- x11-libs/libICE
- x11-libs/libSM
- x11-libs/libX11
- x11-libs/libXrandr
- x11-libs/libXrender
- x11-libs/libXtst
- x11-libs/pango
- )
- qt4? ( x11-libs/qt-gui:4 )
- xml? ( >=dev-libs/libxml2-2.6.8 >=dev-libs/libxslt-1.1.11 )
- dev-java/eclipse-ecj:3.3"
-
-# We should make the build not pickup the wrong antlr binary from pccts
-DEPEND="app-arch/zip
- gjdoc? ( !!dev-util/pccts )
- gtk? (
- x11-libs/libXrender
- || ( >=x11-libs/libXtst-1.1.0 <x11-proto/xextproto-7.1 )
- x11-proto/xproto
- )
- >=virtual/jdk-1.5
- ${RDEPEND}"
-
-RDEPEND=">=virtual/jre-1.5
- ${RDEPEND}"
-
-S=${WORKDIR}/${MY_P}
-
-src_configure() {
- # We require ecj anyway, so force it to avoid problems with bad versions of javac
- export JAVAC="/usr/bin/ecj-3.3"
- export JAVA="/usr/bin/java"
- # build takes care of them itself, duplicate -source -target kills ecj
- export JAVACFLAGS="-nowarn"
- # build system is passing -J-Xmx768M which ecj however ignores
- # this will make the ecj launcher do it (seen case where default was not enough heap)
- export gjl_java_args="-Xmx768M"
-
- # don't use econf, because it ends up putting things under /usr, which may
- # collide with other slots of classpath
- local myconf
- if use gjdoc; then
- local antlr=$(java-pkg_getjar antlr antlr.jar)
- myconf="--with-antlr-jar=${antlr}"
- fi
-
- ANTLR= ./configure \
- $(use_enable alsa) \
- $(use_enable debug ) \
- $(use_enable examples) \
- $(use_enable gconf gconf-peer) \
- $(use_enable gjdoc) \
- $(use_enable gmp) \
- $(use_enable gtk gtk-peer) \
- $(use_enable gstreamer gstreamer-peer) \
- $(use_enable qt4 qt-peer) \
- $(use_enable xml xmlj) \
- $(use_enable dssi ) \
- $(use_with doc gjdoc) \
- --enable-jni \
- --disable-dependency-tracking \
- --disable-plugin \
- --host=${CHOST} \
- --prefix=/usr/${PN}-${SLOT} \
- --with-ecj-jar=$(java-pkg_getjar eclipse-ecj-3.3 ecj.jar) \
- --disable-Werror \
- ${myconf} \
- || die "configure failed"
-}
-
-src_install() {
- emake DESTDIR="${D}" install || die "emake install failed"
- dodoc AUTHORS BUGS ChangeLog* HACKING NEWS README THANKYOU TODO || die
- java-pkg_regjar /usr/${P}/share/classpath/glibj.zip
-}
diff --git a/dev-java/gnu-classpath/gnu-classpath-0.98-r3.ebuild b/dev-java/gnu-classpath/gnu-classpath-0.98-r3.ebuild
index a77af77fc35d..e41e5d9ce92a 100644
--- a/dev-java/gnu-classpath/gnu-classpath-0.98-r3.ebuild
+++ b/dev-java/gnu-classpath/gnu-classpath-0.98-r3.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2010 Gentoo Foundation
+# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-java/gnu-classpath/gnu-classpath-0.98-r3.ebuild,v 1.5 2010/11/06 17:17:53 halcy0n Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-java/gnu-classpath/gnu-classpath-0.98-r3.ebuild,v 1.6 2011/03/29 09:13:40 caster Exp $
EAPI=2
@@ -26,10 +26,10 @@ RDEPEND="alsa? ( media-libs/alsa-lib )
gstreamer? (
>=media-libs/gstreamer-0.10.10
>=media-libs/gst-plugins-base-0.10.10
- x11-libs/gtk+
+ x11-libs/gtk+:2
)
gtk? (
- >=x11-libs/gtk+-2.8
+ >=x11-libs/gtk+-2.8:2
>=dev-libs/glib-2.0
media-libs/freetype
>=x11-libs/cairo-1.1.9