summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJoshua Nichols <nichoj@gentoo.org>2006-11-19 19:40:51 +0000
committerJoshua Nichols <nichoj@gentoo.org>2006-11-19 19:40:51 +0000
commit87af257e653876415c15d750f91e26927f3d5608 (patch)
treeed0d02e415c46bd5bab4ac4cff94bc2c25d2c2a5 /dev-java/gnu-classpath
parentFixing D-Bus dependancies (diff)
downloadgentoo-2-87af257e653876415c15d750f91e26927f3d5608.tar.gz
gentoo-2-87af257e653876415c15d750f91e26927f3d5608.tar.bz2
gentoo-2-87af257e653876415c15d750f91e26927f3d5608.zip
Version bump, bug #133875. Now is slotted, so VMs can use the appropriate version they are compatible with.
(Portage version: 2.1.2_rc1-r5)
Diffstat (limited to 'dev-java/gnu-classpath')
-rw-r--r--dev-java/gnu-classpath/ChangeLog9
-rw-r--r--dev-java/gnu-classpath/files/digest-gnu-classpath-0.923
-rw-r--r--dev-java/gnu-classpath/gnu-classpath-0.92.ebuild94
3 files changed, 105 insertions, 1 deletions
diff --git a/dev-java/gnu-classpath/ChangeLog b/dev-java/gnu-classpath/ChangeLog
index 749744887ca3..d5b39ffbdf1f 100644
--- a/dev-java/gnu-classpath/ChangeLog
+++ b/dev-java/gnu-classpath/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for dev-java/gnu-classpath
# Copyright 2000-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-java/gnu-classpath/ChangeLog,v 1.65 2006/10/06 18:13:03 caster Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-java/gnu-classpath/ChangeLog,v 1.66 2006/11/19 19:40:51 nichoj Exp $
+
+*gnu-classpath-0.92 (19 Nov 2006)
+
+ 19 Nov 2006; Joshua Nichols <nichoj@gentoo.org>
+ +gnu-classpath-0.92.ebuild:
+ Version bump, bug #133875. Now is slotted, so VMs can use the appropriate
+ version they are compatible with.
06 Oct 2006; Vlastimil Babka <caster@gentoo.org>
gnu-classpath-0.90.ebuild:
diff --git a/dev-java/gnu-classpath/files/digest-gnu-classpath-0.92 b/dev-java/gnu-classpath/files/digest-gnu-classpath-0.92
new file mode 100644
index 000000000000..3b09e22bcaae
--- /dev/null
+++ b/dev-java/gnu-classpath/files/digest-gnu-classpath-0.92
@@ -0,0 +1,3 @@
+MD5 4603ef3e593713d94788b919bc0b6c75 classpath-0.92.tar.gz 9161101
+RMD160 aba37c221768a6152ebb4440059199414e396668 classpath-0.92.tar.gz 9161101
+SHA256 8bc678263b40635623995826a3c1f0ea177dba9cc29bfe6572cc8acdb182b0d0 classpath-0.92.tar.gz 9161101
diff --git a/dev-java/gnu-classpath/gnu-classpath-0.92.ebuild b/dev-java/gnu-classpath/gnu-classpath-0.92.ebuild
new file mode 100644
index 000000000000..a9f4b2e6845f
--- /dev/null
+++ b/dev-java/gnu-classpath/gnu-classpath-0.92.ebuild
@@ -0,0 +1,94 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-java/gnu-classpath/gnu-classpath-0.92.ebuild,v 1.1 2006/11/19 19:40:51 nichoj Exp $
+
+inherit eutils multilib
+
+MY_P=${P/gnu-/}
+DESCRIPTION="Free core class libraries for use with virtual machines and compilers for the Java programming language"
+SRC_URI="mirror://gnu/classpath/${MY_P}.tar.gz"
+HOMEPAGE="http://www.gnu.org/software/classpath"
+
+LICENSE="GPL-2-with-linking-exception"
+SLOT="0.92"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~x86"
+
+# Add the doc use flag after the upstream build system is improved
+# See their bug 24025
+
+IUSE="alsa cairo debug dssi examples gtk xml"
+
+RDEPEND="alsa? ( media-libs/alsa-lib )
+ dssi? ( >=media-libs/dssi-0.9 )
+ gtk? ( >=x11-libs/gtk+-2.4
+ >=dev-libs/glib-2.0
+ || ( (
+ x11-libs/libICE
+ x11-libs/libSM
+ x11-libs/libX11
+ x11-libs/libXtst
+ )
+ virtual/x11
+ )
+ cairo? ( >=x11-libs/cairo-0.5.0 )
+ )
+ xml? ( >=dev-libs/libxml2-2.6.8 >=dev-libs/libxslt-1.1.11 )"
+
+DEPEND="app-arch/zip
+ dev-java/jikes
+ gtk? ( || ( (
+ x11-libs/libXrender
+ x11-proto/xextproto
+ x11-proto/xproto
+ )
+ virtual/x11
+ )
+ )
+ ${REPEND}"
+
+S=${WORKDIR}/${MY_P}
+
+src_compile() {
+ unset CLASSPATH JAVA_HOME
+ # We want to force use of jikes, because it is the only way to build
+ # classpath without requiring some sort of Java already available, ie ecj
+ # requires a runtime and gcj already has a bundled version.
+ local compiler="--with-jikes"
+
+ # Now this detects fastjar automatically and some people have broken
+ # wrappers in /usr/bin by eselect-compiler. Unfortunately
+ # --without-fastjar does not seem to work.
+ # http://bugs.gentoo.org/show_bug.cgi?id=135688
+
+ # don't use econf, because it ends up putting things under /usr, which may
+ # collide with other slots of classpath
+ ./configure ${compiler} \
+ $(use_enable alsa) \
+ $(use_enable cairo gtk-cairo) \
+ $(use_enable debug ) \
+ $(use_enable examples) \
+ $(use_enable gtk gtk-peer) \
+ $(use_enable xml xmlj) \
+ $(use_enable dssi ) \
+ --enable-jni \
+ --disable-dependency-tracking \
+ --prefix=/opt/${PN}-${SLOT} \
+ || die "configure failed"
+ # disabled for now... see above.
+ # $(use_with doc gjdoc) \
+
+ emake || die "make failed"
+}
+
+src_install() {
+ emake DESTDIR=${D} install || die "einstall failed"
+ dodoc AUTHORS BUGS ChangeLog* HACKING NEWS README THANKYOU TODO
+}
+
+pkg_postinst() {
+ if use gtk && use cairo; then
+ einfo "GNU Classpath was compiled with preliminary cairo support."
+ einfo "To use that functionality set the system property"
+ einfo "gnu.java.awt.peer.gtk.Graphics to Graphics2D at runtime."
+ fi
+}