summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDylan Carlson <absinthe@gentoo.org>2003-03-22 12:36:06 +0000
committerDylan Carlson <absinthe@gentoo.org>2003-03-22 12:36:06 +0000
commit2a804ceace7e552f11bd34f3585d5efc4c108435 (patch)
treeb208664a66d30b2284c6ddccf04dc52bd92e1bd5 /dev-java/commons-pool
parentInitial import. Keywords ~x86. (diff)
downloadgentoo-2-2a804ceace7e552f11bd34f3585d5efc4c108435.tar.gz
gentoo-2-2a804ceace7e552f11bd34f3585d5efc4c108435.tar.bz2
gentoo-2-2a804ceace7e552f11bd34f3585d5efc4c108435.zip
Changed to use jakarta-commons eclass; 'doc' USE flag. Keywords ~x86.
Diffstat (limited to 'dev-java/commons-pool')
-rw-r--r--dev-java/commons-pool/ChangeLog8
-rw-r--r--dev-java/commons-pool/commons-pool-1.0.1-r3.ebuild29
-rw-r--r--dev-java/commons-pool/files/digest-commons-pool-1.0.1-r31
3 files changed, 37 insertions, 1 deletions
diff --git a/dev-java/commons-pool/ChangeLog b/dev-java/commons-pool/ChangeLog
index 1bcf147a0562..4849a14fb7a8 100644
--- a/dev-java/commons-pool/ChangeLog
+++ b/dev-java/commons-pool/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-java/commons-pool
# Copyright 2002-2003 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-java/commons-pool/ChangeLog,v 1.6 2003/02/12 05:51:13 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-java/commons-pool/ChangeLog,v 1.7 2003/03/22 12:36:06 absinthe Exp $
+
+*commons-pool-1.0.1-r3 (22 Mar 2003)
+
+ 22 Mar 2003; Dylan Carlson <absinthe@gentoo.org>
+ commons-pool-1.0.1-r3.ebuild:
+ Changed to use jakarta-commons eclass.
*commons-pool-1.0.1-r2 (02 Nov 2002)
diff --git a/dev-java/commons-pool/commons-pool-1.0.1-r3.ebuild b/dev-java/commons-pool/commons-pool-1.0.1-r3.ebuild
new file mode 100644
index 000000000000..a5e3c0a31a9d
--- /dev/null
+++ b/dev-java/commons-pool/commons-pool-1.0.1-r3.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-java/commons-pool/commons-pool-1.0.1-r3.ebuild,v 1.1 2003/03/22 12:36:06 absinthe Exp $
+
+inherit jakarta-commons
+
+S=${WORKDIR}/${PN}-${PV}-src
+DESCRIPTION="Jakarta-Commons component providing general purpose object pooling API"
+HOMEPAGE="http://jakarta.apache.org/commons/pool.html"
+SRC_URI="http://jakarta.apache.org/builds/jakarta-commons/release/${PN}/v${PV}/${PN}-${PV}-src.tar.gz"
+DEPEND=">=virtual/jdk-1.3
+ >=dev-java/ant-1.4
+ >=dev-java/commons-collections-2.0
+ junit? ( >=junit-3.7 )"
+RDEPEND=">=virtual/jre-1.3
+ >=dev-java/commons-collections-2.0"
+LICENSE="Apache-1.1"
+SLOT="0"
+KEYWORDS="~x86"
+IUSE="doc jikes junit"
+
+src_compile() {
+ echo "commons-collections.jar=`java-config --classpath=commons-collections`" >> build.properties
+ jakarta-commons_src_compile myconf make
+ jakarta-commons_src_install dojar
+ use doc && jakarta-commons_src_compile makedoc
+ use doc && jakarta-commons_src_install html
+}
+
diff --git a/dev-java/commons-pool/files/digest-commons-pool-1.0.1-r3 b/dev-java/commons-pool/files/digest-commons-pool-1.0.1-r3
new file mode 100644
index 000000000000..0532b13e26a7
--- /dev/null
+++ b/dev-java/commons-pool/files/digest-commons-pool-1.0.1-r3
@@ -0,0 +1 @@
+MD5 df9aaf5ee3e5d68abbee6eca0b8d037f commons-pool-1.0.1-src.tar.gz 62093